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EMDS for ADS Basics

Electromagnetic Design System (EMDS) for Advanced Design System (ADS) is a complete solution for electromagnetic
simulation of arbitrarily-shaped, passive three-dimensional structures. EMDS for ADS makes full 3D EM simulation an
attractive option for designers working with RF circuits, MMICs, PC boards, modules, and Signal Integrity applications.
It provides the best price/performance, 3D EM simulator on the market, with a full 3D electromagnetic field solver,
and fully automated meshing and convergence capabilities for modeling arbitrary 3D shapes such as bond wires and
finite dielectric substrates.

EMDS in now integrated into ADS. Along with Momentum, this provides RF and microwave engineers access to some
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of the most comprehensive EM simulation tools in the industry. If you are unfamiliar with Advanced Design System,
refer to the Drawing Tips.

Developed with the designer of high-frequency/high-speed circuits in mind, EMDS for ADS offers a powerful
finite-element EM simulator that solves a wide array of applications with impressive accuracy and speed.

By combining fast solution times, efficient memory usage, and powerful display capabilities, EMDS for ADS delivers
leading price/performance solution to complex high-frequency problems. EMDS for ADS users need very little
background in electromagnetic field theory in order to operate and achieve accurate, meaningful solutions.

Major Features and Benefits

EMDS for ADS comes with a list of impressive features. These key technological enablers demonstrate the advantages
of full 3D EM design and verification which include:

e Conductors, resistors, isotropic dielectrics, isotropic linear magnetic material modeling that allow a wide range of
application coverage.

e An unlimited number of ports, which enables simulating multi-I/O design applications such as packages.

¢ Electric and magnetic fields modeling, enabling visualization of EM fields in a design.

e Absorbing boundary condition (free space), enabling antenna modeling.

e Full-wave, EM-accuracy for first-pass design success.

e Antenna parameters (gain, directivity, polarization, and so on), to enable better insight into antenna design.

e EMDS/ADS integration providing an integrated approach to EM/Circuit design.

Application Areas

EM modeling tools are known for their great accuracy. EMDS for ADS redefines this term with broad application
coverage, including the following:
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e Microstrip, stripline, CPW elements (filters, couplers, spiral inductors, via holes, air bridges, meander lines...)
e Multilayer structures

e Ceramic filters

e Adapters/transitions

e Antennas

e Couplers

e Power splitters/combiners

Visualization and Display of Results

The visualization and animation capabilities in EMDS for ADS enable you to evaluate simulation results thoroughly.

To aid in analyzing your designs, EM field animation and dynamic rotation of structures can be performed
simultaneously. Choose from shaded plots, contour lines, or vectors. 3D far-field plots illustrate beam shapes in both
azimuth and elevation on a single plot. To aid in analyzing your designs, EM field animation and dynamic rotation of
structures can be performed simultaneously. Choose from shaded plots, contour lines, or vectors. 3D far-field plots
illustrate beam shapes in both azimuth and elevation on a single plot.

EMDS for ADS Overview

EMDS for ADS commands are available from the Layout window. The following steps describe a typical process for
creating and simulating a design with EMDS for ADS:

1. Create a physical design. You start with the physical dimensions of a planar design, such as a patch antenna or
the traces on a multilayer printed circuit board. There are three ways to enter a design into Advanced Design
System:

e Convert a schematic into a physical layout

e Draw the design using Layout

¢ Import a layout from another simulator or design system. Advanced Design System can import files in a
variety of formats.
For information on converting schematics or drawing in Layout, refer the Schematic Capture and Layout
documentation. For information on importing designs, refer to the Importing and Exporting Designs
documentation.

2. Define the substrate characteristics. A substrate is the media upon which the circuit resides. For example, a
multilayer PC board consists of various layers of metal, insulating or dielectric material, and ground planes. Other
designs may include covers, or they may be open and radiate into air. A complete substrate definition is required
in order to simulate a design. The substrate definition includes the number of layers in the substrate and the
composition of each layer. This is also where you position the layers of your physical design within the substrate,
and specify the material characteristics of these layers. For more information, refer to, Substrates.

3. Assign port properties. Ports enable you to inject energy into a circuit, which is necessary in order to analyze the
behavior of your circuit. You apply ports to a circuit when you create the circuit, and then assign port properties
in EMDS for ADS. There are several different types of ports that you can use in your circuit, depending on your
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application. For more information, refer to Ports.

4. Add a box or a waveguide. These elements enable you to specify boundaries on substrates along the horizontal
plane. Without a box or waveguide, the substrate is treated as being infinitely long in the horizontal direction.
This treatment is acceptable for many designs, but there may be instances where a boundaries need to be taken
into account during the simulation process. A box specifies the boundaries as four perpendicular, vertical walls
that make a box around the substrate. A waveguide specifies two vertical walls that cut two sides of the
substrate. For more information, refer to 3D Extension.

5. Set Simulation Options. A mesh is a pattern of tetrrahedra that is applied to a design in order to break down
(discretize) the design into small cells. A mesh is required in order to simulate the design effectively. You can
specify a variety of mesh parameters to customize the mesh to your design, or use default values and let EMDS
for ADS generate an optimal mesh automatically.

6. Simulate the circuit . You set up a simulation by specifying the parameters of a frequency plan, such as the
frequency range of the simulation and the sweep type. When the setup is complete, you run the simulation. The
simulation process uses the mesh pattern, and the electric fields in the design are calculated. S-parameters are
then computed based on the electric fields. If the Adaptive Frequency Sample sweep type is chosen, a fast,
accurate simulation is generated, based on a rational fit model. For more information, refer to Simulation.

7. Create Layout components. Layout components can be used in the schematic design environment in combination
with all the standard ADS active and passive components to build and simulate circuits including the parasitic
layout effects. The EMDS engine is automatically invoked to generate an S-parameter model for the Layout
component during the circuit simulation. For more information on the Layout Components and EM/Circuit
cosimulation feature, refer to Layout Components.

8. View the results. The data from an EMDS simulation is saved as S-parameters or as fields. Use the Data Display
or Visualization to view S-parameters and far-field radiation patterns. For more information, refer to Viewing
Results Using the Data Display and Viewing Results.

9. EMDS for ADS Visualization. EMDS for ADS visualization enables you to view and analyze, S-parameters,
currents, far-fields, antenna parameters, and transmission line data. Data can be analyzed in a variety of 2D and
3D plot formats. Some types of data are displayed in tabular form.

10. Radiation patterns. Once the electric fields on the circuit are known, the electromagnetic fields can be computed.
They can be expressed in the spherical coordinate system attached to your circuit. For more information on
radiation patterns, refer to Radiation Patterns and Antenna Characteristics

Getting Started with EMDS for ADS

This chapter is intended to help you get started with EMDS for ADS. It illustrates basic tasks and exercises using
EMDS. The subsequent chapters contain more in-depth reference information and examples.

Layout Basics

There are two basic ways to create a layout:

e From a schematic (in a Schematic window)
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e Directly (in a Layout window)
The best approach to creating a layout depends on the design and the designer.

This section describes how to create a layout automatically from a finished schematic, and how to use the basic
features in a Layout window to create a layout directly.

 Note

When you are through working in layout, release the Layout license so that it is available to another user. To
do this, choose File > Release Layout License from the Layout window.

Creating a Layout from a Complete Schematic

If all data is contained in the schematic, it is very simple to create a layout.

1. In the Schematic window, build the schematic shown here, then choose the menu command Layout >
Generate/Update Layout (the schematic is the source representation). The Generate/Update Layout dialog box

appears.
MSOBEMD_MDS
Bend2
Subst="MSub1"
For LI W=25 0 mil
P2 L3
Mum=2 Subst="MSuk 1"
MSub W=25 0 mil
L=100.0 mi FALIM
MSUE TLZ
MSuk Subst="MSub1"
H=10.0 il Wi=25 0 mil
Er=95 L=100.0 mil
fuar=1
Cond=1 .0E+30
Hu=3 Se+034 mil
T=1 mil
TanD=0 1 MSOBND_MDS
Rough=0 mil Q —Jd Bend
Mum=1 Subst="MSuk1" :
W=25 0 mil
L=100.0 mi

By default, the layout will begin with P1, at 0,0, with an angle of 0 degrees. There is no existing layout, so the
Equivalence (the layout component that corresponds to the starting component in the schematic) is shown as not
created.

11
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Starting item for generation

Generate/Update Layoukt:3
Starting Component E quivalent Component
F1 [
Options Status
Delete equivalent components in Layout not created
R that have been deleted/deactivated in Schematic
[ Show statuz report H-Coordinate
oo
[~ Fix starting component's pozition in Layout - Coordinate
- Fix all components in Lapout during Generate/ | pdate ||:|-|:|
Angle
Preferences... Waniables... | foo

Mate: *When you chooze OF or Apply, the "Undo" stack will be cleared.
Current dezign will be zaved in ' zpnc' file. Uze "Undo Generate/Jpdate” to retrieye.

oK. | _ﬁpm Cancel | Help |

Place P1 in layout at 0,0 with angle of 0.0

N
Start generation degrees

Fix or free the position of P1 (so that it will or will not be re-positioned in
subsequent generations).

At this point, all of the elements in the schematic are highlighted, indicating that they all need to be generated.
2. Click OK.

The Status of Layout Generation dialog box appears. It displays the number of designs processed, the number of
items regenerated (created) in the layout, the number of items that are oriented differently in the layout than in the
schematic, and the number of schematic components that were not placed in the layout.

12
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i Status of Layout Generation:3

Generation of layout started from schemalic representatbon: J

1 design(z] processed

¥ item(z] regenerated in layout
¥ itern(z] relocated in lapouk

0 item(z] unplaced in layout

[ trace designiz] created

Print | Help |

The program automatically opens a Layout window and places the generated layout in it. The orientation of the layout

is different from that of the schematic, because the layout is drawn from left to right across the page, beginning at the
Starting Component.

Bendil

Creating a Layout Directly

13
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Launch Advanced Design System and create a project. To display a Layout window, choose Window > New Layout
from the ADS main window, or choose Window > Layout from an open Schematic window.

Jel@la] | sein] ol @ 2|2] 8| we|| £l 2| 0]o|OlA
|TLines-Micrustrip j| j O = m |N |v,s cond j S _.,C 3+_ “'_ _,1 i

+

|, Palette List

| 52 R Create a Trace

+ + +

= | = ﬂ . .. Component History

== -Component S I S
Mefil Melin Palette ) - ) ) ) DraWI_I"Ig Jé-rezl

Mcorn | Morozs

)

Meurve | Mourve ﬂ

| AJ/RF  Sim3Schem

Select: Enter the starting poink 0 kems =320.0000, 00000 =300,0000, -35.0000 i

The following tasks are performed the same way in a Layout window as they are in a Schematic window:

e Selecting components

e Placing and deselecting components
e Changing views

e Hiding component parameters

¢ Coping and rotating components

¢ Using named connections

Connecting Components with a Trace

As in a Schematic window, you can connect components without having them actually touch. In a Layout window, this
is done by placing a trace between the component (in the same way a wire is used in the Schematic window). Either
choose Component > Trace , or click the Trace button in the toolbar.

Unlike wires in a Schematic window, a trace in a Layout window may be inserted alone (click twice to end insertion).

Shapes
In Layout you can insert shapes, using either Insert commands or toolbar icons:
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Insert commands rectangle
paolygon

Fie Edt Select View [Insert Opbons Tools Schematc Momentum EMDS  Window DesgnGude Help }

+
.
*

lJIBJ[ﬂIQI = | et 3] 9. (RS0 $)LS] le|d| &9 0/0]|O)

|
polyline
path circle

With each shape, you can either click and drag to place it, or define points by coordinate entry (choose the shape,
then choose Insert > Coordinate Entry ).

e path : starting point, segment end (click), and end point (double-click)

e polygon : starting point, vertex (click), and end point (double-click) that closes the shape
e polyline : starting point, segment end (click), and end point (double-click)

e rectangle : two diagonal corners

e circle : center and circumference point

e arc : (Insert command only) center and circumference point

 Note

The final segment of polygons and polylines can be entered by pressing the space-bar rather than
double-clicking the mouse.

Experiment by drawing different shapes to get the idea of how each is created.

Layers

In a Layout window, items are placed on a layer. The name of the current insertion layer is displayed in the toolbar
and in the status bar.

15
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Current Insertion Layer

) fotsfhpsrmifdlfusers fednah My Designs fejample.prjf neteorks fGntitled 1:1 1==1 i3
File  Edl  Selsct Vew Draw  Comporenl  Oplions  Schematic  Mecre | Verdfy  Momenlon  Window Heip

SRS | 20 o | eEapnE | | AYOCAl

s i QBN IN P R HEAENE ]

el METT J
Select: Eater the skarting poand 0 itewns R -Z20.00, -B5.00 -20U00, -95.00 il ARF - Layy

Current Insertion Layer

Changing the Insertion Layer

There are many ways to change the insertion layer:

e In the toolbar, retype the name of the layer and press Enter.

e In the toolbar, click the arrow next to the layer name. Choose a name from the list of currently defined layers.

e Choose the command Insert > Entry Layer and select a layer from the list.

e Choose the command Options > Layers and select a layer from the list of defined layers in the Layer Editor
dialog box.

e Choose the command Insert > Change Entry Layer To , and click an object whose layer you want to make the
current insertion layer.

e Use the Layers window, that is opened when a Layout window is opened and select a name in the list of currently
defined layers.

16
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L Layers =]

Layvers Options Help

Current entry laver

| zond -

Sel Wiz Lavers

<1 <1 «

<1 <l

<l <l

|te:-:t
|Ieads '
|packages 3

< <1 «

< < =<l < < =< <] < < < < %] %
<]

T
=]
=]
=3

N I D

L ]

&5

Llntitleu:lZ (Layouk)

Experiment with placing shapes on different layers. Remember to click OK to accept a change in a dialog box.

Copy to a Different Layer

Experiment with copying shapes from one layer to another; use the command Edit > Advanced Copy/Paste > Copy to
Layer. Note that the copied shape is placed at exactly the same coordinates as the original. Move one to see them
both.

Default Layer Settings

Choose the command Options > Layers to display the Layer Editor. This is where you can edit the parameters of any
defined layer, add layers, or delete existing layers.

17
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x|

i Laver Editor:6

Bazic l Advanced ]

_ ITI Mame | Color/Pattemn  Inz SelVis Shape Display Line Stvle  Poverse |
R [0 [derau | =IBE=~Ir # P [odine  *][Soid -]
U [eend PP F P [ed  x][soid =]
= [ [eona2 | ="~ [Filed  x][sold =]
37 [res Pl -r P~ [fies =[Sl =]
[4 [del I =l 2r P e [files  =][Sold =]
[z [de [ ZIMN=r = @ [res  =][soid =
[5 [hole ==l 7 F [Filea  =][Sold =l
6 [bond [ =MWz # @ [fied  =][scid =]
= [ [eombol [ Iz & F [fied  =][scid =]
| B [en [ I8 =Ir 7 " [Filed  =][S0id =]
Selec Visible Shape Display Line Style Layer
Al | None || A1 | Mone |l A || i Mew | Cut | Paste |
Search For Laper: M ezzages:
| |
k. | Apply | R eset | Save.. | Read... I Cancel | Help |

Clicking Apply updates layer definitions but does not dismiss the dialog box.

Experiment with layer parameters. Note that you can toggle the visibility of all items on a layer. Protected means you
can not select items on that layer.

Other Layout Defaults

The Options > Preferences command displays the Preferences for Layout dialog box. This dialog box has 11 tabs;
clicking a tab brings the corresponding panel to the front.

18
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Select ] Eriu:l.-’ﬁnap] F‘Iaa:err-entl F'in.-’Teel

Entry;’Edit' Component Tea-:tl Teut ] Display'

Werification I Units/Scale l Layout Lnits I

Click the Grid/Snap tab.

Preferences for Layout:b

Grid/ 5 nap l F'Ian::ement] F'ir'u"Tee] Entr_l,u"Eu:IiI] Component Tad] Text I Displa],il II..-"erifin::atin:nr'lI Llnitsx'Sn::aIel Layn:nutLlnitsI 1 I *I

Gnd/Snap
Diizplay Spacing Active Snap Modes
Snap Gnd Distance [in lapout unitz] [# Enable Snap
[~ Minar Grid
B 5 L [5 .
™ Major Grid izl
Snap Grid Per Minor Display Grid ¥ Fin
[T Werex
Type % 2 Lt IE -
[~ Midpoint
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This panel is where you set the snap grid and display grid parameters.

The display grid appears on the screen as a series of vertical and horizontal lines or dots that you can use for aligning
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and spacing items in the drawing area.

Adjust Grid Visibility and Color

1. In the Display area, choose Major, Minor, or both.

2. Choose the Type of display (Dots or Lines). You may have to zoom in to see the grid display.

3. Click the colored rectangle next to the word Color, and choose the desired color for the grid. Click OK to dismiss
the color palette.

4. Click Apply. Experiment with different settings

 Note

The drawing area color is the Background color under the Display tab.

Adjust Snap and Grid Spacing

The ability to display a major grid as an increment of the minor grid enables you to gauge distances and align objects
better in a layout.

1. In the Spacing area, change the Minor Grid display factors for both X and Y. The larger the number, the wider
the grid spacing.

2. Click Apply. Experiment with different settings. If a display factor makes the grid too dense to display, it is
invisible unless you zoom in.

3. Now experiment with the Major Grid.

Adjust Pin/Vertex Snap Distance

Pin/vertex snap distance represents how close the cursor must be to a pin of a component or a vertex of a shape
before the cursor will snap to it.

A large value makes it easier to place an object on a snap point when you are unsure of the exact location of the snap
point. A small value makes it easier to select a given snap point that has several other snap points very near it.

Place several components and several shapes in the drawing area and experiment with different settings of Pin/Vertex
Snap.

Screen pix specifies sizes in terms of pixels on the screen. For example, if you choose 15, the diameter of the snap
region is 15 pixels.

User Units specifies sizes in terms of the current units of the window. For example, if you are using inches and choose
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0.1 user units, the diameter of the snap region is 0.1 inch.

Experiment with Snap Modes

Snap modes control where the program places objects on the page when you insert or move them; you can change
snap modes when inserting or moving a component, or drawing a shape. When snap is enabled, items are pulled to
the snap grid.

Experiment with different snap modes turned on or off to see how they affect the placement of items in a Layout
window.

Snap Mode Priority

You can restrict or enhance the Pin 1

manner in which the cursor snaps by
choosing any combination of snap

modes. This table lists the snap Midpoint
modes, and their priorities.

Vertex 2

Intersect

Arc/Circle Center

Edge 3

Grid 4

Angle Snapping automatically occurs when only Pin snapping is enabled and you place a part so that the pin at the
cursor connects to an existing part. The placed part rotates so that it properly aligns with the connected part.

—_—

— —
CURWVT T

———

\
“Ii\‘ \
v

For example, if you have a microstrip curve at 30° and place a microstrip line so that it connects to it, the microstrip
line will snap to 30° so that it properly abuts the curve.

Enable Snap toggles snap mode on and off. You can also toggle snap mode from the Options menu itself, and there
are snap mode buttons on the toolbar.
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Except for pin snap, the pointer defines the selected point on the inserted object.

When you set all snap modes OFF, you can insert objects exactly where you release them on the page. This is
sometimes called raw snap mode. Like other snap modes, the raw snap mode also applies when you move or stretch
objects.

Pin When a pin on an object you insert, move, or stretch is within the snap distance of a pin on an existing object, the
program inserts the object with its pin connected to the pin of the existing object. Pin snapping takes priority over all
other snapping modes.

Vertex When the selected location on an object you insert, move, or stretch is within the snap distance of a vertex on
an existing object, the program inserts that object with its selected location on the vertex of the existing object.

In vertex snap mode, a vertex is a control point or boundary corner on a primitive, or an intersection of construction
lines.

Midpoint When the selected location on an object you insert, move, or stretch is within the snap distance of the
midpoint of an existing object, the program inserts that object with its selected location on the midpoint of the
existing object.

Intersect When the selected location on an object you insert, move, or stretch is within the snap distance of the
intersection of the edges of two existing objects, the program inserts that object with its selected location on the
intersection of the existing objects.

Arc/Circle Center When the selected location on an object you insert, move, or stretch is within the snap distance of
the center of an existing arc or circle, the program inserts that object with its selected location on the midpoint of the
existing arc or circle.

Edge When the selected location on an object you insert, move, or stretch is within the snap distance of the edge of
an existing object, the program inserts that object with its selected location on the edge of the existing object. Once a
point snaps to an edge, it is captured by that edge, and will slide along the edge unless you move the pointer out of
the snap distance.

Because edge snapping has priority 3, if the cursor comes within snap distance of anything with priority 1 or 2 while
sliding along an edge, it will snap the selected location to the priority 1 or 2 item.

Grid When the selected location on an object you insert, move, or stretch is within the snap distance of a grid point,
the program inserts that object with its selected location on the grid point.

All other snap modes have priority over grid snap mode.

@& Hint

Whenever possible, keep grid snapping on. Once an object is off the grid, it is difficult to get it back on.

Use 45 or 90° angles to ensure that objects are aligned evenly, and to reduce the probability of small layout
gaps due to round-off errors.
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Drawing Tips

This chapter provides suggestions and examples when drawing layouts to be simulated using EMDS for ADS. These
examples take into consideration things that are necessary during the drawing phase to ensure that requirements for
EMDS for ADS are met.

Using Grid Snap Modes

Working in Layout enables you to control all geometry precisely. The variety of available snap modes can help you
draw and position shapes. As an example, if you are connecting shapes, you should have the vertex snapping mode
turned on. You will also want to review snap mode settings prior to adding ports to a layout.

Snap grid spacing also helps control the positioning shapes. In general, snap grid spacing should be about 1/2 of the
minor grid point value. For example, if the minor grid points are 1.0, then the snap grid spacing should be 0.5. This
makes it easy to know how your geometry will snap into place.

For more information on snap modes and snap grid spacing, refer to Chapter 2 of Layout .

Choosing Layout Layers

The standard set of layout layers begins with the layer named default. Do not use this layer for drawing your circuit.
The first valid layer for EMDS for ADS is cond. For more information on layout layers, refer to the Schematic Capture
and Layout manual.

Keeping Shapes Simple

In general, when drawing shapes, you should use a minimal number of vertices per shape, since this will make the
mesh easier to compute. When drawing curved objects, consider using a relatively large value for Arc/Circle Radius
(under Options > Preferences > Entry/Edit ). This will minimize the number of vertices, and facets used to represent
the shape.

Merging Shapes

Merging shapes is often useful for eliminating small geometry overlaps and can also, in some cases, result in simpler
mesh patterns. For example, if you draw a layout using multiple polygons and you suspect there is some overlap,
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merging the polygons will prevent the system from returning an overlap error. To merge the shapes, select each
shape that you want to merge, then choose Edit > Merge.

Viewing Port and Object Properties

Any item selected in a layout, including ports, shapes, or other components, has associated properties. One way to
view the properties is to select the object of interest, then choose Edit > Properties. This method also enables you to
change object properties. If you want to change properties that have been attributed to an object for EMDS for ADS,
you should change these properties either through the EMDS menu or the Momentum menu selections.

To view the properties of the entire layout, choose Options > Info.

Adding a Port to a Circuit

You can add a port to a circuit either from the Schematic window or a Layout window. The procedures below include
considerations for adding ports to a circuit that will be simulated using EMDS for ADS.

Adding a Port to a Schematic

1. Select a port using by choosing the menu item Component > Port, or the port icon from the tool bar: Ql

2. Position the mouse where you want the port and click. Verify the connection has been made.

Fort _é}

Nurm=3 g —@®—<:>
MCLIHM FPort
CLint F4
Mot connecied

Select the port and choose Edit > Component > Edit Component Parameters.

4. The parameter layer= indicates the layer that the port is applied to. When you convert your schematic to a
layout, all components will be assigned to layout layers. You can assign the port to a specific layer at this time.
To change the layer, select layer= from the Select Parameter list, and choose a new layer from the Parameter
Entry Mode listbox. Make sure that the layer you choose will also be mapped as a strip or slot metallization layer.
For more information about metallization layers, refer to Substrates.

5. Click OK to accept the new layer specification.

Connecizd

w
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When you generate a layout from the schematic, you should verify that the port is positioned correctly. For more
information, refer to the procedure for adding a port to a layout and to Considerations.

Adding a Port to a Layout

To add a port:

1. Determine where you want to position the port. A port can be applied to:
e The pin of a component
e The edge of a component or object (such as a rectangle or polygon), usually at the midpoint
e The surface of an object

Pl &
Glint k- i
& &
Fort connected to Part connected o Port connected to
apin an edge a zurface

© Note

Do not place a port on the corner of an object. When you add a port to an edge, make sure the appropriate
snap modes are enabled. It is a good practice to enable the modes Midpoint Snap and Edge Snap (under the
Options menu) to ensure accurate simulation results.

2. If you want to add a port to the surface of a polygon, you may need to disable the following or other snap modes
(under the Options menu):
e Pin snap
e Edge snap
e Midpoint snap
3. Identify the name of the layer on which the component or shape is entered. If you don't know the name of the
layout layer, choose Options > Layers. Select each layer, noting the color in the dialog box. When the color
matches that of the one in the Layout window, note the name of the layout layer. Dismiss the dialog box.
4. Select a port using by choosing the menu item Component > Port, or the port icon from the tool bar:

o

5. The Port parameters dialog box is displayed. The parameter layer indicates the layer that the port will be applied
to. The parameter defaults to the currently active drawing layer.

6. This should be the same as the layer you noted in step 3. To change the layer, select layer= from the Select
Parameter list, and choose a new layer from the Parameter Entry Mode listbox. Make sure that the layer you
choose is also a strip or slot metallization layer. Do not apply ports to shapes that are on layers that are mapped
to via metallization layers. For more information about metallization layers, refer to Substrates.

 Note

If you cannot find the layer name, choose Options > Layers , then select the layer name of interest from the
Layers list. Note the layer number in the Number field. In the Port dialog box, select the layer= parameter
and, under Parameter Entry Mode, select Integer Value . Enter the layer number, then click Apply .
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7. Click Apply to accept the new layer specification.
8. Position the mouse where you want to place the port and click. The port is added to the circuit.

 Note

If you are applying a port to an edge, the port must be positioned so that the arrow is outside of the object,
pointing inwards, and at a straight angle. Generally, this happens automatically when you add a port to an
edge. You may need to zoom in to verify this.

Y P3

9. The Instance Name in the Port dialog box is incriminated if you want to add another port. Verify the layer=
parameter, then use the mouse to add the next port.
10. When you are finished adding ports, click OK to dismiss the dialog box.

Considerations

Keep the following points in mind when adding ports to circuits to be simulated using EMDS for ADS:

e The components or shapes that ports are connected to must be on layout layers that are mapped to metallization
layers that are defined as strips or slots. Ports cannot be directly connected to vias. For information on how to
define strips and slots, refer to Defining Metallization Layers.

e Make sure that ports on edges are positioned so that the arrow is outside of the object, pointing inwards, and at
a straight angle.

e Make sure that the port and the object you are connecting it to are on the same layout layer. For convenience,
you can set the entry layer to this layer; the Entry Layer listbox is on the Layout tool bar.

e A port must be applied to an object. If a port is applied in open space so that is not connected to an object,
EMDS for ADS will automatically snap the port to the edge of the closest object. This will not be apparent from
the layout, however, because the position of the port will not change.

o If the Layout resolution is changed after adding ports that are snapped to edges, you must delete the ports and
add them again. The resolution change makes it unclear to which edges the ports are snapped, causing errors in
mesh calculations.

 Note

Do not use the ground port component in circuits that will be simulated using EMDS for ADS ( Component >
Ground or the toolbar button = ¢ | ).

Either add ground planes to the substrate or use the ground reference ports that are described later in this
chapter.
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Examples

This section includes a number of examples to help you understand how to use the product.

The examples provided in this section include:

Designing a Microstrip Line

Creating a Simple Substrate

Setting up Mesh Parameters

Performing the Simulation

e Designing a Microstrip Filter

Designing a Microstrip Line

This section is made up of an exercise that takes you through the process of creating a schematic, converting to a
planar (Layout) format, preparing the layout for simulation, simulating, and generating analysis plots.

This exercise uses many default settings and a simple circuit (a microstrip line with step in width), and illustrates how
quickly a design and analysis can be accomplished.

In this exercise, you will:

e Draw a simple microstrip line with step in width as a schematic, then generate a corresponding layout
e Create a simple substrate

¢ Define a mesh

e Perform a simulation

e Examine the results

Terms such as substrates and meshes may be unfamiliar, so they are explained in the course of the exercise.

This and later exercises assume that you have an introductory working knowledge of Advanced Design System, such
as understanding the concept of projects, and being familiar with Schematic and Layout windows and placing
components.

Drawing the Circuit
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The basic steps to making the microstrip line with step in width circuit include:

e Creating a new project
¢ Adding microstrip components to the schematic
e Converting the schematic to a layout

The schematic and layout representations are shown here. The sections that follow describe how to create both.

<O~ F—1 M=

Port MLIN MLIN Port
P1 TL2 TL3 P2
Num=1  Subst="MSubl" Subst="MSubl" Num=2

W=25.0 mil W=35 mi]
L=100.0 mil L=100.0 mi]
P P2

Creating a New Project

You should start this exercise in a new project.

1. From the Main window, choose Tools > Preferences. Ensure that Create Initial Schematic Window is enabled.
Click OK.

2. From the Main window, choose File > New Project. The New Project dialog box appears.

3. In the Name field, type stepl.

4. In the Project Technology Files section, choose ADS Standard: length unit - mil

5. Click OK.

A Schematic window appears, which is where you will enter the design.

Adding Microstrip Components to the Schematic

The steps in this section describe how to select a component. In the next section, it will be placed in the Schematic
window.
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Refer to the this figure to select the microstrip line component (MLIN) from the Microstrip Transmission Lines palette:

= [

File Edit Select View Draw
Je @@ ] =0

TLines - Microstrip “| —— 1 Click Palette List arrow once.
The Palette List drops down.

Simulation-LS3P
Simulation-XDB
Simulation- Envelope
Simulation- Transient
OptimiStativield
Probe Components
Data Items

TLines- Ideal

I'Lines - Microstrip —— 2 Click TLines-Microstrip. The
I.E:E:_ ;';'.:ﬁznﬂmm 2zl pglette Ii.st closes and the
TLines- Suspended Substrate Microstrip Component palette
TLines- Finline is displayed.
Tlines-Wavequide
TLines - Multilayer
Passive- RF Circuit

Misng | Mangs|

ﬂi@a o 3 Clickthe MLIN button. This selects
the Libra Microstrip Line component.

| 4 Crosshairs and a ghost icon of the

MLIN MG E component appear as you move the

e cursor over the design window.

_MLSE | iring

Placing the Components

The steps in this section describe how to place two microstrip lines in the Schematic window.

1. Move the crosshairs to the Schematic window and click once to place the component. A schematic representation
of the component is placed in the Schematic window.
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-|

Click here to place a component File Edit Select View Draw Compor

== ﬂ%ﬁ
| MLIN

[ PR [ 1.

2. Move the cursor so that the crosshairs are directly over the r|ght pin of the first component, and then click once

to place a second component.

Fosition cursor here

W —*%—— and click to add ancther
] component
TL1
Subst="M3ub1"
W=25. 0 mil
L=100.0 mil

Cancelling Commands

If you continue to click without ending the current command, you will add another component with each click

1. Click the arrow button hl . The crosshairs disappear.

2. You can also end a command by pressing the Esc key.

You will use the end command frequently in this and other exercises, so be sure you are familiar with it

Editing Component Parameters

Below the schematic representation of each component are some of the editable parameters of the component. This
section describes how to change the width of one of the strips. The result is a microstrip step in width transmission

line.
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1. Click twice on the second component that you placed. The Libra Microstrip Line dialog box opens.

i Libea Microstrip Line:1

MLIM Parameter Entry Made

Irstancs N amme |'3 tring and Referience ﬂ
TL3 Subst
Sedect Parameter Iﬁmﬁl Brovess.., I
Subst="M5ub1"

=250 mil

L=100.0 il

wall1=

Wall2=

Temps=

v Display parameter on zchematic
| ] | | Component Dptions. . |

[Subst : Substrate instance name

oK | dpply | Cancel|  Reset | Help |

2. In the Select Parameter field, select the W (width) parameter. When the field to the right shows the value of the
width, change the value in this field to 35 mil. Click Apply.
3. Click OK to dismiss the dialog box.

© Note
If a parameter for a component is displayed in the Schematic window, you can also edit that parameter by
clicking on the value and entering a new value.

4. Verify that the width of component on the left is set to 25 mil, and if needed, change the value of this parameter.

Adding Ports to the Circuit

To complete the circuit, you must add ports, one at the beginning of the microstrip step in width and one at the end.
In EMDS for ADS, ports identify where energy enters and exits a circuit. This section describes how to add ports.

1. In the menu bar, click the Port button x| Move the cursor over the Schematic window and note the
orientation of the ghost icon of the port. The ports should be positioned as shown in the schematic below at the
end of these steps.

2. You may need to rotate the port to the necessary orientation. If so, click the Rotate button | . and move the

cursor back into the Schematic window. Note the rotation of the port outline, and repeat until it is correct.
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w

Move the cursor over the open pin on the left side of the left component, then click.

4. The command to insert a port remains active. To insert a second port, change the orientation appropriately,
move the cursor over the open pin on the right side of the right component, then click.

5. End the current command. Your schematic should now look like this figure. It is a microstrip line step in width.

The width of the first part of the line is 25 mil, and it increases to a width of 35 mil. The overall length is 200 mil.

& Note

All of the components are connected. Diamond-shaped pins indicate that pins are not connected, and you will
need to select and move components to make complete connections.

o = =<

Port MLIN MLIN Port
P1 TLZ TL3 Pz
Num=1 Subst="MSubl" Subst="MSubl" Num=2
W=25.0 mil W=35 mil
L=100.0 mil L=100.0 mil

Saving the Design

It is good practice to save your work periodically. This section describes how to save the schematic.

1. Choose File > Save Design. When the Save dialog box appears, enter the name of the project, in this case, type
stepl.

2. Click OK.

Generating the Layout

A powerful feature of Advanced Design System is the ability to convert a schematic to a layout automatically. Since
EMDS for ADS requires a circuit be in Layout format, this gives you the option of drawing your circuits either as
schematics or as layouts. Note that if you do choose to draw in a Schematic window, footprints of the components you

use must also be available in Layout. Components that are available in Layout include transmission lines and lumped
components with artwork.

This section describes how to covert the microstrip line step in width schematic that you just finished to a layout.

1. In the Schematic window, choose Layout > Generate/Update Layout . The Generate/Update Layout dialog box
appears. It is not necessary to edit fields.
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2. Click OK .

3. A Status of Layout Generation message appears indicating that the conversion is complete

4. Click OK .

5. A Layout window appears, showing a layout representation of the schematic. This window may be hidden by the

Schematic window, so you may need to move some windows to locate the Layout window.

P 1 P2

6. From the Layout window, choose File > Save Design . Name the layout stepl . You now have a layout and a
schematic as part of your project.

Creating a Simple Substrate

A substrate is required as part of your planar circuit. The substrate describes the media where the circuit exists. An
example of a substrate is the substrate of a multilayer circuit board, which consists of:

Layers of metal traces

Layers of insulating material between the traces
Ground planes

Vias that connect traces on different layers

The air that surrounds the circuit board

EMDS for ADS includes several predefined substrates for your use, or you can create your own. Complete details
about substrates, including where substrates are saved, are in Substrates.

The steps in this section describe how to define a substrate.
For the microstrip line step in width example, a substrate with the following layers will be used:

A ground plane

A layer of insulation, such as Alumina
A metal layer for the microstrip

¢ An air layer above the microstrip

1. From the Layout window, chose EMDS > Substrate > Create/Modify. The Create/Modify dialog box opens,
showing the Substrate Layers options and parameters.

33


http://edocs.soco.agilent.com/display/ads2008/Substrates+in+EMDS#SubstratesinEMDS-1104591

Advanced Design System 2008

Create/Modify Substrate:2 Eil

Substrate Layers I i etalization Layers I

Mame: none

Salect a substrate layer to edit OF define a new lsper

Substrate Layers Boundary Substrate Layer Name
Cpen - | |FieeSpace
Alumna " »
JER GHD M Pemittivity [Er) Petrmeability [Mu]
[Fie. Loss Targent [ |Fe. Loss Tangent =
Reasl Feal
1 I
Lozs Tangent Lozs Tangent
tdd | cu | | o G

oK. Cancel Help

2. In the Substrate Layers field, select FreeSpace. Move to the Substrate Layer Name field and change it to read Air
. Leave all other parameters at their default values and click Apply.

3. Keep the default layers Alumina and ///GND/// , but highlight and Cut any other layers that may be showing.
Click Apply.
You currently see three of the four substrate layers that you need. The fourth (metal) layer can be found by
clicking the Metallization Layers tab.
The metal layer is automatically positioned between the Substrate layers of Alumina and air. The microstrip line
is assumed to be on this layer.
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Create,/Modify Substrate:4

Substrate Layers  Metalization Layers

Select a lapout laper to map az a stp or slot to an interface plane [dazhed line]
of a3z a via to a zubstrate laper:

Laver Mapping Layout Layer
Substrate Layers:
I |cond =
------- Strp cond
Alumina Type | Sheet Conductar j
AEAEGHD A8
Thickness o il j
Conductivity | Perfect Conductar _ﬂ

Faor a perfect sheet conductar, the zimulatar ignares thick ness.

Overlap Precedence

1_|Ilr__|l‘| _‘_I
O 55|

k. | Eancell Help |

4. Click OK to dismiss the dialog box.
5. To save the substrate with the project, choose EMDS > Substrate > Save As. Type stepl in the Selection field
and click OK. The substrate stepl.slm is saved in the project networks folder.
Some other information about saving substrates:
¢ A substrate definition is automatically saved with the design when File > Save is invoked from the Layout
window
e The command Substrate > Save As enables you to save the substrate definition in
slm that can be saved anywhere and used with another design
e When a design is opened, the substrate definition that was saved with the design is automatically loaded.

Setting up Mesh Parameters

A mesh is required in order to perform a simulation. The simplest method for generating a mesh is to skip the Mesh
menu entirely and allow EMDS to automatically generate the mesh for your circuit; however, you can still choose to
edit parameters that control how the mesh is generated.

A mesh is a grid-like pattern of tetrahedra that is applied throughout the volume of a circuit. Using the mesh, the
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electric fields within each tetrahedron volume is calculated, and any coupling effects in the circuit can also be
calculated during the simulation. From these calculations, S-parameters are then calculated for the circuit.

Details about mesh definitions, seeding and generation can be found in Simulation Options.

The steps in this section describe how to set the frequency for mesh computations. All other options will remain at the
default values.

1. From the Layout window, choose EMDS > Simulation Options . An EMDS Simulation Options dialog box appears.

=/ EMDS Simulation Options:2

Mesh Refinement
Delta Error |0.01
Consecutive Ikerakions of Delka Error Required |1

Lirnit on Mumber of Adaptive Passes |15

Mesh Frequency Cverride

Refine at a Specific Frequency

Adapt the mesh at 4 GHz W

Mesh Seeding

) Minimal (%) Moderate () Cuskom  Cuskom Sektings...

[ Ik ] [ Apply ] [ Cancel ] [ Help

2. Select Refine at a Specific Frequency.
3. Set The mesh will be adapted at 4 GHz, and then click OK.

Performing the Simulation

The EMDS for ADS simulation process creates an initial mesh from the mesh seeding information and solves for E-field
in the circuit. Using the E-field calculations, S-parameters are then calculated for the circuit.

There are a variety of options to select to set up a simulation. Details are in Simulation. This section describes the
minimal steps for running a simulation.

1. From the Layout window, choose EMDS > Simulation > S-parameters. The Simulation Control dialog box
appears.
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2. Set the Sweep Type to Linear and confirm that the following parameters are set:
e Start =1 GHz
e Stop =4 GHz
e Frequency Step = 1 GHz
By choosing this sweep type, a linear simulation will be performed over the 1-4 GHz frequency range,
selecting the frequency points to be simulated based on the step size.
3. Click Add to Frequency Plan List . The dialog box should resemble Simulation Control Dialog.

The initial mesh is refined at the mesh frequency until the adaptive mesh refinement criteria are satisfied. Then a
frequency sweep is performed.

% Simulation Contral: 2

St s
Salect & fraquency plan from kst bo edit or dafine & new one

Fraquency Plans Edit/Dwafine Frequency Plan
Type F acartc F acop Hpta/Scep Sweep Type
Linear 1.0000 GH=z 4.0000 GH=z 1.000 GH=z Linar b
Start
] GHz W
Sop
4 GHz W
Frequency Step
] GHz W
[ Cit 1 Paste j[ Updste | | & to Fraquency PlanList |
Process mode: local Sohtion Files Data Display
0O Fieiise Fibes From the 0O Cxpens daba desplay wehsn
previous sirulation sirmlation completes
Foreground Dakasst Templaks

(omaee ] [ ] (e ] [ ]

Simulation Control Dialog

1. Ensure that the field Open data display when simulation completes is enabled.

2. Click Simulate. The simulation will be performed. The simulation progress and its completion will be indicated in
the Simulation Status window.

3. When the simulation is complete, the S-parameter simulation results are automatically displayed on both
rectangular plots and Smith charts in a Data Display window. This is because the field Open data display when
simulation is complete was enabled as a default in the simulation setup. Choose View > View All or click the View

All button to view all of the plots, then zoom in on individual plots. An example of one S-parameter result is
illustrated here.
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This completes the first EMDS for ADS design exercise.

Designing a Microstrip Filter

This section is made up of an exercise that takes you through the process of designing a microstrip coupled-line filter.
It is similar to the previous exercise, but uses fewer defaults and explores how to:

Create a more complex substrate

Specify port properties

Use a box to simulate the filter within a metal enclosure
Specify mesh parameters

Drawing the Circuit

This section is very similar to the drawing instructions in the previous exercise. The circuit is drawn as a schematic,
then converted to a layout. If you need more information on how to perform certain steps, refer to the previous
exercise.

Opening a New Project

Like the previous exercise, start the filter design in a new project.

1. From the Main window, choose File > New Project.
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2. In the Name field, type filter.
3. In the Project Technology Files section, choose ADS Standard: length unit - mil.
4. Click OK in the New Project dialog box to create the new project.

Adding Components to the Schematic

The steps in this section describe how to select microstrip filter components.

In the Schematic window, click the Palette List arrow. The Palette List drops down.

. Scroll and select T-lines Microstrip __ from the Palette List.

3. In the component palette, locate and click Mcfil. This selects the Libra Microstrip Coupled-Line Filter Section
component.

4. Crosshairs and a ghost icon of the component appear as you move the cursor over the Schematic window.
Position the cursor and click.

5. End the command either by clicking the Cancel Command button or by choosing Insert or the arrow button.

N =

Editing the Component

This section describes how to edit several component parameters, such as the length and width, and also how to
change the parameters that are displayed below the component.

1. To edit the component parameters, double click the component.

2. In the dialog box that appears, select one of the parameters listed below, and edit the value. Also, enable
Display parameter on schematic so that the parameter will be displayed below the component in the Schematic
window. Select another parameter, and continue to set the values for these parameters:

e W = line width = 0.25 mm

e S = spacing between lines = 0.044 mm

e L =linelength = 1.8 mm

e W1 = width of the line that connects to pin 1 = 0.25 mm

e W2 = width of the line that connects to pin 2 = 0.25 mm
3. Click OK to accept the edits and dismiss the dialog box.

Copying and Placing another Component

This section describes how to make a copy of the filter section and add it to the schematic.

1. Click the filter component on the schematic to select it. A black outline appears around it.

2. From the Schematic window, choose Edit > Copy.

3. Choose Edit > Paste. ** Move the crosshairs so that they are directly over the left connector of the first
component and click.
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4. End the current command.

Adding Ports

Ports are required on a circuit. If you forget to add ports to the schematic, you can always add them later after the
schematic is converted to a layout. In this exercise, ports will be added to the layout.

With EMDS for ADS, you can define additional characteristics to a port. This also will be performed later in this
exercise.

Your schematic should now look like the figure here. Be sure that all components are connected correctly.

d—

=)
MCFIL
CLinl
Subst="MSubl" o

=0.25 mm MCFIL
5=0.044 mm Clin?

L=1.5 Subst="MSub1"

W1=0.25 mm W=0_25 mm
5=0.044 mm
L=1.& mm

W1=0.2% mm

Saving the Design

It is good practice to save your work periodically.

1. Choose File > Save Design.
2. Enter filter as the file name.
3. Click OK.

Generating the Layout
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This section describes how to covert the microstrip coupled-line filter schematic that you just finished to a layout.

1. From the Schematic window, choose Layout > Generate/Update Layout . The Generate/Update Layout dialog box
and a Layout window appear.

2. From the Layout window, choose Options > Preferences . Click the Layout Units __ tab and set the Resolution to
0.001 mm . Click OK .

3. In the Generate/Update Layout dialog box, enter -1.8 in the X field and 0.294 in the Y field. This step identifies
the placement of P1 on the layout. This step is usually optional, but specifying the location will be helpful later
when the box is added to enclose the filter. Click OK .

4. A window displaying the results of the conversion is displayed. Click OK .

A layout representation of the schematic appears in the Layout window. It should resemble the figure here.

L
CLinl

CLinZ
&

5. From the layout window, choose File > Save Design . The layout name is filter . You now have a layout and a
schematic as part of your project.

Defining a Substrate

This circuit uses a relatively simple substrate. In this exercise, the thickness of some of the layers is modified. A more
important task is that ground planes are added to the top and bottom of the substrate. These ground planes form the
top and bottom of the metal box in which the filter will be enclosed. The substrate will have the following layers:

A ground plane representing the top of the box

A layer of air

The microstrip filter traces

A layer of Alumina

A ground plane representing the bottom of the box.

1. From the Layout window, chose EMDS > Substrate > Create/Modify.
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. Select the top layer in the Substrate Layers field. In the Boundary list, select Closed . The top ground plane is
added to the substrate.

. In the Substrate Layers list, select Free_Space . Change the Thickness to 2846 um. This sets the layer of air to
an appropriate thickness.

. In the Substrate Layers list, select Alumina . Change the Thickness to 254 um.

. Keep the bottom ground plane, but select and Cut any other layers that may appear in the substrate.

. Click Apply.

Note
The top and bottom of the box enclosure are defined with groundplanes, the sides of the enclosure will be
defined later in this exercise.

You currently see four of the five substrate layers that you need. The metal layer for the microstrip filter can be
found by clicking the Metallization Layers tab.
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In this instance, the metal layer is automatically positioned between the Alumina and air layers.
Note the following points about this layer:

e Metal layers are identified by a dashed line.

e The word cond identifies the layout layer that is mapped to this position. Refer to the Layout window, and
you will see that the microstrip circuit was automatically applied to the layout layer named cond during the
translation process.

e The word strip defines the layer such that the microstrips are metal and what surrounds the microstrips on
that layer is air or dielectric. Other choices are slot and via. These are described in the exercise in the next

chapter.

7. Click OK to dismiss the dialog.
8. Choose EMDS > Substrate > Save As. Use the file name filter and click Save. The substrate file filter.slm is saved

as part of the project.
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Adding Ports to the Layout

In EMDS for ADS, you can define the ports in your circuit to be one of several types. Depending on the type you
choose, the ports will be characterized in different ways. This can impact the result of a simulation, because the
simulation can take these characteristics into account. With different port types, you can select one that best matches
the intended application of your layout.

More detailed information about the various port types can be found in Ports.

Ports are defined in a two-step process. First, ports are added to a circuit when the circuit is drawn. Then, in EMDS for
ADS, you specify the port type in order to tailor the port to your circuit. Note that you can add the port components at
any time as you draw the circuit, but before a port type can be specified, a substrate must be defined for the circuit.

This section describes how to add ports to a layout and how to specify a port type for them.

w

From the Layout window, click the port icon. A Port dialog box appears. If necessary, set layer = cond. The ports
must be on the same layout layer as the microstrip filter. Click OK.

Move the cursor over the open port on the left side of the layout and click. Move the cursor over the open port on
the right side of the layout and click. End the command. The layout should resemble the figure here.

CLin?2
« P2

From the Layout window, choose EMDS > Port Editor . This opens the Port Properties Editor dialog box.

If necessary, drag the dialog box away from the Layout window so that both ports are visible. Click the connector
P1.

The Port Properties dialog box will change so that you can select a port type to be applied to P1.
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6. Select Internal from the Port Type drop down list and click Apply.
7. Click the connector P2. Select Internal from the Port Type drop down list. Click OK to accept the port type and
dismiss the dialog box.

The internal port type is selected because it can be applied to the interior of a circuit. While normally this placement of
the ports on the filter would not be considered internal, they are in this case because the filter is enclosed within the
box. More information on this and other port types is in Ports.

Finishing the Box around the Filter

Boxes and waveguide enclosures are useful because they introduce vertical boundaries to the design. Adding a box
enables you to look at box resonance, which can have a significant effect on S-parameters in a small band centered
around the box resonance frequency. More information about boxes, waveguides, and their uses are in 3D _Extension.

Recall that when you defined the substrate, you defined ground planes as the top and bottom of the metal box that
will enclose the filter. This section describes how to specify the dimensions and location of the sidewalls of the box.

1. From the Layout window, choose EMDS > Box & Waveguide > Add Box .

2. You will enter specific x, y coordinates for the left and right sides of the box. Choose Insert > Coordinate Entry .
Type -4.5, -4.5 in the X,Y fields of the Coordinate Entry dialog box and click Apply.

3. Type +4.5, +4.5 in the X,Y fields of the Coordinate Entry dialog box and click Apply . The box appears as shown
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below (you may need to click View All to see the box). Click Cancel to close the dialog box.

Performing the Simulation

This section describes how to set up and run the simulation. In this exercise, the adaptive sweep type is used in the
simulation process. This the preferred sweep type, because it used a fast, highly accurate method of comparing
simulated data points to a rational fitting model. Unlike the linear sweep type, where simulated data points are chosen
in a linear fashion based on step size, adaptive sweep type data points are chosen based on where the most variance
seen. Wherever S-parameters vary from the rational fitting model the most, more samples are taken.

1.
2.

w

From the Layout window, choose EMDS > Simulation > S-parameters .
Select the Adaptive Sweep Type and set these parameters to the following values:

e Start =1 GHz

e Stop = 40 GHz

e Sample Points Limit = 50
Click Add to Frequency Plan List .
Make sure that Open data display when simulation completes is enabled The S-parameters will automatically be
plotted and displayed at the end of the simulation.
Click Simulate . The simulation will be performed and its progress and completion will be indicated in the status
window.
Click EMDS > Simulation > Summary... and saved simulation details will be displayed. You can print the report if
you wish.
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Viewing Simulation Results

The S-parameter simulation results are automatically displayed on both rectangular plots and Smith charts in a Data
Display window. An example of S12 plotted on a rectangular plot is shown here.
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Substrates in EMDS

A substrate definition describes the media where a circuit exists. An example is the substrate of a multilayer circuit
board which consists of layers of metal traces, insulating material, ground planes, vias that connect traces, and the air
that surrounds the board. A substrate definition enables you to specify properties such as the number of layers in the
substrate, the dielectric constant, and the height of each layer for your circuit.

A substrate definition is made up of substrate layers and metallization layers. Substrate layers define the dielectric
media, ground planes, covers, air or other layered material. Metallization layers are the conductive layers in between
the substrate layers, and they are used in conjunction with the layout layers. By mapping layout layers to
metallization layers, you can position the layout layers that your circuit is drawn on within the substrate. An example
of a substrate is shown below. It contains four substrate layers and two microstrips with a via.
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Substrate definitions can be saved and used with other circuits. A variety of predefined substrates are included with
Advanced Design System, which can be used "as is", or modified to your design specifications.

The steps for defining a substrate include:

Defining the substrate layers

Mapping the layout layers to metallization layers
Specifying metallization layer conductivity
Solving the substrate

Details on how to work with existing substrate definitions and create new ones follow.

Selecting a Predefined Substrate

EMDS for ADS includes a number of predefined substrate definitions, so it may not be necessary to create a substrate
from scratch. Substrate files end with the extension .sIm.
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To open a predefined substrate:

1. In the layout window, select EMDS > Substrate > Open.

2. If you want to open a supplied substrate, click Yes. A list of supplied substrate files appears.
If you want to open a substrate that has been saved as part of the project, click No. A list of substrate files that
are saved as part of the project appear.
For more information on locating substrate files, refer to To save a named file, choose EMDS > Substrate >

Save. Identifying Where Substrates are Saved.
3. Select the substrate file, then click OK.

Creating/Modifying a Substrate

This section provides information about creating, modifying and editing a substrate. For information on metallization
layers, refer to Defining Metallization Layers.

Defining Substrate Layers

You can define a substrate from scratch or edit an existing one. A substrate must have, at the minimum, a top plane
and a bottom plane.

) Note

Do not use substrate components that might appear on layout component palettes. You must use the dialog
box under EMDS > Substrate > Create/Modify to create or edit substrate definitions.

To define substrate layers:

1. Choose EMDS > Substrate > Create/Modify.
2. If this is a new definition, three default layers appear in the Substrate Layers Field:

Free_space (top plane)

Alumina (dielectric)

GND (bottom plane)

These layers represent a basic substrate definition that includes the three types of substrate layers in EMDS
for ADS.

Free_Space represents the top plane of the substrate. In this definition, it is defined as an open boundary.
Alumina represents a dielectric layer of finite thickness. These layers are also referred to as interface layers.
GND represents the bottom plane of the substrate. GND defines a closed boundary. Closed boundaries
define ground planes or other closed boundaries, such as the lid or bottom of an enclosure.

For an existing substrate definition, you may see more layers with different names, but they will all be one
of these three basic types of layer, and the substrate will have a top and bottom plane. A substrate
definition must have a top plane and a bottom plane, and these planes can be defined either as open
boundaries or closed boundaries.

3. Select the layer of interest.
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4. To create a substrate, you will edit these layers, rename them, and add to them as desired. More information on
how to perform these tasks is detailed in the following sections.
5. When you are finished defining the substrate, click OK to dismiss the dialog box.

Defining an Open Boundary

An open boundary represents a layer of infinite thickness, such as air. An open boundary can be used to define other
gases or infinitely-thick materials by editing the relative permeability and permittivity values of the boundary.

To define an open boundary:

1. Select the Free_Space layer or another open boundary layer.
2. Select Open from the Boundary list.
3. From the Permittivity (Er) listbox, select a format for the relative permittivity of the boundary. You can enter the
components of relative permittivity as:

¢ Real and imaginary

e Real and loss tangent

e Real and conductivity, conductivity in Siemens/meter

The real portion of the relative permittivity, g, is a dimensionless quantity and is identical to the material's

relative dielectric constant, ¢ . For more information on this parameter, refer to Dielectric Permittivity.
r

To represent a dielectric that dissipates the power of a high-frequency electric field, enter the dielectric loss
tangent, g” /g”, of the material in the Loss Tangent field. The smaller the loss tangent, the less lossy the

material. For more information on this parameter, refer to Dielectric Loss Tangent.
Enter the components of the relative permittivity in the fields below the listbox.
4. From the Permeability (MUr) listbox, select a format for the relative permeability of the boundary. You can enter
the components of relative permeability as:
e Real and imaginary
e Real and loss tangent
The real portion of the relative permeability, u’ , is a dimensionless quantity and is identical to the

material's relative permeability constant. For more information on this parameter refer to Dielectric Relative
Permeability.

To represent a dielectric that dissipates the power of a high-frequency magnetic field, enter the magnetic
loss tangent, u”f u’ , of the material in the Permeability Loss Tangent field. The smaller the loss tangent,

the less lossy the material. For more information on this parameter, refer to Dielectric Magnetic Loss

Tangent.
Enter the components of the relative permeability in the fields below the listbox.

5. Click Apply to accept the open boundary definition.

@ Hint
You can create a ground plane from a open boundary layer by selecting the layer and choosing Close from the
Boundary list.
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Defining an Interface Layer

Interface layers have finite thickness, and they can be characterized using relative permittivity and permeability
values. The thickness of a layer can be an arbitrary value, with these considerations:

e Thin substrates are substrates less than one micron in thickness, and they require special meshing
considerations. Substrates less than 0.1 micron should be avoided.

e Thick substrates should be less than 0.5 wavelength in thickness. The recommendation for thick substrates is
based upon typical design values. For example, a 10 mil substrate with a cover height (air) of 300 mils would be
acceptable for frequencies up to 20 GHz, which is 0.5 wavelength.

To edit an interface layer:

1. Select the Alumina layer or other interface layer of interest.
2. Enter the thickness of the layer in the Thickness field and select the appropriate units in the adjacent listbox.
3. From the Permittivity (Er) listbox, select a format for the relative permittivity of the boundary. You can enter the
components of relative permittivity as:

¢ Real and imaginary

¢ Real and loss tangent

¢ Real and conductivity, conductivity in Siemens/meter

The real portion of the relative permittivity, g7, is a dimensionless quantity and is identical to the material's

relative dielectric constant, ¢ . For more information on this parameter, refer to Dielectric Permittivity.
r

To represent a dielectric that dissipates the power of a high-frequency electric field, enter the dielectric loss
tangent, g” /g*, of the material in the Loss Tangent field. The smaller the loss tangent, the less lossy the

material. For more information on this parameter, refer to Dielectric Loss Tangent.
Enter the components of the relative permittivity in the fields below the listbox.
4. From the Permeability (MUr) listbox, select a format for the relative permeability of the boundary. You can enter
the components of relative permeability as:
e Real and imaginary
¢ Real and loss tangent
The real portion of the relative permeability, u’ , is a dimensionless quantity. For more information on this

parameter refer to Dielectric Relative Permeability.
To represent a dielectric that dissipates the power of a high-frequency magnetic field, enter the magnetic

loss tangent, u”j l_l’ , of the material in the Permeability Loss Tangent field. The smaller the loss tangent,

the less lossy the material. For more information on this parameter, refer to Dielectric Magnetic Loss

Tangent.
Enter the relative permeability components in the fields below the listbox.

5. Click Apply to accept the layer definition.
Defining a Closed Boundary Layer

A closed boundary represents a plane, such as a ground plane. It is a layer with zero thickness. It can be defined as a
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perfect conductor, or you can specify bulk conductivity or sheet impedance to characterize it as a lossy conductor.
To edit a ground plane:

1. Select the ///GND/// layer of interest.
2. Select Closed from the Boundary list.
3. From the Plane listbox, select a format for the ground plane. You can specify the ground plane using these
parameters:
e Perfect conductor
e Bulk conductivity in Siemens/meter
e Sheet impedance in Ohms/square
Conductivity is entered as a real number. Impedance is entered as the real and imaginary components of a
complex value.
Enter the ground plane parameters in the field below the listbox.
4. Click Apply to accept the closed boundary definition.

& Hint
You can create an open boundary layer from a ground plane by selecting the ground plane and choosing Open
from the Boundary list.

Renaming a Layer

To rename a layer:

1. Select a substrate in the Substrate Layers list.
2. The name appears in the Substrate Layer Name field. Edit the name as desired.
3. Click Apply.

) Note

A ground plane is identified as ///GND/// and its nhame cannot be changed.

Deleting, Adding, and Moving Layers

To organize your substrate layers in the correct order, you can delete, add, and move layers.

To delete a substrate layer:

1. Select a substrate layer in the Substrate Layers list.
2. Click Cut. The layer definition is deleted.

To add a substrate layer:
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1. Select a substrate layer in the Substrate Layers list that has the same basic property (open boundary, closed
boundary, or finite thickness) as the layer you are adding.

2. Click Add .

3. The new layer is highlighted. To rename the new layer, edit the Substrate Layer Name field.

To move a substrate layer:

Select the substrate layer that you want to move from the Substrate Layers list.

Click Cut.

Select the substrate layer that you want positioned below the substrate that you are moving.
Click Paste.

PN

Defining Silicon Substrate Layers

The electrical behavior of Silicon material is usually specified using the dielectric constant and a resistivity (or
conductivity value).

For the dielectric constant, a value for g” of 11.8 (11.9 is usually used).

Resistivity (P ) values are normally specified in ohm cm, and a typical value is 10.
In EMDS for ADS, you can specify the conductivity (¢ ) in S/m (inverse of the resistivity).

For more information, see Dielectric Conductivity.

Calculating Conductivity from Resistivity

Conductivity is simply the inverse of resistivity. Make certain that the units of resistivity are ohms m before inverting.

Example:
1. p = 10 ohm cm
2. p = 10 ohm cm = 0.1 ohm m
3. ¢ =1/rho=10S/m

Defining Conductivity
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To define conductivity for silicon substrates:

Choose EMDS > Substrate > Create/Modify.

In the Create/Modify dialogue box, select RE, Conductivity under Permittivity ER).
Specify the substrate dielectric constant and conductivity (S/m).

When you are finished, click OK to dismiss the dialog box.

Sl

Defining Metallization Layers

Metallization layers enable you to:

¢ Define the position of layout layers in the substrate
e Specify which parts of the layer are conductive
¢ Define the conductivity of the layout layers

In order to identify which areas of a layout layer are conductive, a layer can be specified as:

e Strip-The objects on the layout layer are conductive, the rest of the layer is not

the hairpin filter objects are conductive and mapped to a strip
metallization layer

e Slot-The inverse of a strip, the objects drawn on the slot layout layer are the opposite image of the metals,
hence they are not conductive, but the rest of the layer surrounding the objects is conductive. When simulated,
EMDS for ADS considers the electric field distribution (the equivalent magnetic current flow) in the slot.

Slot metallization layer in
Physical Skot EMDS for ADS

€

metal etal

 Note
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Conductivity in slot metallization is ignored and perfect metallization is assumed.

e Via-The objects on the layout layer are conductive and cut vertically through one or more substrate layers. For
more information on how to draw and apply vias, refer to Applying and Drawing Vias in Layout.

Some examples of using strips and slots include:

e The patches of the Double_Patch antenna example. They are drawn on the layout layer named top_met, and are
conductive. This layout layer is mapped to a metallization layer that is defined as a strip.

e The slots of the Slot_dipole antenna example. The slots are drawn on the layout layer named slot. The slots are
not conductive, but the area surrounding the slots is. This layout layer is mapped to a metallization layer that is
defined as a slot.

Note that a layout can have many other layers that are not part of the actual circuit, such as text or error reporting
layers. For the purposes of an EMDS for ADS simulation, they are ignored. If layout layers containing parts of the
circuit are not mapped to metallization layers, they are ignored as well.

The steps for defining metallization layers are:

e Mapping a layout layer to a metallization layer
e Defining the conductivity of the layer
e Setting overlap precedence

Details for performing these steps are presented in the following sections.

Applying and Drawing Vias in Layout

EMDS for ADS creates a via by extruding the object that is mapped as via through the substrate layer it is applied to.
Vias are drawn as lines or closed polygons. A simple line segment via is the simplest and most practical way of
drawing a via. Vias drawn as lines are often called sheet vias because, when the line is extruded through the
substrate, it is treated as a horizontal metal sheet. For vias of other shapes, you draw a closed polygon. So, for
example, for a cylinder via you draw a circle. When the shape is mapped to a via metallization layer in EMDS for ADS,
another dimension is added to the object in order for the shape to cut through the substrate. Thus a line becomes a
sheet, a circle becomes a cylinder.
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| | | representations
of vias in Layout

/ bridige = —
via via — =
strip Fip via
| | vias extruded
through a
substrate layer
in EMDS for

Regardless of how you draw vias, avoid having them extend over the sides of the objects that they connect to. Vias
must be on the edge or inside the object. Any portion of the via outside of the object boundaries will not be taken into
account during the simulation. The figure below illustrates various vias connecting two strips.

Incorrect:
vias overlapthe
object edges.

Efficient via:
— sheet via with
width matching
width of strip.

Circular Via: '—|—'

correct, but Correct, but
may not be efficient. not as efficient
Use an appropriate as sheet via
arc recognition. with matching
width to strip.

Vias are treated in the following manner:

e Vias are represented as infinitely thin vertical sheets of metal. If a cylinder is drawn as a via, then it is also

treated as separate sheets of metal that comprise the cylinder walls.
e Vias are assumed to be opened, not covered, with current traveling on the sheet. Vias can be drawn as covered,
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using a cap (cover) of the same size as the via end, which is a terminating metal strip layout layer.

e A via cannot be coincident with another via if they cut through the same substrate layer and they are on different
layout layers. But two vias can be coincident on the same layout layer.

¢ Vias should be wholly contained within any primitives that are to be connected.

¢ Vias can be specified with loss but are considered to have zero thickness.

Vias through Multiple Substrate Layers

Vias can be applied to multiple layers so that they cut through one or more layers.

When drawing vias that cut through multiple substrate layers, each via must be drawn once on a single layout layer.
This layout layer must then be mapped as Via to each substrate layer that the via cuts through (using the
Metallization tab) to assign the via layer to all substrate layers.

_ In Layout:
(Top view) I:I One via drawn on

one Layout layer.

via 1
. . _ In EMDS for ADS:
(Side view) via 1 Four substrate layers
hawve onevia (process
via 1 layers) mapped to
each one.
via 1

Mapping a Layout Layer

Layout layers that contain any shapes or components that are part of the circuit must be mapped to metallization
layers. If layout layers are not mapped to metallization layers, they will not be included in the simulation.

To map a layout layer:
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Choose EMDS > Substrate > Create/Maodify.

. Click the Metallization Layers tab.

Select a layer from the Layout Layers list box. Note that the layout layer default cannot be mapped to a
metallization layer, the first valid layer is cond.
To map the layer as a slot or strip, select from the Substrate Layers list a dashed line to position the slot or strip
in between two substrate layers, then click Strip or Slot.
If you make a mistake, click Unmap, then click the correct choice.
e A Strip defines the objects on the layout layer as conductive, the area surrounding the objects is not.
e A Slot is the inverse of a strip, it defines the objects on the layout layer as not conductive, but the area of
this layer surrounding the objects is conductive. When simulated, EMDS for ADS considers the electric field
distribution (the equivalent magnetic current flow) in the slot.

Note
Conductivity in slot metallization is ignored and perfect metallization is assumed.

. To map the layer as a via, select the substrate layer that you want the via to cut through, then click Via.

If you want the via to cut through more than one layer, select the next layer, then click Via again.
¢ A Via defines the objects on the layout layer as conductive and they vertically cut through one or more
substrate layers.
To define the conductivity characteristics of this layer, refer to Defining Conductivity.

. If you have or suspect that you have overlapping layers, you need to set overlap precedence. Refer to Setting

Overlap Precedence.
Click the Apply button.

Unmapping a Layer

If you want to change the location of a layer or remove one from the substrate definition, use Unmap.
To unmap a layer:

uvhwne

Choose EMDS > Substrate > Create/Modify.

Click the Metallization Layers tab.

In the Substrate Layers list, select the substrate layer or the interface where the layout layer is mapped.
Click Unmap . This removes all layout layers assigned to this position.

To remap a layer, refer to the steps in Mapping a Layout Layer.

Via Simulation Models

EMDS for ADS only supports 3D Distributed via models. For information about 2D Distributed and Lumped via models
in Momentum, refer to the Via Simulation Models section in Chapter 3:Substrates of the Momentum documentation.

EMDS for ADS Layer Mapping GUI
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The EMDS for ADS layer mapping dialog has been enhanced to accommodate the new via models. The following
changes are implemented:

¢ Unmapped layers need to be mapped first before the layer properties can be defined. Hence, all layer properties
for an unmapped layer are made INVISIBLE.

e For Layers mapped as VIA, users can select one of the three simulation models (Lumped, 2D Distributed and 3D
Distributed).

e The 2D Distributed model is the default VIA model used for all pre-2006A substrate definitions.

e For Layers mapped as STRIP, you can select one of the three already existing geometrical models:

Sheet (No Expansion)

Thick (Expansion Up)

Thick (Expansion Down)

For Layers mapped as SLOT, there is only one selection option in the Model combo box "Ground Plane (Holes)"
Embedded Info in the dialog provides additional information about the selected layer properties.

The Thickness field is only visible for layers mapped as STRIP

The Overlap Precedence field is only visible for layers mapped as STRIP

Unmapped Layer

59



Advanced Design System 2008

Aumira 1A del
= STAIP cons?
JHITGND HA 1

Layered Mapped as STRIP
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Layer Mapped as SLOT

61



Advanced Design System 2008

Creale ™odify Substratesd

FreaSpace
- STRIP cond
Alumina Wik del

SRS GND AN

Layout Layer Mapped as VIA

Selection of Via Model
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reate M™Modify Substratesd

0
NI GND 28

Selection of Material
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Defining Conductivity

You can define a layout layer as a conductor or a resistor. If the layout layer is defined as a strip or via, you define the
conductivity of the strip or via. However, if the layout layer is defined as a slot, it is not possible to define the
conductivity of the metal around the slot. This is because a slot is assumed to be surrounded by a perfect conductor.

To define conductivity:

1. Choose EMDS > Substrate > Create/Modify.

2. Choose the Metallization Layers tab.

3. Select a mapped layout layer from the Layout Mapping list.

4. Select the conductor type from Type list in the Layout Layers section. Choose Sheet Conductor , Thick Conductor
(up) or Thick Conductor (down).

5. Set the Thickness.

6. Select the conductivity definition from the Conductivity list:

e Perfect conductor

e Sigma (Re, Im)

e Impedance (Re, Im)
Perfect Conductor means the strip, via, or metal around the slot is a perfect conductor and is lossless. No
further definition is required.
Sigma (Re, Im, thickness) specifies bulk conductivity as a complex number. Enter bulk conductivity's real
and imaginary value in the respective fields below the Conductivity list, in Siemens/meter or
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Siemens/centimeter. The imaginary value is important for super-conductivity applications. Enter the metal
thickness in the Thickness field above the Conductivity list and select the appropriate units. These values
will be used to calculate the dc and high frequency loss mechanisms when determining the equivalent
surface impedance. For example, the bulk conductivity of gold is 41,000,410 Siemens per meter with any
arbitrary thickness. The equivalent DC sheet impedance that will be used when conductivity and thickness
are specified is:

1
2= ——
bc iorxt)

where o r is the real part of the conductivity (S/m) and t is the thickness of the conductor (m).
At high frequencies, the equivalent sheet impedance will be equivalent to:

where & is the skin depth given by:

1
o=
N Tfligo

with f as the frequency (Hz) and p0 the free space permeability. This high frequency loss specification
corresponds to a single sheet skin-effect loss model, meaning that it assumes the current at high frequency
is assumed to be concentrated on one side of the finite thickness conductor.

Impedance (Re, Im,) specifies conductivity in terms of sheet impedance, in Ohms/square. Enter the real
and imaginary component of the value in the Real and Imaginary fields, respectively.

© Note

EMDS for ADS treats such metal layer definitions as a constant, frequency independent loss model. The
thickness entered in UI is ignored in this case.

7. When you are finished with the definition, click Apply.
8. Repeat these steps for the remaining mapped layout layers.
9. When you are finished, click OK to dismiss the dialog box.

Defining Finite Dielectrics

You can also define a layout layer as a dielectric. This enables you to define finite dielectric regions such as finite
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substrates, dielectric resonators, or implant regions inside semiconducting substrates.

 Note

Dielectric mask regions are only supported in EMDS for ADS. Any layout layer that is given a dielectric material
property will be ignored during Momentum simulations.

If the layout layer is defined as a strip or via, you define dielectric properties of the strip or via. However, if the layout
layer is defined as a slot, it is not possible to define the dielectric properties of the slot. This is because a slot is
assumed to be surrounded by a perfect conductor.

To define a dielectric region (as a thick strip):

1. Choose EMDS > Substrate > Create/Modify.

2. Choose the Metallization Layers tab.

3. Select a mapped layout layer from the Layout Mapping list.

4. Select the model type from Model list in the Layout Layers section. Choose Thick Conductor (up) or Thick
Conductor (down).

5. Set the Thickness.

6. Select the material definition from the Material list:

e Dielectric (Eps)
e Dielectric (Eps LossTan)
e Dielectric (Eps Sigma)
Dielectric (Eps) specifies the material property as a complex relative permeability. Enter the real and
imaginary relative permeability values in the respective fields below the Material list.
Dielectric (Eps, LossTan) specifies the material property as a real relative permeability and a loss tangent.
Enter the real relative permeability values in the Eps field and the loss tangent in the Loss Tan field.
Dielectric (Eps, Sigma) specifies the material property as a real relative permeability and a conductivity.
Enter the real relative permeability values in the Eps field and the conductivity (in Siemens/m) in the Sigma
field.
7. When you are finished with the definition, click Apply.
8. Repeat these steps for the remaining mapped layout layers.
9. When you are finished, click OK to dismiss the dialog box.

Automatic 3-D Expansion for Thick Conductors

Conductors with finite thickness can be modeled in EMDS for ADS using the 3D metal expansion feature. This feature
will automatically expand the mask of a conductor with finite thickness in the direction orthogonal to the layered
medium, using the specified thickness of this conductor.

Automated 3D expansion is activated by selecting either the Thick Conductor (up) or Thick Conductor (down)
expansion. In both cases, an extra dielectric layer is included in the internal EMDS for ADS substrate model. This is
done for each metal layer that is expanded. The thickness values of the dielectric layers in between the metal layers
are not changed, which will preserve the capacitance value between two conductors lying on top of each other in the
substrates.
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To select the automated 3-D Metal Expansion Substrate items:

Choose EMDS > Substrate > Create/Modify .

Click the Metallization Layers tab.
In the Substrate Layers list, select the substrate layer or the interface where the layout layer is mapped.

Select the Type drop-down list from the Layout Layer dialog box.
Choose either Thick Conductor (up) or Thick Conductor (down)

uhwN e

Substrate Layers \l Metallization Layers\]

select a layout layer to map as a stHp or slot to an interface plane (dashed line)
or as a via to a substrate layer:

Layer Mapping Layout Layer
Substrate Layers:
Name cond £
FreeSpace
------- Stipcond 7
Alumina Type Sheet Conductor
fHEERIE GND fAFEfEES Al
Thickness Thick Conductor (up)
Thick Conductor (down)
Conductivity Sigma (Re, Im) ¢ |
Real | 4. 10004E+07 Siemens/m ‘|
Imag | i} Siemens/m f |

For a perfect sheet conductor, the simulator ignores thickness.

Overlap Precedence

e (1|

:%é%ré;;l Mol | Wi | Unmapl

Simulations with automatic expansion require more simulation time and memory, but result in more accurate
simulation results. Typically, when the height/thickness aspect ratio is smaller than a factor of 5, the effect of
accounting for the finite thickness of the conductors will need to be allowed for in EMDS for ADS simulations.
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The following figure illustrates the internal substrate model when using an "up" and "down" expansion for a conductor.
In both cases, an extra dielectric layer is inserted (indicated with [new] in the figure), which in the case of an "up"
expansion has the dielectric properties of the layer above the metal layer. In the case of a "down" expansion, the new
layer has the material properties of the layer below the metal layer.

‘up’ expansion

: [diel2] h,, &, M,
[diel2] h,, &,.u, e

v v 9l

— 1 ’ &M,

[diel1] hy. &, [diel1] h,, &,

e e

‘down’ expansion

_ R [diel2] I h,,&,,u,
[diel2] h,,&,u,

[diel1] hy &1
I

© Note

Extra internal metallization layers are automatically added in EMDS for ADS to model the currents on all four
sides of the finite thickness conductor.

Setting Overlap Precedence
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Overlap precedence specifies which layout layer has precedence over another if two or more layout layers are
assigned to the same metallization layer and objects on the metallization layer overlap. Precedence is used by the
mesh maker so that objects on the layer with the greatest precedence number are meshed and any overlap with
objects on layers with lesser numbers is logically subtracted from the circuit. If you do not set the precedence, and
there are overlapping objects, a mesh will automatically and arbitrarily be created, with no errors reported. Resistive
layers generated from schematics are automatically set to the highest precedence.

Precedence = 1 Precedence = 2

: I
—

Cheerlap removed, geometry of object on top layer is altered

In some cases, you may be designing with an intentional overlap because of manufacturing layout guidelines. In this
case, assign a precedence number to the layout layers that overlap with precedence order in reverse numerical order
(largest to smallest). The system will draw the boundary at the edge of the higher numbered layer without returning
an error.

Precedence affects only how the mesh is created, it does not affect or alter the layout layers in your design.

To specify overlap precedence:

Choose EMDS > Substrate > Create/Modify.

Choose the Metallization Layers tab.

Select one of the overlapping layout layers from the list of Substrate Layers in the Layer Mapping section.
Assign its order of precedence in the Overlap Precedence field. Either type a value directly into the field or use
the arrow keys to select a value.

Click Apply.

Repeat these steps for the remaining overlapping layers.

7. When you are finished, click OK to dismiss the dialog box.

PN

o w

About Dielectric Parameters

The sections below give additional detail about the following dielectric parameters:

e Dielectric Permittivity
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Dielectric Loss Tangent

Dielectric Conductivity

Dielectric Relative Permeability

Dielectric Magnetic Loss Tangent

Dielectric Permittivity

The relative permittivity of all dielectrics is assumed to be complex:
£ =¢g+je"
which can also be expressed as:

e,

e =¢g(l +j%J

where g’ is the real portion of ¢ and g” /g’ is the dielectric loss tangent.

Examples of materials and their typical permittivity are shown in the following table:

Material Relative Permittivity
Alumina 9.8
Sapphire 9.3-11.7
Berrylia 6.0
Rutile 100.0
GaAs 12.9

© Note

The values listed in the table are for illustrative purposes only; use values specifically measured for the
materials that you are using.
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Dielectric Loss Tangent

Material <th
Alumina .0002
Glass .002
Berrylia .0001
Rutile .0004
GaAs .0016

© Note

These values are listed for illustrative purposes only. Use values specifically measured for the materials that
you are using.

Dielectric Conductivity

For some materials (for example, Silicon), the substrate loss effects are better described using the combination (g,

o = conductivity) instead of (g*, loss tangent). The complex dielectric constant is related to (g*, conductivity) using

the following formula:

£ = €& —((jo)/(wed))

where:

@ = 2 ¢ frequency

£() = 8.85e-12 F/m (absolute dielectric constant free space)
Often, resistivity (P ) is specified instead of conductivity. The relationship between resistivity and conductivity is:
p=1/c

Resistivity is usually specified in £} cm, conductivity is specified in S/m.
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Example:

A typical value for resistivity of a Silicon material is
p = 10 ) cm
which corresponds to a conductivity value of:

G = 10S/m.

Dielectric Relative Permeability
The relative permeability of all dielectrics is assumed to be complex:
nw=pu+ju"

which can also be expressed as:

= w1+
=W+

where | is the real portion of 1L and u”;’“_’ is the magnetic loss tangent.

Examples of relative permeabilities are shown in Materials and Relative Permeability.

Material Relative Permeability
Gold .99996
Air 1
Aluminum 1.00002
Nickel 250
Iron 4000

 Note

The values listed above are for illustrative purposes only. Use values specifically measured for the materials
that you are using.
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Dielectric Magnetic Loss Tangent

The magnetic loss tangent associated with a material is a function of frequency. An example of a material with a
magnetic loss tangent is polyiron which, at 30 GHz, has a loss tangent of 0.0208.

Reading a Substrate Definition from a Schematic

Choose EMDS > Substrate > Update From Schematic to update a substrate under the following conditions:

e You have used a substrate component on a schematic, such as MSUB or SSUB
e You have already generated a layout from the schematic using Layout > Generate/Update Layout
e You then change the substrate definition on the schematic, and need to transfer it to the layout

In order to retrieve the new substrate information, you must use EMDS > Substrate > Update From Schematic . Using
Layout > Generate/Update Layout will not transfer the new substrate information to the layout.

To update a substrate definition from a schematic:

1. Choose EMDS > Substrate > Update From Schematic. The substrate on the correct schematic is read and the
new information is entered in the EMDS for ADS substrate definition.

Saving a Substrate

A substrate definition can be saved to a file. This enables you to store the definition outside of the current project,
making it easier to use the substrate definition in other designs.

To save a substrate:

1. Choose EMDS > Substrate > Save As.

2. Type a name for the file and click OK . Substrate files end with the extension .sim
To save a named file, choose EMDS > Substrate > Save. Identifying Where Substrates are Saved
Substrates are saved in one of two locations:

¢ In the directory containing supplied substrates, which is $HPEESOF_DIR/momentum/lib . You should not use this
location for substrates that you have created or modified.
e The substrate information is saved in a file called <substrate_name> .sIm under /networks in the current project

directory.

73



Advanced Design System 2008

Reusing Substrate Calculations

Substrate definitions and substrate computations can be reused for other designs, if the substrate database is
accessible. If you are unsure about access to the database, consult your system administrator.

Before a calculation begins, several folders are searched to determine if a solution has already been generated.
The folders searched, in order, are:

e The project substrates folder
e The home substrates directory or the site substrates directory (made available by your system administrator)
¢ The folder containing the EMDS for ADS supplied substrates ($HPEESOF_DIR/momentum/lib/substrates )
If the Substrate Calculator finds the same substrate definition, regardless of the name, it uses the one it finds
instead of recomputing the same information.

Deleting a Substrate

This command erases the substrate file (.sIm) that you select. If the substrate has been precomputed, the calculations
remain in the database.
To delete a file:

1. Choose EMDS > Substrate > Delete .
2. Select the name of the file that you want to delete.
3. Click OK.

Substrate Examples

Use the following examples to help you set up your own circuits:

e Substrate for Radiating Antennas

e 377 Ohm Terminations and Radiation Patterns

e Substrate for Designs with Air Bridges

Substrate for Radiating Antennas
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To define a substrate for an antenna that radiates into air, you can set up the following substrate definition:

Substrate Layers

Free Spacel
Free Spacez2

Both layers are defined as open boundaries with the characteristics of air (for permittivity and permeability, Real = 1,
Loss Tangent = 0). The antenna design is positioned on the metallization layer in between the two layers of air.

377 Ohm Terminations and Radiation Patterns

It is possible to define the top and bottom layers of a design with 377 ohm terminations, then calculate radiation
patterns for these structures after simulation. For such applications, note the following considerations:

e The actual value of the termination may be between 376 and 378 ohms.

e When replacing top or bottom ground layer with a 377 ohm termination, a thick layer of air in between the circuit
and the 377 ohm termination is required in order to get agreement (both for S-parameter results and radiation
patterns) with the simulation results with infinite top or bottom layer. An air layer of 10-20 substrate thicknesses
is generally thick enough.

e There is a test on the impedance value prior to calculating the radiation patterns. The impedance value must be
in the interval (377 - 10) to (377 + 10) ohm.

Substrate for Designs with Air Bridges

In order to designing a substrate definition for a design that contains an air bridge, you need to first identify
components of the air bridge and their placement on layout layers. Refer to the illustration that follows.

A basic air bridge between two components consists of the follow items:

A via that connects the bridge to the first component

The bridge itself

A second via to complete the path to the second component
The layer of air underneath the bridge

The layout must be drawn on at least three independent layers:

e The vias must be on at least one layer
e The bridge must be on a different layer
¢ The components must be on yet another layer
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No two items that comprise the air bridge (except for the vias) can be on the same layer. For this illustration, the
components that are connected by the air bridge are on the same layer.

The substrate definition would consist of the following items:

¢ An open boundary of air
¢ An interface layer of air at a finite thickness. This represents the layer of air under the bridge.
e An interface layer of dielectric material

You map the layout layers to the substrate as follows:

e The bridge is mapped to the metallization layer that is in between the "Free_Space" substrate layer and the "air"
substrate layer.

e The vias are mapped to cut through the finite "air" substrate layer.

e The components are mapped to the metallization layer in between the air substrate layer and the dielectric layer
"GaAs" layer.

It is not required for the components that the bridge connects to be on the same layout layer or mapped to the same
metallization layer. Nor do the vias need to be on the same layout layer. Just be sure that the substrate definition has
the correct number of substrate layers and that the components, vias, and bridge are mapped to the appropriate
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Substrate Layer Setup

Substrate Layers

Air, boundary is Open

Free_Space
air Air under bridge, thickness is specified
GaAs Dielectric, thickness is specified

Metallization Layer Mapping

Substrate Layers:

Free Space
Map bridge here — |---—--- Strip bridge
Map vias here air ” via

Map strips here —— I Stﬂp

Physical Circuit G

/ Ericige 7 air2

. via
via
strip TEE

Drawing Air Bridges in Layout

If you are simulating an air bridge, you will have to create a layout and a substrate definition that will support the
geometry. This means adding an air layer (height equal to the air bridge) which the vias will cut through. For
example, you would have some geometry (like a spiral) on a dielectric layer. Then a via would rise vertically cutting
through the air layer, where it would connect to a metal bridge. Then another via would connect from the bridge,

down to the previous layer, and onto another path.
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/ air brdge /|
via 1 via 2
// " metal /

~ meta

Silicon Substrate

The following is an example of a silicon substrate used in a EMDS for ADS simulation (this example is taken from
examples > Momentum > Microwave > SPIRAL_prj ):

Free space

Layer3 (Eps=3.9) | via

............... spiral (strip)

Layer2 (Eps=3.9)
Layer1l (Eps=11.9 ; cond=12.5 S/m
G\D

Silicon Substrate with 3D Expansion

The following is an example of a silicon substrate used with automatic expansion of a thick conductor:
Free space
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----------------- Strip thick conductor up (thickness 4 m| conductivity

Sigma Re: 5e+6 S/nm
Alumi na (Eps=9.6 ; Thickness=25 ml)
G\D

With the Thick conductor up selected, the substrate used for the simulation will become:

Free space
................. Strip

air | via (substrate layer thickness 4 mil|l ; Eps =1)
................. Strip

Al umina (Eps=9.6 ; Thickness=25 ml)
G\D

For more information on automatic 3-D expansion for thick conductors, refer to Automatic 3-D Expansion for Thick
Conductors.

Ports in EMDS

Ports enable energy to flow into and out of a circuit. Energy is applied to a circuit as part of the simulation process. A
circuit solved using EMDS for ADS must have, at the minimum, one port.

Ports are defined in a two-step process. First, ports are added to a circuit when the circuit is drawn. Then, in EMDS for
ADS, you specify the type of port in order to tailor the port to your circuit. This facilitates the simulation process.

This chapter begins with suggestions to keep in mind when adding ports to a circuit that will be simulated using EMDS
for ADS. The remainder of this chapter describes the various port types in EMDS for ADS and gives instructions on
how to specify a port type.

Adding a Port to a Circuit
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You can add a port to a circuit either from the Schematic window or a Layout window. For instructions on how to add a
port to a circuit, refer to Adding a Port to a Circuit. The procedures include considerations for adding ports to a circuit
that will be simulated using EMDS for ADS.

Considerations

Keep the following points in mind when adding ports to circuits to be simulated using EMDS for ADS:

e The components or shapes that ports are connected to must be on layout layers that are mapped to metallization
layers that are defined as strips or slots. Ports cannot be directly connected to vias. For information on how to
define strips and slots, refer to Defining Metallization Layers.

e Make sure that ports on edges are positioned so that the arrow is outside of the object, pointing inwards, and at
a straight angle.

e Make sure that the port and the object you are connecting it to are on the same layout layer. For convenience,
you can set the entry layer to this layer; the Entry Layer listbox is on the Layout tool bar.

v, s slot j

e A port must be applied to an object. If a port is applied in open space so that is not connected to an object,
Momentum will automatically snap the port to the edge of the closest object. However, EMDS for ADS will leave
the port unattached to the structure. This difference will not be apparent from the layout, however, because the
position of the port will not change.

o If the Layout resolution is changed after adding ports that are snapped to edges, you must delete the ports and
add them again. The resolution change makes it unclear to which edges the ports are snapped, causing errors in
mesh calculations.

 Note

Do not use the ground port component ( Insert > Ground ) in circuits that will be simulated using EMDS for
ADS. Ground components placed in layout are not recognized by EMDS for ADS. Either add ground planes to
the substrate or use the ground reference ports that are described later in this chapter.

Ground port component toolbar button: ES

Determining the Port Type to Use

There are five port types in Momentum. However, only three of these port types are supported in EMDS for ADS. The
purpose of ports is to inject energy into a circuit and to allow energy to flow into and out of a circuit. The different port
types enable you to tailor the ports in your circuit according to your type of circuit and its function in the circuit. In
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general, you should select the port type that best matches the intended application of your layout.

The table below gives a brief description of each port type. You can use a combination of port types in your circuit,
although you should note that port types have limitations on where they can be applied. Only the Single port type can
be applied to objects that are on either strip or slot metallization layers. Only the Internal and Ground Reference types
can be applied to ports that are on the surface of an object, the remaining types can be applied to ports that are
connected to an edge of an object.

© Note

Strips and slots refer to metallization layers. For more information on these layers, refer to Defining
Metallization Layers.

If you elect not to assign port types, any port in the circuit will be treated as a Single port type during simulation.

 Note
All port types can be defined in both Momentum and EMDS for ADS. However, EMDS for ADS only supports
Single , Internal , and Ground reference port types.

Port Type Description Port Connected to Object on Simulation Support

Single (default) The port is calibrated = Edge of object Strip or slot layer Momentum
to remove any mode
mismatch at the port
boundary. Single
ports on slot layers
have polarity. Unless
a port is given
another type, it will
be treated as a single
port.

Internal The port is not Edge or surface of Strip layer Momentum
calibrated. It is useful | object
for making a
connection with
lumped elements or
for representing
other connections in
the circuit.

Differential Two ports with Edge of object Strip layer Momentum
opposite polarity. The
port pair is simulated
as a single port.

Coplanar Two ports with Edge of object Slot layer Momentum
opposite polarity. The
port pair is simulated
as a single port.
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Common mode Two or more ports Edge of object Strip layer Momentum

excited with the
same absolute
potential and the
same polarity. The
ports are simulated
as a single port.

Ground reference Use an explicit Edge or surface of Strip layer Momentum

ground for a single object
(strip), internal, or

common mode

port.Implicit ground

is made available

through the closest

infinite metal, when

no explicit ground

port is present.

Additional details about each port type and how to define them are given in the following sections.

Defining a Single Port

Single is the default port type. It has the following properties:

It is connected to an object that is on either a strip or slot metallization layer.

It can be applied only to the edge of an object.

The port is external and calibrated. The port is excited using a calibration process that removes any undesired
reactive effects of the port excitations (mode mismatch) at the port boundary.

EMDS for ADS requires single ports to be on a bounding box that surrounds the circuit. Ports that are not on this
bounding box will be treated as Internal ports.

The port boundary can be moved into or away from the geometry by specifying a reference offset. S-parameters
will be calculated as if the port were at this position. For more information, refer to Applying Reference Offsets.

When two or more single ports are on the same reference plane, coupling effects caused by parasitics affects the
S-parameters. The calibration process might group the ports so that any coupling in the calibration arms is
included in the S-parameter solution. For more information, refer to Allowing for Coupling Effects.

If the port is connected to an object on a strip layer, the substrate definition must include at least one infinite
metal layer: a top cover, ground plane, or a slot layer, or a ground reference must be used in addition to the
port. For more information on ground references, refer to Defining a Ground Reference.

If the port is connected to an object that is on a slot layer, the port has polarity.

Hint
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It is not necessary to open the Port Editor dialog box to assign this port type. Any port without a port type
specified is assumed to be a single port.

Physical port boundary

L

Calibration arm remowves

mismatch

p2

To define a single port type:

Choose EMDS > Port Editor.

Select the port that you want to assign this type to.

In the Port Editor dialog box, under Port Type, select Single .

Enter the components of the port impedance in the Real and Imaginary fields, and specify the units.

You can shift the port boundary, also referred to as the port reference plane. Shifting the boundary enables a
type of de-embedding process that effectively adds or subtracts electrical length from the circuit, based on the
characteristic impedance and propagation characteristic of the port. Enter the offset in the Reference Offset field,
and select the units. A positive value moves the port boundary into the circuit, a negative value moves the port
boundary away from the circuit.

6. Click Apply to add the definition to the port.

uvnhwne

Avoiding Overlap

Be aware that when using single ports in EMDS for ADS, they must be placed on the bounding box of the circuit. If a
port is not on the bounding box, the port will be changed to an internal port type, and no calibration will be performed
on it. For information about internal ports, refer to Defining an Internal Port.

internal port will be used instead.

|

r P | The port is on the bounding box. An
!
I

— p2
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 Note

Momentum allows single ports to be off of the bounding box as long as this does not lead to overlapping
calibration arms. For more information, refer to the section on Avoiding Overlap in Chapter 4: Ports of the
Momentum documentation.

Applying Reference Offsets

Reference offsets enable you to reposition single port types in a layout and thereby adjust electrical lengths in a
layout, without changing the actual drawing. S-parameters are returned as if the ports were placed at the position of
the reference offset.

S-parameters will be calculated S-parameters will be calculated as if p1 and p2
based on the positions of p1 and p2 were positioned at the reference offsets
| | [
I |1
| I
p1 p2 =
p L p2
| I
I
[

reference offsets applied to p1

no reference off set and p2

Why Use Reference Offsets?

The need to adjust the position of ports in a layout is analogous to the need to eliminate the effect of probes when
measuring hardware prototypes. When hardware prototypes are measured, probes are connected to the input and
output leads of the Device Under Test (DUT). These probes feed energy to the DUT, and measure the response of the
circuit. Unfortunately, the measured response characterizes the entire setup, that is, the DUT plus the probes. This is
an unwanted effect. The final measurements should reflect the characteristics of the DUT alone. The characteristics of
the probes are well known, so measurement labs can mathematically eliminate the effects of the probes, and present
the correct measurements of the DUT.

There are significant resemblances between this hardware measurement process and the way EMDS for ADS operates.
In the case of EMDS for ADS, the probes are replaced by ports, which, during simulation, will feed energy to the circuit
and measure its response. The EMDS for ADS port feeding scheme also has its own, unwanted effect: low-order mode
mismatch at the port's boundary, although this is eliminated by the calibration process. However, in order for this
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calibration process to work well, it is necessary that the fundamental mode is characterized accurately. This can only
be accomplished when the distance between the port boundary and the first discontinuity is sufficiently large, that is,
there exists a feedline that is long enough to provide this distance.

As a basic example, consider a linewidth that varies abruptly in some part of your circuit, as shown in the example
below.

Strictly speaking, all you need is to characterize is the variation of the step-in-width itself, as shown below.

p1 p2

As mentioned previously, it takes a little distance for the fundamental mode to settle, which means that this "short"
structure might not yield the accuracy that you expect from an EMDS for ADS simulation. In this case, allow for some
feed line length:

pl

Now the simulation will yield accurate results, but the results will also contain the extra line lengths. To remedy this,
use reference offsets. Although the circuit has been calculated with the long lines, reference offset shifting allows you
to produce the S-parameters as if the short structure had been simulated instead:
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pl - p2

apply reference offsets atthese
locations

The effect of the extra feed lines is mathematically eliminated from the S-parameter solution.
This process of adding or subtracting line length is generally referred to as de-embedding.

This is the basic process:

During the solution process, the impedance and propagation constant has been calculated for the ports, based on their
physical location in the circuit. When you know the impedance, propagation constant, and the distance of
de-embedding, you can cancel out the extra lengths of line from the S-parameter results, by compensating for the
loss and phase shifts of those lines. The net result is a set of S-parameters, calculated as if the extra line lengths were
not there.

De-embedding Considerations

It is possible to de-embed right up to the discontinuity itself. However, make sure that you do not shift the reference
offset beyond the first discontinuity. This would yield incorrect simulation results, as there is another linewidth beyond
that discontinuity, which means that there is another set of impedance and propagation values that applies there.

 Note

You can de-embed away from the circuit, by placing reference offsets beyond the edges of the layout. This
enables you to simulate the effect of a long feed line that was not drawn in the simulated structure.

Allowing for Coupling Effects

If you have two or more single ports that lie on the same reference plane, the calibration process will take into
account the coupling caused by parasitics that naturally occurs between these ports. This yields simulation results that
more accurately reflect the behavior of an actual circuit.

The following figure helps illustrate which ports will be grouped in order for the calibration process to account for
coupling among the ports. In this setup, only the first two ports will be grouped, since the third port is an internal port
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type and the fourth port is on a different reference plane. Note that even though the second port has a reference
offset assigned to it, for this process they are considered to be on the same plane and their reference offsets will be
made equal.

If you do not want the ports to be grouped, you must add metal to the edge of the object that one of the ports is
connected to. The ports will no longer be on the same plane, and will not be considered part of the same group.

' reference plane

single i part 1

single, with reference |
offset 1 port2
mtemal 1 port 3
single 1 ] pont4

Defining an Internal Port

Internal ports enable you to apply a port to the surface of an object in your design. By using internal ports, all of the
physical connections in a circuit can be represented, so your simulation can take into account all of the EM coupling
effects that will occur among ports in the circuit. These coupling effects caused by parasitics are included in your
simulation results because internal ports are not calibrated. You should avoid geometries that allow coupling between
single and internal ports to prevent incorrect S-parameters.

An example of where an internal port is necessary is a circuit that consists of transmission lines that connect to a
device, such as a transistor or a chip capacitor, but this device is not part of the circuit that you are simulating. An
internal port can be placed at the connection point, so even though the device is not part of the circuit you are
simulating, the coupling effects that occur among the ports and around the device will be included in your simulation.

Internal ports are often used in conjunction with ground references. For more information, refer to Defining a Ground
Reference.

An internal port type has the following properties:
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e It can be applied to the interior of a circuit by applying it to the surface of an object.

e It can be applied to the edge of an object.

e It can be applied to objects that are on strip layers only.

e The orientation of the port is not considered if it is on the surface of an object. (For a description of port
orientation, refer to Adding a Port to a Layout.)

¢ No calibration is performed on the port.
Because no calibration is performed on the port, the results will not be as accurate as with a single port.
However, the difference in accuracy is small.

Ports 1 and 2 are internal
parts

!
H

To define an internal port:

Choose EMDS > Port Editor.

Click the port that you want to assign this type to to select it.
In the Port Editor dialog box, under Port Type, select Internal.
Click Apply.

Ll

Defining a Ground Reference

Ground references enable you to add explicit ground references to a circuit, which may be necessary if no implicit
grounds exist in your design.

Implicit ground is the potential at infinity, and it is made available to the circuit through the closest infinite metal layer
of the substrate. Implicit grounds are used with internal ports and with single ports that are connected to objects on
strip metallization layers.

There are instances where the distance between a port and its implicit ground is too large electrically, or there are no
infinite metal layers defined in the substrate. In these cases, you need to add explicit ground references to ensure
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accurate simulation results.

You can apply ground references to the surfaces of object. The object must be on strip metallization layers.

 Note

Multiple ground reference ports can be associated with the same port. To be associated with a single port, the
ground reference port should be a port attached to an edge of an object in the same reference plane as the
single port.

To add a ground reference:

1. Choose EMDS > Port Editor.

2. Select the port that you want to assign as the ground reference.

3. In the Port Editor dialog box, under Port Type, select Ground Reference.

4. Under Associate with port number , enter the number of the single or internal port that you want to associate
with this ground reference. Make sure that the distance between the port and ground reference is electrically
small.

5. Click Apply.

The EMDS for ADS Port Editor

Once the substrate and dielectric layers have been defined, the Port Editor ( EMDS > Port Editor... ) can be used to
change the Momemtum specific characteristics of ports in a layout. You edit the port in the same manner as when you
entered the initial definition.

) Note

Be aware that it is possible to edit port properties by selecting the port and choosing Edit > Properties from
the Layout menu bar, however, this method is not recommended .

For more information on setting port definitions see the appropriate section:

Defining a Single Port
Defining an Internal Port

Remapping Port Numbers

Some designs contain non-consecutive port numbers. This results in simulation data files that are difficult to use.
When EMDS for ADS simulates designs containing non-consecutive port numbers, the ports are remapped to
consecutive numbers in the resulting data file. The lowest port number is remapped to 1, and remaining numbers are
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remapped in consecutive order. The port humbers are not changed in the design itself .

3D Extension

When you specified the substrate definition of a circuit (from the EMDS > Substrate menu), you specified only the
vertical dimension of the substrate and not the horizontal dimension. Given this definition, the base substrate layers
extend all the way to infinity in the horizontal direction. For many circuit designs this is not relevant and does not
affect the simulation. However, there may be instances where you want to introduce horizontal boundaries. For these
instances, you can use boxes or waveguides.

Additionally, since EMDS for ADS uses a Finite Element simulation technique, the EM problem domain needs to have a
finite extent. Even if your actual substrate is much larger than the circuit you want to simulate, the problem domain
will be automatically truncated by the EMDS for ADS simulator. You can control how this truncation is determined.

Boxes and waveguides enable you to specify substrate boundaries in the horizontal direction. A box enables you to set
boundaries on four sides of the substrate. A waveguide enables you to set boundaries on two sides.

More specifically, for a box, you define four, perpendicular vertical planes of perfect metal as the horizontal boundaries
of the substrate. These four vertical planes, or walls, form a rectangle, if you are looking at the circuit from the top,
along the z-axis. A box can be used only where the top and bottom layers in the substrate definition are groundplanes
or impedance termination. Thus, the four vertical metal walls, plus the top and bottom groundplanes result in a box,
hence the name (the walls are the sides, and the top and bottom ground planes are lid and base of the box).

A box canrepresent a highly resonan metallic
endaosure. Bz eflect wil be laken imo accoun during
gimulaion.

A waveguide is similar, although for a waveguide you specify only two parallel walls. The substrate is therefore only
bounded in the horizontal direction perpendicular to these walls. In the horizontal direction parallel to these walls, the
substrate still extends to infinity. The top and bottom layers of the substrate must also be defined as groundplanes.
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A waveguide enables you to take into account the effects of sidewalls
near the circuit, or verify that sidewalls do not affect your design.

waveguide

The next section describes how to apply a box or waveguide to a circuit. For more information about applications for
these items, refer to About Boxes and Waveguides.

Auto-extend Boundary

Auto-extend Boundary

EMDS for ADS solves for the electric fields associated with the circuit using the Finite Element Method. As the name
implies, this requires a finite problem domain. The Auto-extend Boundary dialog enables you to control how this
truncation is computed.

Setting a Lateral Extension

To set the lateral extension:

1. Choose EMDS > 3D Features > Auto-extend Boundaries . Enter a value in the Substrate LATERAL extension and
select the desired units.
2. Click OK.

Prior to simulation, EMDS for ADS will create a bounding box that surrounds the circuit. All four edges of this bounding
box will be extended in the X- and Y-directions by the distance specified, unless:

e A__ Box is defined (the Box specification is used), or
¢ A Waveguide line is parallel to the bonding box edge (the Waveguide specification is used), or
e A Single Mode port lies on the bounding box edge (the domain is trucated at the port).

The EMDS for ADS problem domain is trucated by this modified bounding box. The effect of this truncation can be
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seen by selecting EMDS > 3D EM Preview .

Setting a Vertical Extension

To set the vertical extension:

1. Choose EMDS > 3D Features > Auto-extend Boundaries . Enter a value in the Substrate VERTICAL extension and
select the desired units.
2. Click OK.

If the uppermost or lowermost substrate layer is specified as an Open Boundary , then the uppermost/lowermost
substrate will be constructed as a layer with the given Vertical Extension thickness and an Open (absorbing) boundary
condition to truncate the problem domain.

The EMDS for ADS problem domain is trucated by this modified bounding box. The effect of this truncation can be
seen by selecting EMDS > 3D EM Preview .

Setting the Wall Boundary

To set the boundary condition on the lateral termination:

1. Choose EMDS > 3D Features > Auto-extend Boundaries , then select a boundary condition from the pull-down
list.

2. Click OK.
The selected boundary condition will be applied to all the side walls of the problem domain. The boundaries that
can be selected are:

e Open an absorbing boundary is applied to approximate an infinite extension

e Perfect Conductor the side walls are perfect (lossless) conductors

e Conductor (Sigma) the side walls are lossy conductors with the given conductivity

e Conductor (Impedance) the side walls are lossy conductors with the given complex impedance
e Perfect MagWall the side walls are perfect (lossless) magnetic walls

Merging Substrate Layers

When the Merge adjacent layers with the same material properties check-box is selected, EMDS for ADS will create a
3D representation where only one object defines all adjacent substrate layers with the same material property. This
will typically result in slightly faster simulations, particularly if any of the adjacent layers are very thin. If you want the
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3D geometry representation to consist of a separate object for each substrate layer, then un-select this check-box.

Adding a Box

A box defines the boundaries on four sides of the circuit substrate. Either one box or one waveguide can be applied to
a circuit at a time. A box can be applied to a circuit only if the top and bottom layers of the substrate definition are
defined as groundplanes or impedance termination. The walls of the box are perfect metal. The ground planes can be
defined either as perfect metals or a lossy metal.

Adding a box to the circuit enables you to analyze the effects of enclosing the circuit in metal; for example, to identify
box resonance. Box resonance can have a significant effect on S-parameters in a small band centered around the box
resonance frequency.

 Note

Single ports in the circuit must be located on, and perpendicular to the box edge, or an error will occur.
Internal (uncalibrated) ports may be placed anywhere in the circuit and point in any direction.

To add a box:

1. Choose EMDS > 3D Features > Add Box.
2. Insert the box using one of the following two methods:
¢ Position the mouse and click to define a corner of the box. Move the mouse to the diagonal corner and click.
e From the Layout menu bar choose Insert > Coordinate Entry and use the Coordinate Entry X and
Coordinate Entry Y fields to specify a corner of the box. Click Apply . Enter the coordinates of the diagonal
corner and click Apply. Click Cancel to dismiss the dialog box.

The box is then displayed in the layout.

Editing a Box

Once the box is applied, you cannot change its dimensions. If you want to change the size, you must delete the
current box and add a new one.

Deleting a Box

To delete a box:

1. Choose EMDS > 3D Features > Delete Box.
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The box is removed from the layout.

Viewing Layout Layer Settings of a Box

The box is defined as a layout layer named momentum_box . You may review the layout layer settings, but it is a
protected layer, so you should not change the settings of this layer.

To view the box layer specifications:

[y

Choose Options > Layers .
2. Select momentum_box from the Layers list; the layer settings are displayed. For more information on these

parameters, refer to the Schematic Capture and Layout documentation.
3. Click Cancel to dismiss the dialog box.

Adding a Waveguide

A waveguide defines the boundaries on two, parallel sides of the circuit substrate. Either one box or one waveguide
can be applied to a circuit at a time. A waveguide can be applied to a circuit only if the top and bottom layers of the
substrate definition are defined as groundplanes or impedance termination. The walls of the waveguide are perfect

metal. The ground planes can be defined either as perfect metals or metal with loss.

During a simulation, all current directions on the sidewalls of the waveguide are taken into account.

To add a waveguide:

Choose EMDS > 3D Features > Add Waveguide .

2. Select the direction of the waveguide. To insert the waveguide parallel to the x-axis, click X-axis. To insert the
waveguide parallel to the y-axis, click Y-axis.

3. Insert the waveguide using one of the following two methods:

e Position the mouse and click to define one wall of the waveguide. Move the mouse to the position of a point
on the second wall and click.

e From the Layout menu bar choose Insert > Coordinate Entry and use the Coordinate Entry X and
Coordinate Entry Y fields to specify a point on the edge of the substrate. Click Apply.

[y

Enter the coordinates of a point on the second, parallel edge of the substrate and click Apply.

Click Cancel to dismiss the dialog box.

These boundaries specify the edges of the substrate and the width of the waveguide.
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Editing a Waveguide

Once the waveguide is applied, you cannot change its dimensions. If you want to change the size, you must delete the
current waveguide and add a new one.

Deleting a Waveguide

To delete a waveguide:

1. Choose EMDS > 3D Features > Delete Waveguide.
The waveguide is removed from the layout.

Viewing Layout Layer Settings of a Waveguide

The waveguide is defined as a layout layer named momentum_box . You may review the layout layer settings, but it is
a protected layer, so you should not change the settings of this layer.

To view the waveguide layer specifications:

1. Choose Options > Layers .

2. Select momentum_box from the Layers list. The layer settings are displayed. For more information on these
parameters, refer to the Schematic Capture and Layout manual.

3. Click Cancel to dismiss the dialog box.

About Boxes and Waveguides

There are a variety of reasons why you would want to simulate a circuit in a box or waveguide:

The actual circuit is enclosed in a metal box

Nearby metal sidewalls may affect circuit performance
The box may resonate

Propagating modes may be present

These situations are discussed next.

Circuits are often encased in metal enclosures. By adding a box to your design, the metal sidewalls that are present in
the real structure may be included in the simulation. This is useful if you suspect that the presence of these sidewalls
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will have an immediate effect on the behavior of the circuit. For example, "broad-coupled filters" are placed in metal
enclosures (a box) and the sidewalls can have a significant influence on the filter characteristics.

You may want to use a box or waveguide because metal sidewalls are present in the real structure and there may be
an effect from these sidewalls on the characteristics of the circuit. This can be a parasitic, unwanted effect. If the
effects of the sidewalls were not taken into account while designing the circuit, you can verify any effect that the
sidewalls may have on your circuit. In most cases, when the sidewalls are not too close to the actual circuit, the effect
of the sidewalls on the simulation results will be marginal. There is however a specific, significant condition, which is
unique for structures with sidewalls.

In the case of a box, this is the occurrence of one or more box resonances. A box resonance is a physical effect where,
under the condition of certain frequency and box size combinations, the box actually starts resonating at a certain
frequency. Because a box resonance has a significant effect on S-parameters in a (small) band centered around the
box resonance frequency which cannot be represented by a smooth function, no smooth adaptive S-parameters will be
available in this frequency band.

In the case of waveguide, the effect is the excitation of a waveguide mode. If your circuit will be positioned near
sidewalls, you may want to add a waveguide to determine whether they have an effect on the performance of the
circuit.

Adding Absorbing Layers under a Cover

You may want to model your box or waveguide as having absorbing layers between the covers and the layout. You
can use a substrate interface layer, define its thickness, and its absorbing properties using &epsilon; and p (make sure
that &epsilon; and p are accurate specifications for this layer). Adding absorbing layers to a box would have an effect
on any box resonances that would occur by producing a weaker resonance, that is, the quality factor of the box
resonances would lower significantly.

Boxes, Waveguides, and Radiation Patterns

If you have a structure enclosed in a box or waveguide and you want to calculate radiation patterns for it after the
simulation, you need to set the top and bottom planes to values between 376 and 378. There are also other
considerations. For more information, refer to 377 Ohm Terminations and Radiation Patterns.

3D EM Preview

Before simulating your design using the EMDS simulator, it is recommended that you validate that your three
dimensional design has been properly constructed. This will give you confirmation of your design and also simulation
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of designs which are not correct. The representation seen in the viewer is the same definition that will be used in
EMDS. If the view does not appear to be correct, it is essential that the you correct the design before attempting a
simulation.

The key benefits of this visual confirmation are:

e Correct Substrate Set Up - The substrate information within ADS is defined using the Substrate menu options.
Using these commands, the height of each substrate is defined and the corresponding layers are assigned. The
previewer enables you to validate that the proper mappings have been set up and that they are the correct
height.

e Correct Bondwire and Dielectric Brick Placement - Bondwires, described in the schematic window of ADS, are
mapped to the ADS layout and incorporated into the overall EMDS design for simulation. Dielectric bricks are
defined as part of the substrate definition. Since these portions of the design are difficult to see in layout, the
previewer can be used to validate their location and design.

Setting Up the Viewer on External X Window Displays

On Unix/Linux Systems, it is common practice to use a local machine as a display and do the actual processing on
another machine. The display from the original machine is typically mapped back to the local display using the
command

export DISPLAY=machine:0.0

The 3D previewer requires the setting of an additional environment variable, HOOPS_PICTURE. This environment
variable is set to the same value as the display variable with the addition of X11/ prior to the machine name. Using
the above example, the HOOPS_PICTURE variable would be set to

export HOOPS_PICTURE=X11/machine:0.0

Validating Your Geometry Visually

The 3D Previewer is invoked by choosing the EMDS > 3D EM Preview menu option.This command will start the 3D
previewer. The Previewer needs to be started each and every time that you want to review your design as it does not
remain synchronized with the current ADS layout. It is recommended that you do not keep one instance of the
previewer open while an older instance is present. It will not interfere with the data; however, it might be confusing
and cause an unnecessary error.

The basic layout of the EMDS previewer can be seen in EMDS Previewer. The previewer contains a dockable widget
that controls the display of the individual mask layers, substrates and port boundaries. Upon startup, a dockable
widget is docked on the left-hand side of the previewer.
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EMDS Previewer

Additional information is also located along the bottom status bar. On the far left side is the current operation mode.
For more information on these modes, refer to Navigating in the 3D Environment.

Identifying and Highlighting Individual Objects
Individual objects can be selected and highlighted in two ways:

e Picking on the Screen - Objects can be selected graphically using the mouse. If the previewer is in Query mode,
an object can be selected by clicking on any line or vertex of the object. Once selected, the object's lines are
highlighted, the object is selected in the material and object list and the coordinates of the selection point are
displayed in the lower right area of the status bar.

e Selection from the Material or Object List - Objects can be selected from either the material or object list box.
Once selected, the object's lines become highlighted.

Identifying and Highlighting Materials
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The material selection is located in the docking widget. It has the same controls for individual objects as the Object
Tab. In addition, each material's visibility and shading can be controlled using check boxes associated with the
material itself.

Controlling the Visibility and Translucency of Selected Objects and Materials

Once an object has been selected, its visibility and translucency can be controlled using the Object Information control
located at the bottom of the docking widget. This option enables you to control the translucency and visibility of an
object.

It is also possible to control the visibility and shading for the substrate and mask layers. Within the Material portion of
the docking widget, each material and object has separate toggles for visibility and shading. By setting these controls
appropriately, you can control the visibility and shading for all the objects that share this substrate or mask. However,
the translucency can only be controlled at the object level.

Navigating in the 3D Environment

The 3D previewer operates in several different modes. The current mode is displayed in the lower left portion of the
status bar. Regardless of the mode, the mouse wheel will enable you to zoom in and out of the design at the location
of the mouse cursor on the screen.

e Zoom Box - You can select a region on the design by selecting a rectangle around the area of interest. Once
selected, the previewer will zoom into this area and update the local rotation origin.

e Zoom - You can zoom in or out on the design by moving the mouse up or down on the image respectively.

e Rotate - The rotation mode is the default start up mode for the previewer. You can rotate the design around its
current origin by holding down the main mouse button and moving it around the screen.

e Pan - You can move the design around on the screen by holding down the main mouse button and moving it
around the screen.

e Query - You can query your model using this command. When you click on an object's edge or vertex, the
location and object name are displayed in the status bar. In addition, the object is highlighted and the object is
automatically selected in the Object and Material tabs in the Docking widget. Visually, a solid dot is placed if the
selected location is on a vertex and a hollow dot is placed if the selected location is on an edge.

Measuring Distances in the 3D Previewer

The measure dialog is activated from the Window/Measure command. Once activated, the measure dialog is
displayed.
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Measurement is done between a reference point and the current query point . The query point is updated after every
mouse selection using the query command. The reference point remains fixed until it is explicitly updated using the
Move Current Point to Reference.

Simulation Options

Simulation options that are specific to the EMDS for ADS simulator are specified in the EMDS Simulation Options
dialog that can be accessed by selecting EMDS > Simulation Options. This dialog enables you to control how the EMDS
for ADS mesh is generated.

An EMDS for ADS mesh is a sub-division of the entire 3D problem domain into a set of tetrahera (or cells). This
pattern of cells is based on the geometry of a circuit and optionally, user-defined parameters, so each circuit will have
a unique mesh calculated for it. The mesh is then applied to the circuit in order to compute the electric within each cell
and identify any coupling effects in the circuit during simulation. From these calculations, S-parameters are then
calculated for the circuit.

EMDS for ADS implements an adaptive mesh algorithm, where an initial mesh is generated and the electric fields (and
S-parameters) are computed on that initial mesh for a single frequency. An error estimate is generated for each
tetrahedron. The tetrahedra with the largest estimated error are refined to create a new mesh on which the electric
fields (and S-parameters) are computed. The S-parameters from consecutive meshes are compared. If the
S-parameters do not change significantly, then electric fields (and S-parameters) are computed for all the requested
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frequencies. If the S-parameters do change significantly, then new error estimates are computed, a new mesh is
generated and new electric fields (and S-parameters) are computed.

The initial mesh is controlled by the Mesh Seeding settings. The adaptive loop (most significantly the stopping criteria)
is controlled by the Mesh Refinement settings.

Setting Simulation Options

The EMDS Simulation Options dialog box enables you to control the way the circuit is meshed.

=/ EMDS Simulation Options:4 ? | x

—Mesh Refinement

Delka Error | 0.01

Consecutive Iterations of Delka Error Required |1

11

Limit on Mumber of Adaptive Passes |15

Mesh Frequency Owerride

[ Refine at a Specific Frequency

The mesh will be adapted at I 1 IGHz LI

—Mesh Seeding

{* Minimal ¢ Moderate € Custom Custom Setbings...

Ok, Apply Cancel Help

Mesh Refinement below describes the Mesh Refinement settings in the EMDS Simulation Options dialog box.

Option Description

Delta Error Global Delta S-parameter sets a value that is applied to
all S-parameters in the solution. Enter a value in the
Delta Error field. This is the allowable change in the
magnitude of the vector difference for all S-parameters
for at least two consecutive refinement passes.

Consecutive Iterations of Delta Error Required Enter the number of consecutive passes that must meet
or exceed the delta error. If you have concerns about
convergence, you can increase this value, otherwise, use
the default value of 1.

Limit on Number of Adaptive Passes Enter the maximum number of passes to be attempted.
If the number of refinement passes entered is reached
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before the delta error criteria is met, the refinement
process will end, based upon this limit. The number of
passes from all prior simulations is also displayed.
Typically, a value between 10 and 20 is recommended.

Mesh Freguency Override includes a description of the Mesh Frequency Override options in this EMDS Simulation

Options dialog box.

Option

Refine at a Specific Frequency

The mesh will be adapted at

Mesh Seeding describes the Mesh Seeding options available

Option

Minimal

Moderate

Custom

Description

By default, the mesh refinement is performed at the
highest frequency specified in the simulation. To change
the frequency at which the mesh refinement is
performed, enable " Refine at Specified Frequency' and
enter a value in " The mesh will be adapted at' field, in
GHz.

Enable " Refine at Specified Frequency' and enter a value
in *The mesh will be adapted at' field, in GHz.

in the EMDS Simulation Options dialog box.

Description

Use mesh seeding controls at their minimum values. This
is recommended for most geometries.

Use mesh seeding controls with moderate values. This is
recommended for very simple geometries.

Use mesh seeding controls set in the Custom Settings
dialog.

After you have completed entering your EMDS Simulation Options, click the Apply button to apply the current settings
in the EMDS Simulation Options dialog box, or simply click OK to accept the settings. Alternatively, you can click the
Cancel button to abort the changes and dismiss the dialog box.

Custom Mesh Seeding Options

The EMDS Custom Mesh Seeding Options dialog box enables you to more precisely control the way the initial mesh is
constructed. This dialog box is launched using the "Custom Settings..." button in the Mesh Seeding section of the

EMDS Simulation Options dialog box.
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=) EMDS Custom Simulation Options:4

— Initial Mesh Seeding

Mazx Divisions per Edge (1 to 16) |1|—
Mazx Divisions per Loop (10 ko 1600 IIIJ—
Modes per Wavelength {0 to 200 II:I—
Max Added Nodes (0to 300%) [0

Set to Minirmum Set ko Moderate |
Mesh Refinement
’7Max Refinement Points (400 to 3000073 ISEIIZIEI

(04 | Apply | Cancel | Help

Mesh Seeding Custom Settings describes the custom Mesh Seeding options available in the EMDS Custom Settings

dialog box.

Mesh Seeding Custom Settings

Option

Max Divisions per Edge (1 to 16)

Max Divisions per Loop (10 to 160)

Nodes per Wavelength (0 to 20)

Description

Specify the seeding to be applied to the edges of a
structure using Max Divisions per Edge (1 to 16). An
edge will be divided into 1 to 16 segments, and edges
that are divided into a larger number of segments will
have more seed points applied to them. In the Max
divisions per Edge field, enter the maximum number of
segments that the longest edge will be divided into.
Shorter edges will be divided into fewer segments. The
actual number of seed points applied to an edge and the
location of the seeds is determined by EMDS, but longer
edges will have proportionately more seeds.

After dividing up the edges into segments, EMDS adjusts
seeding based on, in part, the number of segments
within a loop. A loop is defined as a closed set of edges
that define the border of a geometry face. Enter the
maximum number of segments that are allowed for any
loop in the Max Divisions per Loop (10 to 160) field. A
loop will be seeded to have from 10 to 160 segments.

Nodes per Wavelength (0 to 20) enables you to change
the number of seed points (or nodes) in the volume. The
number of nodes in a volume is based on the free space
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wavelength at the mesh frequency. If your structure is
designed so that waves propagate through a material
denser than air, increase the value of Nodes per
Wavelength, up to a maximum of 20.

Max Added Nodes (0 to 300%) Max Added Nodes (0 to 300%) enables you to add extra
seed points throughout the edges and volume of the
structure. You can increase overall seeding from 0 to
300%. The locations of the seed points are determined
by EMDS.

Set to Minimum Click the Set to Minumum button to set Mesh Seeding to
its minimum settings.

Set to Moderate Click the Set to Minumum button to set Mesh Seeding to
its predefined moderate settings.

Max Refinement Points (400 to 30000) Max Refinement Points enables you to specify the
maximum number of points added at each mesh
refinement iteration. You can set this limit between 400
and 30,000. The locations of the refinement points are
determined by EMDS.

Simulation in EMDS

The simulation process generates a mesh for the circuit and solves for E-fields in the circuit. Using these electric field
calculations, S-parameters are then calculated for the circuit. The mesh electric field is then refined and new electric
fields and S-parameters are computed. This adaptive mesh process continues until a mesh refinement stopping
criteria is met.

Prior to running a simulation, the following criteria must be met:

e A substrate definition must be specified for the circuit
e The circuit must include at least one port
e A simulation frequency plan must be specified

If any one of the above criteria is not met, EMDS for ADS will report an error if you try to run a simulation.

The steps for performing a simulation include:

Specifying and editing frequency plans
Specifying solution files

Electing to view data

Running the simulation
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The steps for each part of this procedure follows.

 Note

EMDS for ADS creates several files during simulation. Some of these files can be large (they contain the
computed electric fields.) After you are finished with a project and no longer need to view the fields, or do far
field calculations, you may consider deleting the directories . / ends_dsn/ <design_name> /initial ,

./ emds_dsn/ <design_name> /prev , and ./ends_dsn/ <design_name> /| ast .

Setting Up a Frequency Plan

You can set up multiple frequency plans for a simulation. For each plan, you can specify that a solution be found for a
single frequency point or over a frequency range. You can also select one of several sweep types for a plan. This
collection of frequency plans will be run as a single simulation.

%) Simulation Control: 2

Stimabus
Sedect a frequency plan From kst to edé or define & new one
Frequency Plans Edit [Define Frequency Flan
Type F stact F stop Hpta/Step
Single 10.0000 GHz Swemep Type
Adaptive 0.5000 GHz 14.0000 GHz 25 max Single Ly
Frequency
5 GHr
[ Cut | Paste [ Update ] [ Add to Freguency Plan List
Process mode: local Solution Fles Drata Display
0 Reuss filas from the D Open daba desplay when
previous simulation simubation complebes
Foreground = Distaset Tamplates
(e ]

To set up a frequency plan:

1. Choose EMDS > Simulation > S-parameters .
2. Select a sweep type. The choices are:

e Adaptive

e Logarithmic
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e Linear

¢ Single point
Adaptive is the preferred sweep type. It uses a fast, highly accurate method of comparing sampled
S-parameter data points to a rational fitting model. The value entered in the Sample Points Limit field is the
maximum number of samples used in an attempt to achieve convergence. The solutions from the final
attempt will be saved. If convergence is achieved using fewer samples, the solutions are saved and the
simulation will end. For more information about this sweep type, refer to About Adaptive Frequency
Sampling.
Logarithmic simulates over a frequency range, selecting the frequency points to be simulated in logarithmic
increments. Type the start and the stop frequencies in the Start and Stop fields, and select frequency units
for each. Enter the number of frequency points to be simulated per decade of frequency in the
Points/Decade field, and select units.
Linear simulates over a frequency range, selecting the frequency points to be simulated in linear increments
based on the step size you specify. Type the start and the stop frequencies in the Start and Stop fields, and
select frequency units for each. Enter the step size in the Step field, and select units.
Single simulates at a single frequency point. Type the value in the Frequency field and select the units.

3. When you are finished setting the plan, click Add to Frequency Plan List.

 Note

In a simulation, frequency plans are executed in the order in which they appear in this list.

4. Repeat the preceding steps to insert additional frequency plans.
5. When you are finished, click Apply.

Considerations

In general, the Adaptive sweep type is the preferred sweep type. The exception is cases where a specific frequency
point or points must be simulated, such as the need to view antenna patterns. Since radiation patterns can be
calculated only at solved frequencies, you may want to specify a single specific frequency using the Single sweep type,
or a range using Linear or Logarithmic sweep types.

If you use one or more sweep types, make sure to set up your frequency plan list so that plans with Adaptive sweep
types are at the top of the list. Any additional plans that use other sweep types should follow these plans.

Editing Frequency Plans

You can modify, delete, or move frequency plans in the Frequency Plans list.

To modify a frequency plan:

1. Choose EMDS > Simulation > S-parameters.
2. Select the frequency plan from the Frequency Plans list.
3. Edit the plan using the sweep type and frequency fields displayed under Edit/Define Frequency plan. These fields
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are described in the previous section.
4. When you are finished editing the plan, click Update.
5. Click Apply to save the changes.

To delete a frequency plan:

Choose EMDS > Simulation > S-parameters.

Select the frequency plan from the Frequency Plans list.
Click Cut.

Click Apply to save the changes.

Ll

To move a frequency plan:

Choose EMDS > Simulation > S-parameters .

Select frequency plan from the Frequency Plans list.

Click Cut .

Select the frequency plan that you want positioned below the plan that you cut.
Click Paste to re-enter the plan.

Click Apply to save the changes.

ouhNE

@ Tip

You can perform several editing tasks, then click Apply once before you dismiss the dialog box.

Selecting a Process Mode

Momentum simulations can be performed in the foreground, the background, or they can be queued. For more
information, refer to the section on Selecting a Process Mode in Chapter 7:Simulation of the Momentum
documentation. These settings are ignored by EMDS for ADS.

Saving Simulation Data

A dataset stores the solutions for one simulation only. If you perform multiple simulations and want to save the data
from previous simulations, you must specify a unique dataset name for each simulation.

One simulation can produce one or two datasets:
e Data at the frequency points computed by the simulator are stored in <project_name> _emds.ds.

It is the standard dataset created from any simulation.
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o If the Adaptive sweep type is used to simulate, data computed by AFS at each sampled frequency point is stored
in the dataset < project_name >_emds_a.ds.

If you change the name in the Dataset field, the datasets will use the new name and not the default project_name.
To specify the dataset:

1. Choose EMDS > Simulation > S-parameters .

2. The name of the default dataset is displayed in the Dataset field. This is the file in which the simulation data will
be stored. The default name is based on the name of the current project.
If you want to use a different dataset, either type the name of a new dataset into the Dataset field, or click
Browse to reuse a dataset. If you choose Browse , a list of the datasets in the data folder of the current project
are displayed. Select file name and click OK .
Dataset files use the extension .ds and are stored in the data folder of the current project.

3. Click Apply to accept the changes.

Viewing Results Automatically

Simulation data is saved in datasets, so you can view simulation results at your convenience. If you choose to view
results immediately after the simulation is complete, enable Open data display when simulation completes . A data
display window containing default plot types or the data display template of your choice will be automatically opened
when the simulation is finished. The default is S-parameters plotted on Smith charts.

If you are using the Adaptive sweep type for your simulation, the data from both the standard and adaptive datasets
are displayed for comparison. Data from the standard dataset will be displayed as discrete points, the adaptive sweep
data will be displayed as a linear trace.

To open a data display window when the simulation completes:

1. Choose EMDS > Simulation > S-parameters .

2. Enable Open data display when simulation completes.

3. If you want a template to be loaded into the window, type the name of the template in the Template field or click
Browse . A list of templates in the data folder of the current project are displayed. Select a template and click OK

 Note

If you want to use a template from another project or location, copy the template into the data folder of the
current project.

4. Click Apply to accept the changes.

Starting a Local Simulation
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This section describes how to run a local simulation.

The simulation process solves for currents by combining the Green's functions that were precomputed for the
substrate and the mesh calculations. S-parameters are then calculated and saved to the dataset.

To start a simulation:

Choose EMDS > Simulation > S-parameters.

Verify that at least one frequency plan appears in the Frequency Plans list.

Check that the Process Mode, Solution Files, and Data Display options are set to your specifications.
Check whether the simulation mode is set to local machine.

Click Simulate.

uhwnNe

Any messages or errors that occur are displayed in the EMDS for ADS Status window. To indicate progress, a progress
line appears across the Status window if the number of unknowns in the simulation is greater than 500; otherwise,
only the frequencies are displayed.

If the simulation fails for a reason related to the setup, the partial data is saved and a message appears in the Status
window.

Viewing Simulation Status

After a simulation is started, any messages regarding the simulation will appear in the EMDS for ADS Status window.
Messages usually refer to any errors found, the percent of completion and simulation completion.

) Note

Do not close the status window. Stop simulation is not available in a new status window after closing a
previous status window.

Stopping a Simulation

To stop a simulation:

1. From the EMDS/Job Control window, click the Kill button.
The simulation will stop and the partial data will be saved.

Viewing the Simulation Summary
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As the simulation progresses, you can view solution statistics. Some of the information returned includes time to
solve, the resources required, mesh information, and any messages that were displayed in the status window. An
example of solution statistics is given next.

Choose EMDS > Simulation > Summary to view the data. Clicking Refresh to update the statistics as the simulation
progresses will only work for local and remote EMX simulations. The following example shows a (partial) summary
displayed when using the EMDS for ADS microwave simulation mode.

EMDS Simulation Summary:1 §|
)
EMDS 311 _day Copyright (C) 1996=2007 by Agilent Technologies
Computer Operating Svatemn: MHicrosoft Windows XP Service Pack 2
Obtaining licenses to run sinple _via @ a0047793: Wed Hay 16 07:24 2007
Pass 1 : Wed May 16 0724 2007
PORTS 1
CPU time: 00:00:00
GRADE 1
CEU time: 00:00:01
MESH 1
Hode count after EDGE seeds: 168
Hode count after FACE seeds: 176
Hode count after VOLUME sesds: 176
Humber of Elemsnts: 237
CFU time: 00:00:00
PORTS 1
SOLYE 1
Frequency : 4.000000 GH=z Unknowns: 2594
CPU time: 00:00:00 Henory: 3.23 Hbyte
Pass 2 . Wed May 16 07.24 2007
ADAPT 2
Humber of Elements: 764
CPU time: 00:00:00
PORTS 2 o
Flsiresh Pint | Help |

 Note
User Time and Elapsed Time __ are listed as separate entries in the Summary window. The difference between
the two is that elapsed time represents the overall time it took to complete the simulation, while user time
only represents the time it took the CPU to complete the calculations. In other words, if the CPU is able to
work exclusively on the simulation and is not occupied by another process, the user time and elapsed time will
be equal.

About Adaptive Frequency Sampling
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Adaptive Frequency Sampling (AFS) is a method of comparing sampled S-parameter data points to a rational fitting
model. In order to accurately represent the spectral response of the circuit, the AFS feature in EMDS for ADS takes a
minimal number of frequency samples and then applies its algorithm to the sampled data. Wherever the S-parameters
vary the most, more samples are taken. When the fitting model and the sampled data converge, the AFS algorithm is
then complete and the S-parameter data is written into the dataset. In this way, the maximum amount of information
can be obtained from the minimum amount of sampling.

By using the AFS feature, you can greatly reduce the amount of time required to simulate circuits that have
resonances or other sharp responses that are difficult to detect. Data that would have remained hidden using other
types of analyses can now be obtained.

Even in the case of a low-pass filter, AFS can solve for the S-parameters faster and more accurately than discrete data
sampling. For example, if you were measuring a 2 GHz low-pass filter, you would enable the AFS feature and then
enter a start frequency of 500 MHz and a stop frequency of 4 GHz. AFS would then sample the two end points,
construct the fitting model, and then sample points in between as needed. As this occurs, the model is automatically
refined and appropriate sample points are taken until the model and the sampled data converge. When convergence is
reached, both sampled data and the AFS data are written into two separate datasets and can be presented as
S-parameter traces on a plot.

Setting Sample Points

If you are using the Adaptive sweep type in a simulation, you may want to select specific sample points to be used in
the AFS process. In general, this is not necessary (and is in fact, discouraged), but there may be instances where it is
beneficial. An application where this may be beneficial is simulating a structure that has a distinct variation in
response at some point over a frequency range, such as a resonant structure. To set up the simulation:

1. Select the Single sweep type, enter either the value of the resonant frequency or a value near it in the Frequency
field, and add this to the frequency plan list.
2. Select the Adaptive sweep type, set up the plan, then add it to the list of frequency plans.

For this situation, the sample point aids the AFS process by identifying an area where there is clearly a variation in the
response of the circuit.

Applying extra sample points may be necessary for visualization or far-field calculations.
It is not beneficial to attempt to add sample points for other purposes, such as attempting to force smoothing to occur
at specific points, without taking into consideration the response at these points. For example:

1. Selecting the Linear sweep type, adding sample points spread linearly across the frequency range, and adding
the frequency plan to the list.
2. Adding an Adaptive sweep type, selecting the same frequency range, and adding it to the list.

For this situation, the sample points from the linear simulation will be included in the adaptive simulation. This
impedes the AFS process of selecting the optimal distribution of samples over the frequency range, and this can
produce poor simulation results.
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To remedy this situation, either run the Adaptive sweep plan first or make sure that the frequency ranges of the two
plans do not overlap.

Viewing AFS S-parameters

When viewing the S-parameters in an AFS dataset, if you zoom in you may see small, unexpected spurious ripples or
oscillations, with an amplitude less than 0.0002. The amplitude of these oscillations is always less than the AFS
accuracy level, which is approximately -60 dB. Generally, these ripples will only appear if the dynamic behavior of the
S-parameters is limited, for example, an S-parameter that is nearly 1 over the frequency range simulated. This is
likely due to the rational fitting model have too many degrees of freedom and being too complex for this situation

Layout Components for EMDS

Layout Components are user-defined components that you can create from a layout page in ADS. The component that
can be inserted in a schematic page just like any other component, and represents the (parametric) layout from the
layout page. The symbol representing this component in schematic can either be a black box or a layout look-alike
symbol.

Once the Layout Component is defined, you as a user can use it in one of the following ways.

You can directly include the Layout Component in the schematic. When doing a circuit simulation from the schematic
environment, the EMDS for ADS EM solver will be called automatically during the circuit simulation (EM/Ckt
co-simulation) to generate a EMDS for ADS model on the fly. The user-defined layout parameters and the most
relevant EMDS for ADS simulation parameters can be set from the schematic page. With the co -optimization feature
you can also determine an optimized value for your Layout Component without returning to layout. The layout
components have a built-in database mechanism that keeps track of previously calculated EMDS for ADS simulation
results, that is, once the EMDS for ADS simulation is done for a certain layout component, no new EM simulations are
required, unless there is a change in the parameters for this component.

Layout Components and Circuit Co-simulation

The Electromagnetic-Circuit co-simulation feature enables you to combine EM (EMDS for ADS) and circuit simulations
from the schematic. From a layout in Advanced Designh System, you can create and insert a (parametric) layout
component in a schematic. The symbol representing this component in a schematic can either be a black box or a
layout look-alike symbol.
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" — layout Look-Alike

— —it
Ref
simple_via simple_via
simple_via_4 Black Box simple_via_5
L1=100 mil L1=100 mil
L2=200 mil L2=200 mil
ModelType=EMDS ModeIType%DS

You can set the layout and EMDS for ADS simulation parameters such as model type and mesh density from the
schematic. When a circuit simulation is done in a schematic that includes a layout component, the EMDS for ADS
simulation engine is automatically called as part of the circuit simulation process. The co-optimization feature enables
you optimize your component during this simulation. For more information on co-optimization, refer to
Co-optimization with Parameterized Layout Components

Layout components have a built-in database mechanism that keeps track of previously calculated EMDS for ADS
simulation results. Once the EMDS for ADS simulation is completed for a certain layout component, no new EM
simulations are required unless there is a change in the component parameters.

 Note

When a Layout Component is simulated during an EM/Circuit co-simulation session, a work layout design <
name >work is created (where < _name > is the name of the layout component) with an instance of the
layout component inserted. The work design is then sent to EMDS for ADS for EM simulation. The simulation
results are stored back into the model database associated with the original layout component. This work
design is only used temporarily and can be ignored. It is not automatically deleted after the simulation.

Setting up a Layout

There are two basic ways to create a layout. Use the one that best complements your own design methodology and
suits your design needs:

¢ Layout synchronized from a schematic
¢ Directly drawn or imported layout

Once you have a layout, you will need to prepare it for a EMDS for ADS simulation using the following steps before
you create a layout component:

1. Set up the substrate and layer mapping
2. Use Port Type Mapping to insert ports and set the port types
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You can also specify mesh settings and frequency plans if you haven't done so in the schematic window.

© Note

Only single (calibrated) and internal (uncalibrated) ports are supported with the layout components. Other port
types will be mapped to single or internal port types during component creation. More information on port

mapping is given in Port Type Mapping.

Adding Layout Parameters

Layout components with layout parameters enable you to sweep, tune, or optimize geometrical (shape) variations of
planar layout objects. This includes:

e Typical dimensions such as lengths, widths, gaps, spacing, or diameters
¢ Interdependent layout modifications such as length and width varying simultaneously
e Unconventional layout modifications such as varying port locations

 Note

There is a limit of 100 layout parameters per component.

There are two ways to create a parameterized layout:

e Using nominal/perturbed designs
e Using subnetwork parameters

Only the latter is supported by EMDS layout components.

Using Existing Layout Components

A parameterized layout can be set up using a combination of several built-in microstrip components. Use the Layout
Component Parameter dialog box ( EMDS > Component > Parameters ) to specify subnetwork parameters for the
layout component.
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—| Layoul Component Parameters:7
Design Hame | compl
Select Paramelar Creale/Edil Parameler
L1 Hame LI
o |

Type Subnetwork

Default Value 100 IE

HAudd the parameter and select a component
in the layout to set the parameter value.

Al Cut Pasle Updiate

oK Apply Cancel Help

Once a subnetwork parameter is defined, it can be used to set the parameters values of one or more component
instances used in the layout.
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In this example, the subnetwork parameter L1 is used to set parameter value L of the MLIN instance.

 Note

Only the top-level design parameters can be used to set the lower level instance parameters. The use of any
other variable is prohibited.
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Creating a Layout Component

Use the Create Layout Component dialog box ( EMDS > Component > Create/Update ) to specify the appropriate
settings for creating a layout component.

= Create Layout Component:2

Sek the symbol, model parameter and model database options
and hit Ok to Create/Update the Layout Companent,

Syrbal
(%) layout look-alike ) black box
Size

min pin-pin distance w( =1 schematic units

[] add Reference Pin
Model

Parameter Defaults
Maodel Type
EMDS W

Mamenturm Simulation Contral

Schematic Layout

Maodel Parameters

Substrate

Lowesk Frequency 0 aHz v

Highest Frequency 10 aHz w
Database

Delete previous database

add last simulation resul:

) Note

The Add Reference Pin checkbox enables you to turn on or off the addition of an extra reference pin during
layout component creation. This "extra" pin is used by EMDS for ADS to provide a reference voltage for all
other pins in the layout and enables you to model ground effects (e.g., ground bounce, imperfect ground
connections, etc.).

The Add Reference Pin option is only available for the layout look-alike symbol selection. When selecting black
box this option is unavailable (grayed out), however because black box uses standard symbols, a reference pin
will appear in all schematic black box representations. This can cause problems if you are creating a structure
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with finite ground planes and wish to use them in the schematic. In this case, the layout look-alike component
with Add Reference Pin disabled is a better choice.

This option should also be disabled and the layout look-alike component used for components intended for use
with the Schematic > Generate/Update command. The presence of this extra pin can cause an error during
design synchronization.

Once the setup is complete, click OK to create the layout component. This layout component will have the same name
as the layout design. The following actions are performed automatically:

The technology data is saved. For more information on technology data, refer to Technology Files.
e A component symbol is created

The component definition is updated

The model database is initialized

An information dialog box will be displayed to confirm that the creation or update was completed successfully.

) Note

You need to update a layout component whenever a change is made to any layout attribute such as the
parameters, ports, and the shape. You also need to reinsert or swap existing instances of the component in a
schematic using Edit > Component > Swap Components.

Selecting a Symbol

You can choose between two schematic symbol types:

1. A layout look-alike symbol for which the symbol shape is a scaled copy of the layout shape.

®ef

simple_wia
simple_wia 3
ModelType=EMDS
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1. A black box symbol with a generic rectangular shape.

— |

simple_wia
simple_wia_2
ModelType=EMDS

Scaling the layout look-alike symbol can be set in three different ways:

¢ Setting the minimal pin-pin distance in schematic units.
One schematic unit corresponds with the size of most standard two port components such as resistors,
capacitors, and inductors. Setting the minimal pin-pin distance to one schematic unit (1 inch) ensures that a
component with a given symbol size will fit between two pins.

e R—
+ *
¢+
£ & -
| ] %
A
H1
Re50 Ohm

e Setting the maximum pin-pin distance in schematic units.

The following figure illustrates the scaling when the maximal pin-pin distance is set to be equal to one schematic unit
(1 inch).
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e Mapping the layout unit dimensions to the schematic unit dimensions (recommended when combining different
components in the same schematic page).

When you combine different layout components on a single schematic, a fixed, absolute scaling factor is the most
appropriate choice to ensure that the relative sizes of the layout components are preserved.

1 layout unit (mil) =
0.01 schematic unit

finch) ® @

A1
R=50 Ohm

Model Parameter Defaults

L & i -
* - 4

+
* - -
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Each time a new layout component instance is inserted on a schematic page, the model parameter values specified
during the layout component creation are applied as the initial settings for the instance. These parameters are a
subset of the EMDS for ADS simulation control options in the Layout environment.

You can specify the following model parameters.

e Model Type set the EM Simulator to be used to Momentum MW, Momentum, or EMDS
e Substrate specify the substrate description ( *.slm ) using the browse button
e Lowest Frequency lowest frequency to be used during the EMDS for ADS model generation for the adaptive

frequency sweep algorithm
e Highest Frequency highest frequency to be used during the EMDS for ADS model generation for the adaptive

frequency sweep algorithm

) Note

If the circuit simulation requires frequency points outside the specified range, this is done through
extrapolation.

Model Database Settings

When running a circuit simulation, EMDS for ADS is invoked to generate a model for the layout component. This model
is stored in the layout component's model database. During the creation or update of a layout component, you have
the option of deleting all previous models for this component.

e Delete previous database toggle deletes all previously calculated models for this component.

Primitive and Hierarchical Components

Parameters Type Component Type Artwork Type
None Primitive AEL Macro
Subnetwork Hierarchical Synchronized
Nominal/Perturbed Primitive AEL Macro

Layout Component File Structure

The layout component is made up of a group of files that combine to define the component. Manually modifying or
deleting one or more of these files may corrupt the component definition resulting in unexpected behavior.
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<project>_pi|

<substrate= lay
<substrates. prf

schematic.lay
mom_dsn

|— <comp:

|—mDDD

|— 0000

networks

<compz.dsn

Technology Files

During the layout component Create/Update process, four technology related files are created or modified. Three of
these files define the substrate technology:

1. <substrate>_layout.lay layout (or mask) layers definition file
2. <substrate>_layout.prf layout preferences file
3. <substrate>.sIm substrate definition file

The names for these files are derived from the substrate name that was chosen. The default nhame is the layout design
name.

The fourth file is the schematic layers definition file < schematic.lay >. This file is loaded whenever a new schematic
window is opened and it specifies the drawing layers for the schematic. In the case of a layout look-alike symbol,
additional layers are appended to this file to draw the schematic symbol for the layout component. They can be
recognized by their * _lay ' postfix. Keep in mind that a schematic window that is already open does not dynamically
update its layers definition. You will need to manually load the modified schematic.lay file.

Model Database Files
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The EMDS for ADS model database is stored under the mom_dsn/<comp> directory where < comp > is the design
name of the component. A model.ndx file keeps track of the models that are stored in the database.

Models are stored in a two level hierarchy. The top level differentiates entries (models) based on the model parameter
settings. The bottom level differentiates entries (model samples) based on the layout parameter settings.

Model Database
------ mO00 — mode!
g Q00 = Samme
S04
s0002
S0003
50004
50005
50006
mo01
50000

Two models are considered to be the same if the following model parameter settings are identical:

Model type (ModelType)

Simulation control (SimControl)
Lowest model frequency (LowFreq)
Highest model frequency (HighFreq)

For a given model, one or more (in the case of a parameterized component) samples can be generated and added to
the database.

The models already available for a component can be viewed by choosing EMDS > Component > Model Database .
This will open the layout Component Model Database dialog box.
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i Layout Component Model Database:1 E3

Model Database

Available Models Description

PARAMETERS:
mywidth =VALUE 25 mi
rayF adius = VALUE 60
mydngle = WALUE 60 deg
MODEL:
modelT ype = RF
substrate = Alum25mil
lowFreq =1 GHz

wahFreg =10 GH
[A] i ar

arcRezolution = 45 deg
Selected Models to delete edgeMesh = OFF

Sefect Al | Unselectall |

oK | Apply | Ean-::ell Help |

In this example one model is available in the model database. By selecting the model, the parameter values for which
the model is generated become visible in the Description box

Using Layout Components in a Schematic

The layout components created in the layout window can be inserted in a schematic, either by selecting the
component using the library browser (select Insert > Component > Component Library ) or by typing the name of the
component in the component name entry field. The layout ports become schematic pins that can be connected to
other components.
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Specifying Layout Component Instance Parameters

Double click a layout component in the schematic to display the Layout Component dialog box. This dialog box has
three tabs that enable you to set the parameters and their display for the layout component instance.

Model Parameters
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B Momentum Component:5 El
simple_via
Irstance Mame
iriphe_via 1]
Model IF'u'mm| Display |
Model Type
[EMDS =
Momentum Simedation Contol
" Schematic " Lagpout
Moded Parameters
Subsirate
[simgle_via_lay Browese
Lowest Frequency [+ |GHz =]
Highest Fiequency [+ |GHz |
Mesh Density [20 [Hone |
Arc Reschition [+5 |deg =]
¥ EdgeMesh
Model Databaze
[+ Reuss Model Select
v Interpolate Model Dptions. ..
ok | sogk | Cancel | Help_|

Model Type Selection

The Model Type selection list offers the following choices:

¢ Momentum MW S-parameter model generated by Momentum in MW mode

¢ Momentum RF S-parameter model generated by Momentum in RF mode

e EMDS S-parameter model generated by EMDS for ADS

¢ File Based S-parameter model available in a Dataset, CITI or Touchstone file or model given by an ADS netlist
file

e Subnetwork (for hierarchical components only) the component will be netlisted based on the subnetwork
topology in the schematic page of the component design and use the built-in models

EMDS for ADS Simulation Control Settings

The first three options enable you to change the settings of the most important EMDS for ADS Simulation Control
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parameters.

e Schematic - schematic settings overwrite the ones found in the corresponding layout design from where the
component was created. Only a subset of all EMDS for ADS Control parameters can be accessed and an adaptive
frequency sweep (AFS) will be performed by EMDS for ADS. For more information on adaptive frequency
sampling refer to, About Adaptive Frequency Sampling.

Model Database Settings

All generated models are automatically stored in the layout component model database. When performing an
optimization, select the Reuse Model and Interpolate Model options to minimize the number of EM simulations.

e Reuse Model the database will be inspected, if the model for the specified parameters is available, it will be
reused. When this option is not selected a new EMDS for ADS simulation is launched without inspecting the
database first.

Click the Select button to display the Select Model dialog box that lists the currently available models.

¢ Interpolate Model switch interpolation on or off. When this option is selected a linear interpolation scheme is
used. The circuit simulator only invokes EMDS for ADS for an EM simulation if the requested model sample can
not be obtained by interpolation between neighbor model samples. Neighbor model samples must be within a
normalized distance (L1 measure) smaller than one from the requested sample. The normalization of the
distance is with respect to the interpolation delta values specified in the Set Interpolation Options dialog box.

Click the Options button to display the Set Interpolation Options dialog box, which shows the interpolation type and
the interpolation grid setting for each parameter for the current model parameter settings. You can change the
interpolation grid values or reset them to their defaults (automatically calculated based on the highest model
frequency and the mesh density) by clicking the Defaults button.

| | Set Interpolation Options:6
Specify the model datahase interpolation
oplions.

Interpolation Type

Linear

Interpolation Grid
oelta

L1 [ mil ]
Lt [ wmil ] 53 0951

oK Defaulls Help
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For more information about the model database and its model interpolation refer to Model Database Flow During
Simulation.

Layout Parameters

The Parameters tab enables you to set the layout parameters (nominal/perturbed or subnetwork) similar to any other
component in ADS.

» Momentum Component:1
Coupled_line_filker

Inztance Mame
|Eu:uup|ed_|ine_filter_1

Model Parameters | Displayl

Select Parameter L1
L1=300 urn optf 200 urn to
IBI:II:I Ium j
Optimization Setup... I
'
|L1 : Subnetwork 300 umn
k. | Apply | Cancel Help

Click the Optimization Setup button to specify an optimization setup for the selected parameter.

127



Advanced Design System 2008

Parameter Setup:1 E
Optimization Statuz | =

Type | Continuous

Farmat

Led Lo

| minmas

MHaorminal Yalue

300 [ um

L

kinimum Y alue

|200 [ um

L

b aximurm Y alue

400 [ um

L

I I
k. | Cancel |

L

Display Parameters

The Display tab allows you to individually select which parameters will be visible on the schematic.
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i Momentum Component:1
Coupled_line_filter

Inztance Mame

|E|:uu|:||eu:|_|ine_filter_1

Mu:u:lell Parameters  Dizplay

Dizplay parameter on schematic

v L1

[v Modellppe
[~ ModelFile
[~ SimContral
[T Substrate
[T LowFreqg

[ HighFreq
[ MezhDensity
[T ArcRezolution
[T EdgeMesh
[T ModelReuse

Setal | Clearsll |

k. Apply | Eancell Help

Port Type Mapping

Only single (calibrated) and internal (uncalibrated) ports are supported with layout components. The following
examples illustrate how simulations with differential, ground reference, and common mode ports can be set up in the
schematic in a way that is equivalent to the simulations in the layout.

Differential Ports
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Ports 1,3 and 2,4 are differential port combinations. EMDS for ADS calculates a four-by-four S parameter result. This
can then be converted to a differential excitation using the following illustration of a setup for S-parameter ports.

Term1 g § Termz2
Murm=1 Murm=2

£=a0 Ohm £=50 Ohm

diff_1 e

hodelType=RF

Common Mode Ports
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Ports 1,3 and 2,4 are Common Mode port combinations. To obtain Common Mode results, use the setup illustrated in

the following schematic.

Term ~ i = : TErm
Term1 g - g Term?
Mum=1 common Mum=2
=50 0hm - common 1 - =40 0hm
- - &
ModelType=RF

Optimization and Tuning

During a tuning session, models cannot be generated on the fly. Consequently, tuning of parameters that influence a
layout component is only possible when the requested layout component model samples are already part of the

database or if the database can provide interpolated results.

If the database cannot return a valid model, tuning will fail and issue an error message indicating that the model
database is incomplete. In other words, tuning is only possible within specific ranges that are covered by a sufficient

number of samples.
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Model Database Flow During Simulation

The following illustration shows how the model database handles a request for a model sample for a given layout
component. Multiple requests may be generated during an analysis even when only one instance of the component is
present. This is the case when layout component parameters are swept, optimized, or tuned.

adds new sample

Model
Raquestad
N (swapt, optimize, tune) {auto salection)

model?
or luner error
Meighbor samples are within ]
della distance
N L
reuse model enough

modal? available amplas?

Auto sslection is driven by two criteria:
« well anough apart to avoid numerical noise issues
«not too far apart to allow for a linear interpolation

1
database

calculata
(rejcalculate rause calculate madal interpolate
madel maodel model Or tung anmor madel
Model
Hequested

A first model request will propagate to the Reuse Model? point. If the Reuse Model option is off, EMDS for ADS will be
invoked to (re)calculate the model.

If the Reuse Model option is on, the model database will verify if the requested sample is already part of the database.
If this is the case, the existing model will be reused.

If the model sample is not available yet, the component instance's Interpolate Model option will be checked. If this
option is off, EMDS for ADS will be invoked to calculate a new model. The following warning message will be issued to
the status window:

The nodel for the Layout Conponent is not found in the Database, a new nodel is generated for the
request ed paraneter val ues.

If the Interpolate Model option is on, the model database will try to locate neighbor samples. Samples are considered
to be neighbor samples if they are within the interpolation delta distance (L1 measured), which can be viewed and
specified in the Set Interpolation Options dialog box. If no neighbor sample is found, EMDS for ADS will be invoked to
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calculate a new model. A warning message, which is the same as the one above, will be issued to the status window.
In the case of a tuning session, the following error message will be sent to the status window.

Model Database for <instanceNane> is not conplete for tuning. Sinulate the Layout Conponent first to
conpl ete the Mbdel Database.

If at least one sample is found in the neighborhood, the database will try to interpolate in the database. If sufficient
samples are not available, they will be added automatically based on the interpolation deltas that were specified (or
their default settings). The number of additional samples is kept as low as possible to save computation time. When
this happens, the following message is shown in the status window:

There are not enough sanples available to allow interpolation, a new sanple is generated and added
to the Mddel Database.

Co-optimization with Parameterized Layout Components

The co-optimization feature enables you to optimize parameterized layout components in the schematic as part of a
co-simulation. This section provides an exercise illustrating how to set up, perform and view the results of
co-optimization.

Copying an Example Project

Start by copying an ADS EMDS for ADS example project into your local directory.

1. From the Main window, choose File > Copy Project...

2. In the Copy Project dialog From Project section, choose Example Directory.

3. Select Browse....

4. In the drop down menu, choose Momentum > Microwave select Coupled_line_filter_prj and click OK to select
project.

5. In the To Project section, select a location for the project to be copied to.

6. Activate Copy Project Hierarchy and Open Project After Copy then, click OK. This opens the project and saves it

to the new location.

Editing the Component

This section describes how to prepare and parameterize a component for co-optimization.

1. When the project opens, dismiss the README window.
2. Select the Coupled_line_filter layout window.

133



Advanced Design System 2008

3. Next, choose EMDS > Component > Parameters. This opens the EMDS for ADS Component Parameters dialog.
4. In the Create/Edit Parameter section, type L1 for the parameter name and. choose Subnetwork for the
parameter type. The set the Default Value at 300 um.

Design Name | Coupled line_filter

Select Parameter Create/Edit Parameter

Name |L1§
Type  Subnetwork |
Default Value Iaul:[ um 4

Add the parameter and select a component
in the layout to set the parameter value.

Addel cut | faste | Update |

oK | Apply | Cancel | Help |

5. Click Add then select OK.
6. In the Layout window double click on Microstrip Line TL6 to select it. This opens a new dialog.

7. Select Parameter L in the MLIN column and set Line Length L to L1 in the Parameter Entry Mode column.
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MLIN Parameter Entry Mode
Instance Name (hame[<start:stop=]) Standard 0 |
s

L

Select Parameter
L1 Mone i |

Subst="MSub1"
W=73 um Equation Editor... |

Walll = Tune/Opt/Stat/DOE Setup... |
Wallz=

Temp=

Mod=Kirschning

M Display parameter on schematic

Fightl 9114 Fasta Component Options...

I L : Line length

0K | prlyl Cant:ell Hesetl Help |

8. Click OK to dismiss this dialog.

Creating the Parameterized Component

This section describes how to create the parameterized component.

1. In the Layout window, select EMDS > Component > Create/Update . This opens the Create Layout Component
dialog.
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Create Layout Component: 2 El

Set the spmbol, model parameter and mode] datahass options
ared it QF, to Create/Update the Lavout Component,

Symbel

(% layout look-alke " black box

Size

|rrnpn-pn|.istatca :J - [1 tchemabc: units

W Add Ratersnce P

Moded
Paamater Dol sults
Madel Type

EMDS -

Momentum Smulation Control
i Schematic © Lapout

Modal Pasameters
Subsirate

[srnpla_vea_lay_1 Browie |

Lowest Frequency hh |GHz =]
Highest Frequency [« [6Hz =]
Meth Dansly |20 [Hone =|
A Rezoluton [45 |*g :I
[ EdgeMash
Databace

[ [Drelete previous database

[ A last sarvadation resul

_Carcel | _teo |

In the Symbol section of this dialog, choose layout look-alike and enable Add reference pin .

In the Model section, ensure the Model Type is set to EMDS , set the frequency range from 25 GHz to 50 GHz

and deselect Edge Mesh .

4. Click OK to create the parameterized component.

5. This brings up two new dialogs, select OK in the message window advising you the component was successfully
created and select No in the Add simulation to Model Database dialog.

wnN
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There is simulation data available for this Layout Component.
Do you want this data to be added to the Model Datahase?

The program does not check if all current design settings are
identical to the previously used settings. If you changed:

the circuit geometry,
or the substrate,
or the poris,
or the mesh parameters,
or the version of the simulator,
or the frequency plan

you cannot reuse the data!

Yes Ho |

Adding and Using the Component in a Schematic

This section describes how to add and use the parameterized layout component in the schematic.

1. Open a new Schematic window. Insert the newly created component by opening the library browser and
selecting Sub-networks > Coupled_line_filter_prj * > *Coupled_line_filter component. Place the layout
component in the Schematic window.
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& [ Coupled _line_filter_prj | untitledd * [Schematic):15

Flo Edt Select View Insert Options Took Layout Smuste Window Dynamscirk DesgnGuds Help
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Coupled_line_filtar
Coupled_line_filter_1
L1=300 um
ModelType=EMDS
- ¥
Select: Enter the starting ot 0 demrs 4.500, 0.500 2375, 0.250 N ARF Sm

2. Add 2 S-parameter ports and 3 grounds to the schematic as shown in the following illustration.

+F [erm

Term? ;
Murm=1
=50 Ohrn

rg Term
TermZ
—E—E f Mum=2
Coupled_line_filter =50 Ohm
Coupled_line_filter_1
L1=300 um =
ModelType=EMDS —i—

3. Add an S-parameter simulation block to the schematic. Set the Start frequency to 25 GHz , the Stop frequency to
50 GHz and the Step-size to 0.1 GHz .
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3_Param Instance Mame

|'sP1

| Frequency ] Parameters] Hoise LL

Frequency

Sweep Type Linear ‘|

“ Start/Stop .~ Center/Span

Start 25.0 GHz -
Stop 50.0 GHz ¢
step-sice [ 0.1] GHz

Mum. of pts. | 251

_I Use sweep plan I il

OK_| Apply | Cancel Help

4. Click OK .

Optimization Setup for a Parameterized Layout Component in the Schematic

This section discusses setup required to the optimize a parameterized layout component during schematic simulation.

1. Double click the Coupled_line_filter component. This brings up the EMDS for ADS Component dialog.
2. Choose the Parameters tab, then select the Optimization Setup... , to bring up the Optimization dialog.
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Optimization Status  Enabled _"|
Type Continuous A
Format minfmax A
Nominal Yalue
300 um Ll

Minimum Yalue

20 um X

=,

Maximum Yalue

A0 um X

0K Cancel

. In this dialog, set Optimization Status to Enabled , set the Minimum Value to 200 um and the Maximum Value to
400 um .

. Click OK .

v

Add a Goal and an Optimization block to the schematic.

. For the Goal block set:

e Expr = "dB(S11)"

e SimInstanceName = "SP1"

e Max = -10

e Weight = 1 **

e RangeVar[1l] = "freq"

e RangeMin[1] = 39 GHz

e RangeMax[1] = 42 GHz

. In the Optimization block set the Optimization Type to Minimax .
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Expr="dB(311)"

Rangetar[1]|="freq"
Rangetin[1]=39 GHz
Rangehdax[1]=42 GHz

SimlnstanceMame="3FP1"

GOAL I 5y | oPTIM
Soal Ontirr
Optimizoall Optirn1

OptimType=Minimax
ErrorFarm=ha

hdin= Maxlters=25
Ma}_{:-*llil DesiredError=0.0
Weight=1 StatusLevel=4

Final&nalysis="Mone"
SetBestValues=yes
Savesolns=no
oaveGoals=yes
Savelptimyars=no
UpdateDatazet=yes
Savelominal=yes
Savedllterationz=no
UseAllDptyars=yes
UszelllGoals=yes

8. Save the schematic design as " filter_opt ". Choose File > Save Design As...

EE

S-PARAMETERS

Miam 3l Gogk= 1o
Seterfialies=yer
== =] [FAT)
AkGakE=gs
SakOptmvaK=
) poctari: D v iyl
Sk Homliak o
=k O rators =10
UgeSI0pDiars=yes
Urep Gk =y

=10
Sar=S0GHE
Sop=T00GHE
Sepe0.1 GHz
Tem
Tem2
-li.'" Ham=2
l'l'l'l|-|n--l i T Z=E00Mm
Conpkd_llue_fier_1
L1=200 o beoprtd X0 am o 400 am
Mok [Type= R F L
| m OPTIM GO.&.L
Optim Goal
ot 1 optmGealt
I Typse= W0 (4 M S i W EEF= b Bipr="dB &1 1"
P e =25 Sim v T Name="5P1°
DegIredErrar=00 M=
St Lape =4 Mar=-10
Flvalenaks r="Noye" kg b= 1

Rangevar[f]="teq"
Range M [=35H:
Range Ma[f]=42 GHx

9. From the Schematic window, choose Simulate > Simulate to start the simulation.
10. After 9 iterations the optimized value of 207.039e-6 is shown in the status window.
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File SimulationfSynthesis Text Window

Simulation / Syntheziz Meszages

Status / Summary

SP Optimlld1,5PL00] <<string/CEMY netlist>> optlter=0 freg={25 GHz->50 GHz} =
[teration/Trial #9:
CurrentEF: 2,23740858099094
Optimization wariables:
Coupled_line_filter_1,w0 = 207,0352-06
Fesource usage:
Total stopwatch time: 161,12 seconds., N
F

Using and Viewing the Results of Co-optimization

This sections shows how to use the results obtained from a co-optimization.

Select Edit > Component > Deactivate/Activate. Click the Goal and Optimization blocks to deactivate them.
Double click the Coupled_line_filter component to bring up the EMDS for ADS Component dialog.

Choose the Parameters tab then select the Optimization Setup... button.

Set the Optimization Status to Disabled and select OK .

Set the parameter value of L1 to 207 um. This is the optimized value.

uhwnN e
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. Save this schematic design as " filter2 ". Choose File > Save Design As....

. Choose Simulate > Simulate from the toolbar to start the simulation. If the simulation runs successfully, a Data
Display window will open.

. Insert a rectangular plot in the Data Display with the data set dB(S11).
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The plot shows an optimized value for S11 < -10dB. This is within the range of the optimized goal that was previously
set.
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Limitations when Using Layout Components

There are some limitations on the components that are available from the layout palettes:

Do not use substrate components that might appear on layout component palettes. You must use the dialog box
under EMDS > Substrates > Create/Modify to create or edit substrate definitions.

Lumped elements cannot be included in a layout that is to be simulated by EMDS for ADS.

Components from the Microstrip palette can be used, with limitations:
° The substrate name (e.g., Subst = MSub1) is not used in EMDS for ADS. Substrate definitions must be
loaded from the EMDS > Substrates menu.
° Any electrical properties, if defined, are not used. For example, the parameters CPUA, RsT, and RsB in
MFTC are ignored.

For most of the components in Layout, only the geometry is transferred to EMDS for ADS. Any electrical
properties must be defined from the EMDS for ADS menus.

Components from the Printed Circuit Board or Waveguide palette cannot be used in a layout that will be
simulated using EMDS for ADS.

Stripline and suspended substrates components can be used, but the substrate name parameters for these
components will be ignored.

A maximum of 100 layout parameters can be used per component.
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Viewing Results in EMDS

This chapter shows how to display EMDS for ADS results.

Viewing Results Using the Data Display

You have two tools available for displaying the results of an EMDS for ADS simulation: the Data Display, and EMDS for
ADS Visualization. The visualization tool is described in following chapters. This chapter describes how to use the Data
Display.

You can display S-parameter data from an EMDS for ADS simulation. Additional data is calculated during a simulation

and saved in the dataset, and can also be viewed or used in calculations:

e Propagation constant (gamma) for each port in the circuit
e Characteristic impedance of each port
For detailed information on how to use the Data Display, refer to the "Data Display" manual.

Opening a Data Display Window
You view simulation results using the Data Display. You can open a Data Display window using different methods:

e Open a Data Display window automatically when a simulation is complete. For steps on how to do this, refer to
Viewing Results Automatically.

e Open a new Data Display by choosing Window > New Data Display from the Layout Window menu bar.
e Open a saved Data Display by choosing Window > Open Data Display and selecting a Data Display in the current
project. Data Display files end in the extension . dds .

Viewing the EMDS for ADS Data

Simulated EMDS for ADS data is saved in one or more datasets:

¢ Data collected at the frequency points computed by the simulator are stored in < design_name >.ds . It is the
standard dataset created from any simulation.

o If the Adaptive sweep type is used for simulation, densely resampled data, computed by AFS at each sampled
frequency point, are stored in the dataset < design_name >_a.ds .
The datasets for the current project are displayed in the dataset listbox.
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To view EMDS for ADS data:

1. Select the plot type by clicking the appropriate plot icon, dragging the mouse into the window, then clicking to
place the plot.

2. The variables in the default dataset are displayed. Select a different dataset from the list, if desired.

3. Select the variables containing the data that you want to add to the plot, then click Add .

 Note

Most of the simulation data is in complex format. If you are adding data to a rectangular plot, you must choose
to display the data in one of several scalar formats.

4. You can add data from different datasets to the same plot. Repeat steps two and three to add more data to the
plot.
5. Click OK to view the data.
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1. Select a dataset. 2. Select a variable. 3. Click Add. 4. Selected variables appear
here.

© Note

Multiple graphs within the same view will overlay one another. To view multiple graphs simultaneously, assign
each graph to a separate view.

Viewing S-parameters

Specific information about the data available in the S-parameter datasets is given in the following sections.
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Variables in the Standard and AFS Dataset

Variable Description

freq The independent variable frequency, which was specified
during the simulation setup. The number of data points
is based on the sweep type and frequency plans specified
during simulation.

PORTZ n The impedance of Port n as defined in the Impedance
fields of the Port Editor dialog box. If an impedance is
not specified, 50 ohms is assumed.

S S matrix, normalized to PORTZ n .

S(i,j) S-parameters for each pairing of ports in the circuit,
normalized to PORTZ n .

Standard and AFS Datasets

If the Adaptive sweep type is used for a simulation, two datasets are created for storing data. The first one contains
data computed by the simulator at the frequency points determined during the simulation. (This dataset is the
standard one produced by any simulation.) The second contains data computed by AFS, resampled with a very dense
frequency distribution. This "adaptive" dataset is denoted by _a appended to the dataset name. The adaptive dataset
contains the same variables as the standard dataset, but data is calculated for a significantly greater number of
frequency points.

Typically, when viewing data in the _a dataset, you should see very smooth results, which reflect the behavior of the
circuit. Viewing the standard dataset on the same plot will show the frequency points for which the simulator was
invoked, superimposed on the smooth curve. Those frequency points will be scattered over the whole range, with
relatively more points grouped in areas where the S-parameters show more variation. Viewing both datasets can help
you determine the quality of the AFS process on your simulation. For more information on AFS, refer to About
Adaptive Frequency Sampling.

Viewing Results Using EMDS for ADS Visualization

In EMDS for ADS Visualization, you can display S-parameters in tabular or plotted formats. This chapter describes how
to view and work with S-parameters. It also gives general information about S-parameters.

S-parameter Overview
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When viewing and working with S-parameters, you should be aware how impedance is specified and what naming
convention is used. These are described in the following sections.

Normalization Impedance

The S-parameters that you can display are S-parameters with respect to a normalization impedance as defined in the
Impedance fields of the Port Editor dialog box. If an impedance is not specified, 50 } is assumed.

Naming Convention

The S-parameter naming convention, which is based on the name of the project, indicates which set of S-parameters
you are viewing or working with. There are only two datasets available for a project. One is named design_name
which contains the discrete frequencies that were actually simulated. The second is design_name(afs) is available only
when an adaptive frequency sweep is specified in the simulation setup. An adaptive frequency sweep dataset contains
a high resolution sampling based on the pole-zero model fitted on the simulated frequencies.

Viewing S-parameters in Tabular Format

You can view S-parameters in tabular format. The table displays S-parameter values for each port in these formats:

¢ Magnitude
¢ Real and imaginary components
¢ Magnitude and phase

The table is for viewing data only, you cannot plot data from this table.
S-parameters are displayed as shown here.
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To view S-parameters:

Choose Plot > Matrix.

Sl

Select the data format:

Select the data you want to view from the S Parameters list.
Select the frequency of interest from the Frequencies list. Some S matrices have data at only one frequency.

e *Magnitude * Displays the magnitude of the S-parameters
e *Real/Imag * Displays the S-parameters as complex numbers
e *Mag/Phase * Displays the magnitude and phase of the S-parameters

5. Use the scroll bars to view large matrices.
6. Click OK to dismiss the dialog box.

Plotting S-parameter Magnitude
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The S-parameter magnitude plot displays magnitude in dB with respect to frequency.
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To display an S-parameter magnitude plot:

Choose Plot > Mag Plot.

Select an S matrix from the Matrix List.

Select the S-parameters. The combinations are based on ports.

Select the view where you want to display the plot.

Click Apply.

You can add other S-parameters to the plot, or click Done to dismiss the dialog box.

oA wWNRE

Plotting S-parameter Phase

The S-parameter phase plot displays phase in degrees with respect to frequency. Note that when viewing S-parameter
phase, in some cases the phase delay is plotted. For example, a layout of an electrical length with a phase of 60
degrees, S 21 represents a phase delay, and appears as -60 degrees. For phases greater than 180 degrees, it may
appear that the phase predicted from Gamma compared to S 21 is incorrect, but this is not so if delay is taken into
account.
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To display an S-parameter phase plot:

Choose Plot > Phase Plot.

Select an S matrix from the Matrix List.

Select the S-parameters. The combinations are based on ports.

Select the view where you want to display the plot.

Click Apply.

You can add other S-parameters to the plot, or click Done to dismiss the dialog box.

ok wN=

Plotting S-parameters on a Smith Chart

The Smith chart displays real and imaginary components of S-parameters.
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To display a Smith chart:

Choose Plot > Smith Plot.

Select an S matrix from the Matrix List.

Select the S-parameters.

Select the view where you want to display the plot.

Click Apply.

You can add other S-parameters to the Smith chart, or click Done to dismiss the dialog box.

ouhNE

Exporting S-parameters

S-parameters can be exported to a file, in either Touchstone or CITIfile format. You can export S-parameters to use
with other tools.

To export S-parameters:

Choose File > Export S Matrix .

Select the set of S-parameters to be exported from the Matrix list.

Select the file format, CITIfile or Touchstone.

Specify the file name either by typing the full file path into the File Name field or click Browse.
Click OK to complete the command.

unhwne
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EMDS for ADS Visualization

EMDS for ADS Visualization enables you to view and analyze these types of simulation data:

S-parameters
Currents

far-fields

Antenna parameters
Transmission line data

Data can be analyzed in a variety of 2D and 3D plot formats. Some types of data are displayed in tabular form.

You can view the simulation results from any EMDS for ADS or Agilent EMDS project.
This chapter gives an overview on how to use the EMDS for ADS Visualization. Viewing Results describes in detail how
to use EMDS for ADS Visualization for viewing specific types of data, such as S-parameters or currents.

Starting EMDS for ADS Visualization

To start EMDS for ADS Visualization choose EMDS > Post-Processing > Visualization . The current project must run
through a complete simulation use Visualization to view data. If simulation has been previously completed for a
project, you can start Visualization directly to view the existing data.

Working with EMDS for ADS Visualization Windows

The following figure highlights the basic elements of the EMDS for ADS Visualization window.
For an overview of EMDS for ADS, refer to EMDS for ADS Overview.
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Selecting the Number of Views

By default, the view screen displays a single view. You can optionally display four views. By using four views, you can

display up to four different plots at one time.
To display four views:

e Choose Window > Tile.
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You can enlarge the viewing area by clicking Hide Controls .

To display a single view:

e Choose Window > Full Window . The currently selected view fills the view screen.

Selecting a View to Work In

You must choose from one of the four views to work in. You can change to a different view at any time.

To select a view:

1. Position the mouse in the view and click.

To identify the selected view, note the title of the Plot Type - View list. This will change to identify the selected view.
For example, if you choose View 3, the title will appear as Plot Type - View_3.
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Plot Type - View_ 3 ——— __jocied view

5 Magnitude

To select a view and enlarge it to a single view:

1. Choose Window > Select View.
2. Select a view from the View list.
3. Click OK . The view screen displays the new view.

Setting Preferences for a View

You can set the color preferences for a view, including the background, grid lines, and text along the plot axes.
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To set preferences:
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1. Choose Window > Preferences.

2. Select a color for the background, the text that labels plot axes, and colors of the major and minor axes. The
major axis includes the grid lines with numbers, the minor axis consists of grid lines that appear in between the
numbered ones.

oo L L L1 1]

90 Elii 100 105 110
one ling of the major one line of the mineor

axis axis

3. Click Done to dismiss the dialog box.

Working with Annotation in a View

You can add text to a view, and edit the position and color of the text, by choosing Display > Annotation. You can
save your settings so that they can be reused.
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Adding Text

To add text to a view:

1. Select the view where you want to add text.
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2. Choose Display > Annotation. Drag the Annotation dialog box so that any existing text is in view.

3. Click New Annotation.

4. Type your text into the Annotation Label field. If text already appears in this field, you can delete it and then
type in your text. When you are finished, press the Enter key.

5. Use the X Location and Y Location scroll tools to position the text on the display.

6. Click Done to dismiss the dialog box and view the new text.

Adding Variables

There are three variables that can be added to the annotation: %project% , %view% , and %date% . These variables
can be displayed automatically whenever EMDS for ADS Visualization is in use.

Editing Text
To edit text:
1. Select the view where you want to edit text.
2. Choose Display > Annotation . Drag the annotation dialog box so that any existing text is in view.
3. Select the text that you want to edit from the Annotations field.
4. To adjust the position of the text in the view, use the X Location and Y Location scroll tools.
5. To change the size of the text, use the Annotation Size scroll tool to increase or decrease the font size.
6. To change the thickness of the text characters, use the Annotation Thickness scroll tool to make fine, normal, or

bold-faced characters.

To change the color of the text, select one of the colors listed under Annotation Color.

To change the orientation of the text, Horizontal or Vertical under Orientation.

To change the text, make your changes in the Annotation Label field.

10. To make changes to other lines of text, select the text from the Annotation field and edit as desired.
11. When you are finished, click Done to dismiss the dialog box.

© © N

Deleting Text

To delete text:

Select the view that you want to add text to or edit text.

Choose Display > Annotation . Drag the annotation dialog box so that any existing text is in view.
Select the text that you want to delete from the Annotations field.

Click Delete Annotation .

Click Done to dismiss the dialog box.

uvhwn e
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Retrieving Plots in a View

Multiple plot types can be stored under a single view. Only one plot at a time can be displayed in a view, but any other
plots that you worked with in the view will be saved so that you can view them again.

To retrieve a plot from a view:

e Select a view and either:
° Use the arrows keys on the keyboard to scroll through plots.
° From the Plot Type - View list, select a plot type that you worked with. The plot and all graphical
information that was added to the plot is displayed.

Plot Type - View_3
5 Magnitude

Selectthe plot
that you want to view
from this list.

Refreshing the Window

Choose Window > Refresh at any time to update the displayed views. Typically, the window refreshes automatically
after a command is completed.

Data Overview

You can display these types of data in EMDS for ADS Visualization:

e S-parameters

¢ Electric and magnetic fields

o far-fields

e Antenna parameters

e Transmission line data (gamma and characteristic impedance)

The plots and tables available for viewing this data can be found under these menus.
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Working with Plots and Data

There are many plot types available, plus many types of data to display. This section describes how to work with plots,
such as adding a plot to a view, adding data to a plot, and editing a plot.

Displaying a Plot

EMDS for ADS Visualization is designed so that for each basic type of data, such as S-parameters or currents, there is
a set of plots available for displaying the data. The details for working with each basic data type and the available
plots are in later chapters in this manual.

S-parameter plots

are under the Plot menu Flok

fatrix ...

Part Data ...

5 Mag Plat ..
5 Phase Plotk ...
5 Smith Plat ...
Gamma Plok ...

This will plat magnitude
versus frequency

Impedance Plat ...
Admitkance Plak ...
FFS Error Plak ...

As an example, to display an S-parameter magnitude plot:

1. Choose Plot > S Mag Plot... .
2. Select a matrix and set of S-parameters from the Matrix and S-parameters list. Details about these lists appear
in Variables in the Standard and AFS Dataset.
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1. Select a view from the View list. The plot will appear in this view.

2. Click Apply .

Advanced Design System 2008

Adding Data to a Displayed Plot

Multiple sets of data can be added to a plot:

e For most rectangular plots, you simply repeat the steps that you took to add the plot to the view and choose a
different set of data from the dialog box. If you want to use data from a different project, select the project from

the Projects menu first, then repeat the steps.

e For current plots, you can add items that are listed under the Display menu.
The dialog box below illustrates how to add a second set of S-parameters to an S-parameter magnitude plot.

i Plat 5 Parametens E

Matnix List 5 Parameters
W aweguide S[[Port 11[Pait 1]]
S[[Part TLIPort 2]

data or load data
from a different
project first

usethe same project

select new datato
add to the plot

Vuew_:Z

View

View 3

Wiew_4

| Done

select the same
—— view that the plot
isdisplayed in

Working with Data Controls

Data controls are available for editing the appearance of the following items:
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e S-parameters
The mesh
Currents
Far-fields

To access data controls, select the data from the Graphs list. Click the button that appears above the Graphs list. The
illustration here is an example for S-parameter data or other data that appears on a rectangular plot.

pottype 1§ Magnitude
information about the
selected data is displayed S[(Port 1).(Port 1]]
click to editthe . )
appearance of the Line Properties
data
Graphs

lect data from th — - — —
I e Bl o[(Port 1).Port 1](afs ‘Wavequide]
S[[Port 1).[Port 2]i(afs_Waveguide)
S[(Port 2] [Port 1]](afs_Wavequide]

Data controls include:

e For rectangular plots, you can change the name of the data, the line color, and the line type used to display the
data.

e For current plots, you can alter the appearance of the mesh, or animate currents.
e For far-field plots, you can set the translucency or constant Phi.

Viewing Data from Another Project

The data from any Momentum or Agilent EMDS project can be added to a plot. After you load new projects, you can
select among any of the projects for data to display.
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To load an Momentum project:

Choose Projects > Read Momentum Project... .

Navigate to the folder where the project is saved (project folder) and open the folder.
Under the project folder is another folder named mom_dsn . Open this folder.

Open the folder that contains your specific design.

Double-click on any file within this folder.

uhwN e

To load a new Agilent EMDS project:

Choose Projects > Read Agilent EMDS Project....

. Select the project directory containing the project.

3. Select the project from the Projects list. Note the annotation at the bottom of the list, it will indicate if the
selected project has saved solutions or not.

4. Click OK.

N =

) Note
The project directory and projects brought up by selecting Read Agilent EMDS Project ... are ONLY those
designs that have been opened in the standalone version of EMDS. If no projects have been opened in the
standalone version, the project list will be empty.

To change to a different project:

1. Choose Projects > Select Project.
2. Select a project from the list of Momentum or Agilent EMDS projects.
3. Click Select Momentum or Select Agilent EMDS.

 Note

The title bar of the Agilent EMDS window will display the name of the currently selected project. Data will be
retrieved from this project.

Erasing Data from a Plot

Choose Window > Erase to delete part or all of the data from a plot. When the data is deleted, it is also removed from
the Graph list.

Select the plot from which you want to erase the displayed data.
Choose Window > Erase Plot .

Select the data to be erased.

Click Apply .

Continue to select data and use Apply as needed.

Click Done to dismiss the dialog box.

ouhNE
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Reading Data Values from a Plot
Data for a single point can be retrieved from any plot. The values are displayed near the bottom of the EMDS for ADS
window. The type of data that is returned is based on the plot type. Data is not retrieved from far-field plots.

To read the values of a single data point:

e Position the mouse on the data point of interest and click.

For rectangular plots and Smith charts, the returned values include the data name, and the values along the X and Y

axes of the plot. In some cases, values may be rounded.
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drawing coordinates of the layout.
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Working with Plot Controls

You can use the plot editing controls at the bottom of the EMDS for ADS window to rotate, resize, and move plots to
optimize the view of your data. When you are working with rectangular plots, you can adjust the scale of the plot.

Rotating a Plot

The Rotate command moves a 3D plot in the X, Y, or Z direction. You can rotate Objects and 3D far-field plots only.

To rotate a plot:

1. Click Rotate.
2. Rotate the plot using one of the following methods:
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Position the mouse anywhere on the plot, then drag the mouse up, down, or diagonally to rotate. To fix the
plot position, release the mouse button.

Click Rotation to set X Rotation, Y Rotation, and Z Rotation values using scroll bars. Values range from -180
to 180 degrees.

Click Views to select a predefined view. Choices are Front Angle , Back Angle , Top , Side , or Front.

Scaling a Plot

The Scale command enlarges or shrinks the size of a plot.
To scale a plot:

1. Click Scale.
2. To enlarge the plot, click anywhere on the plot and drag the mouse up or to the right.
3. To make the plot smaller, drag the mouse down or to the left.

Moving the Centerpoint of a Plot

The Pan command moves a plot in the horizontal or vertical direction.
To move a plot:

1. Click Pan.
2. Click anywhere on the plot and drag the mouse to move the plot up, down, left, or right.

Working with Rectangular-plot Editing Controls

Rectangular plots have additional plot controls for:

¢ Adjusting the x and y axes of the plot
e Adjusting the data legend on a plot
Editing the Axes on a Plot

The options in the Graph Properties dialog box enable you to change the range of data that is displayed on a plot, to
increase or decrease the number of lines in the plot grid, and to change the text that appears along each axis.

To change the data range on a plot:
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1. Click Graph Properties.

2. The current boundaries are displayed in the X Axis and Y Axis Min and Max fields. To change the range of
displayed data, type new values into the Min and Max fields for each axis.
3. Press Enter as you make each entry to view its effect on the plot.

To manually scale x, y axes:

1. Click Graph Properties .

2. Enter the number of units per division in the Div field. For example, if Div is set to 20 when Min is 0 and Max is
100, you would see 5 major divisions along the axis.

| I
80 100

3. Enter the number of grid lines in each division in the Ticks field. In the figure above, Ticks is set to 1, so one line
appears in each division.

4. Press Enter as you make each entry to view its effect on the plot.
To automatically scale the axes of a plot:

1. Click Graph Properties.
2. Click Auto Scale to automatically scale the x and y axes of a plot.

To change the text on each axis:

1. Click Graph Properties.
2. Type new text into the X Legend and Y Legend fields.
3. Press Enter as you make each entry to view its effect on the plot.

Editing the Legend

When several sets of data are on a single plot, the legend can help to distinguish the data. The legend displays the
colors used to display the data and the names of the data.

You can move and resize the legend, or erase it. You can also change the name of the data.
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To edit the legend:

Click Legend Properties.

If the dialog box appears to be empty, enable Visible.

Use the X Location and Y Location scroll bars to adjust the position of the legend in the view.
Adjust the font size if the title using Legend Title Size.

Adjust the font size of the data names using Legend Entries Size.

To change the title above the data names, enter a different title in the Legend Title field.
Click Done to dismiss the dialog box.

NouhwnN=

To edit the name of the data:

Select the data from the Graphs list.

Click Line Properties.

Under Line Legend, enter a new name for the data.
Click Done to dismiss the dialog box.

sl

Saving a Plot

You can save plotted data and the plot type to a file. The data types include:

169



Advanced Design System 2008

e S-parameter magnitude or phase
Impedance

Transmission data

Far-field cuts

The file is in ASCII format, so you can use the data in other applications.

You can also import these files directly into EMDS for ADS Visualization. This eliminates the need to read in a project

and then select the project in order to view the data.

To export plotted S-parameters:

1. Choose File > Export Plot Data.

2. Select the type of plot you want to export.

3. Under Plots, select the S-parameters that you want to apply to the plot.

4. Click Browse. Navigate to where you want to save the file and enter a file name. An extension (. hfd ) will be
automatically appended to the file name. Click OK.

5. If you are satisfied with your selections, click Apply . The calculated S-parameters and plot type are written to
the file.

6. Continue to save other sets of S-parameters with other plot types, as desired. Be sure to click Apply so that the
file is generated.

7. When you are finished, click Done to dismiss the dialog box.

8. The file is saved in ASCII format. You can view the file in any text editor.

B dipole_gamma.hfd - Motepad [ _ (O]

Fl= Edit Seach Help
Begin_Block Header -

Hode ASCII
File_Hame C: users-default~dipole_gamma. hfd
Yersion 1.00

End_Block Header

Eegin_Block Data

Graph_Type Gamma

Hane “Gamma[(FPort 1)]{dipole_us)"
Type Frequency

Size 1

. 0000000000000000=—001 0.0000000000000000e+000 3.4735385894775391e+001

End_Block Data

1 ILIﬂ

Importing a Plot

Plots that have been saved to a file in .hfd format can be imported. This eliminates the need to read in a project and
then select the project in order to view the data.
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To import a file:

1. Choose File > Import Plot Data....

Expork Yiew ...

Expork 5 Matkrix ...
Expork Plot Data ...

Impark Plot Data ...

Close ...

2. Click Browse and select the file of interest.
3. The dialog box will display the following information:
¢ File Name -the full path and name of the file
¢ Plot Type Label -the type of plot that is saved in the file
¢ Plot Name Label -the S-parameters that are saved in the file
e Import Name -the name that is assigned by the post processor to the S-parameter plot. This is the name
you will choose when you go to display the plot.
4. Click Apply . Continue importing S-parameter plots as desired.
5. When you are finished loading plot files, click Done .
To view an imported plot:

1. Choose Field > Plot Imported Data....

Set Excitations ...
Plat Fields ...
Plat Imported Data ...

Select a plot type. A list of available plots is displayed.
Select the name of the plot that you want to view.
Select a view.

Click Apply. Continue adding plots to views as desired.
Click Done to dismiss the dialog box.

ouALN

Displaying Fields

In EMDS for ADS Visualization, you can display electric and magnetic fields on cut planes in the geometry. This section
describes how to view fields.

Setting Port Solution Weights

Before displaying a current plot, select a frequency and set the port solution weights for that frequency. Weighting
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port solutions enables you to specify the amount that any one port solution contributes to the solution at a given
frequency. The weighting will be reflected in the current plots.

A Thevenin voltage source (voltage source + source impedance in series) is attached to each circuit port. The source
impedance is either the characteristic impedance for single, differential, and coplanar ports; or 50 ohms for all other
port types. The voltage source amplitude for each port is set to its corresponding solution weight (magnitude +
phase). The displayed currents are those that correspond with this excitation state.

To set port solution weights:

1. Choose Current > Set Port Solution Weights.

2. Select a frequency.

3. Select a port, and enter the magnitude in the Solution Weight field, and enter the phase in the Solution Phase
field.

4. Repeat the previous step for other ports, as necessary for the same frequency.

5. Click OK to complete the command.

Displaying the Layout

An outline of the layout is loaded into a view (if it is missing) when the current plots are displayed. If a layout is not
loaded or if it was deleted, choose Display > Objects to display the layout.

Displaying a Field Plot

The field plot displays surface currents on all objects of the simulated layout. The plot can be animated to illustrate
the fields propagating through the circuit.

) Note

Make sure the layout is loaded into the view. Choose Display > Objects to load the layout if it is missing.

To display a Field plot:

1. Choose Field > Plot Fields.
2. Select the graphical format:
¢ Arrow Plots a vector field quantity using arrows to indicate direction and magnitude.
¢ Contour Displays the "equal magnitude" contours of the vector field.
e Shaded Displays a shaded plot of a magnitude of the vector field quality. The magnitude being plotted is
represented by a range of colors. A color scale showing the range of values also appears on the screen.
e Line Scalar quantities plotted along a line path in a graph. The paths are defined with Define > Line... . The
X-, Y-, and Z-components of vector quantities are plotted as a function of position along the line. For scalar
quantities (i.e. E dl), the scalar value is plotted as a function of position along the line.
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e Surface Scalar quantity plotted as a shaded plot on the intersection of a cut plane with metallic surfaces
e 3D Cloud Scalar quantity plotted as a cloud plot in the entire 3D space. The point density represents the
maximum magnitude of the scalar quantity, while the color represents the phase varying magnitude.
3. Select the view that you want to use to display the plot.
4. Click OK.

Plot Graph Plane YView

E

Mag E

H

Mag H

Mag *[E)

Mag "[H]

Ed

Suilace Cuirent

Poynting Yector

.'-. Iriossy

TR L] L‘fzm ‘-I"H_E
Shaded 2 plare Wisw_3
Ling Wiew_4

Surface
0 Choud

TIWMAIIIIITNT
WYY

1] 4 | Apply | Cancel |

Animating Plotted Currents

The currents have a sinusoidal, or harmonic, time dependence, with steady-state conditions assumed. There is an
implied IEJ' wt time dependence. Animation enables you to visualize the surface currents in the time domain, illustrating

the propagation through a circuit. Changing time corresponds with changing the additional phase introduced by the
ej wt factor. You can change this phase continuously or you can step through the phase changes manually.

To change the phase manually:

e Use the scroll bar. This enables you to freeze the phase in the layout.
To automate the animation:

1. Click Display Properties.
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2. Enable Animate.

3. The currents are animated in time. The animation repeats automatically until Animate is disabled. The speed of
the animation can be changed by editing the Increment field. A larger value speeds the animation, smaller values
slow it down.

4. You can change the maximum value of the color scale. Depending on the selected graphical format, you can
change other options:

e For the shade and contour plots, you can set the translucency, and color of the current.
e For the arrow plot, you can change the length of the arrow vector.

Displaying the Mesh on a Current Plot

Choose Display > Mesh to add the mesh to a current plot.
To display a mesh:

1. Choose Display > Mesh.
2. Select the view displaying the plot to which you want to add the mesh. Meshes can be displayed in Objects only.
3. Click OK to complete the command.

@ Tip
Depending on the drawing order, the mesh may be under the shaded current plot, and not visible. To see the
mesh, lower the translucency of the shaded plot.

Radiation Patterns and Antenna Characteristics

This chapter describes how to calculate the radiation fields. It also provides general information about the antenna
characteristics that can be derived based on the radiation fields.

About Radiation Patterns

Once the currents on the circuit are known, the electromagnetic fields can be computed. They can be expressed in the
spherical coordinate system attached to your circuit as shown in Co-polarization angle. The electric and magnetic
fields contain terms that vary as 1/r, 1/r 2 etc. It can be shown that the terms that vary as 1/r2, 1/r 3, ... are
associated with the energy storage around the circuit. They are called the reactive field or near-field components. The
terms having a 1/r dependence become dominant at large distances and represent the power radiated by the circuit.
Those are called the far-field components (E ff , H ff ).
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© Note

In the direction parallel to the substrate (theta = 90 degrees), parallel plate modes or surface wave modes,
that vary as 1/sqrt(r), may be present, too. Although they will dominate in this direction, and account for a
part of the power emitted by the circuit, they are not considered to be part of the far-fields.

The radiated power is a function of the angular position and the radial distance from the circuit. The variation of power
density with angular position is determined by the type and design of the circuit. It can be graphically represented as
a radiation pattern.

The far-fields can only be computed at those frequencies that were calculated during a simulation. The far-fields will
be computed for a specific frequency and for a specific excitation state. They will be computed in all directions (theta,
phi) in the open half space above and/or below the circuit. Besides the far-fields, derived radiation pattern quantities
such as gain, directivity, axial ratio, etc. are computed.

About Antenna Characteristics

Based on the radiation fields, polarization and other antenna characteristics such as gain, directivity, and radiated
power can be derived.

Polarization

The far-field can be decomposed in several ways. You can work with the basic decomposition in (Eg, Eq:n ). However,

with linear polarized antennas, it is sometimes more convenient to decompose the far-fields into (E co, E cross ) which
is a decomposition based on an antenna measurement set-up. For circular polarized antennas, a decomposition into
left and right hand polarized field components (E |hp , E rhp ) is most appropriate. Below you can find how the
different components are related to each other.
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= > 4 2 > > 2
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E'EI
E
Hy = —,°
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Z.is the characteristic impedance of the open half sphere under consideration.

The fields can be normalized with respect to:

max( "PE'EIP"" |ELP|3]

Circular Polarization

Below is shown how the left hand and right hand circular polarized field components are derived. From those, the
circular polarization axial ratio (AR cp ) can be calculated. The axial ratio describes how well the antenna is circular
polarized. If its amplitude equals one, the fields are perfectly circularly polarized. It becomes infinite when the fields

are linearly polarized.

S

Eihp = J:,

I"EE' —JIEl:P:I
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1. o
AR = |E3-ﬁP|+IEth|

T

Linear Polarization

Below, the equations to decompose the far-fields into a co and cross polarized field are given (g

is the co polarization angle). From those, a "linear polarization axial ratio" (AR Ip ) can be derived. This value
illustrates how well the antenna is linearly polarized. It equals to one when perfect linear polarization is observed and

becomes infinite for a perfect circular polarized antenna.

E, = Egcos(at—@) +E sin(o— )

E = 'L—E.E.]E»iﬂiﬂl—(P]+Eq:,cc:5|;c¢—(p]

cross

IEco| + IEcro.::|
AR, = E

ca| - | cross

© Note

Eco is defined as colinear and Ecross implies a component orthogonal to Eco. For a perfect linear polarized
antenna, Ecross is zero and the axial ratio AR=1. If Ecross = Eco you no longer have linear polarization but

circular polarization, resulting in AR = infinity.

177



Advanced Design System 2008

Ol = co-polarization angle, normally chosen parallel to main
current flow on antenna.

Eco and Ecross are in i0 and i plane (perpendicular to 1,
plane).

Example: 0L = 0 (main current flow on antenna parallel with

x-axes), results in Eco parallel with x-axes for 0- o,P=0

Co-polarization angle

Radiation Intensity

The radiation intensity in a certain direction, in watts per steradian, is given by:

e o= %LEﬁ:{ 0,¢)x H;"f:""l& Q) = EWE'&[‘B‘ nq:u]l2 + IE'P[‘B" q:|]|3]

For a certain direction, the radiation intensity will be maximal and equals:

U, .. =max(U(8,¢))
B¢
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Radiated Power

The total power radiated by the antenna, in Watts, is represented by:

Effective Angle

This parameter is the solid angle through which all power emanating from the antenna would flow if the maximum
radiation intensity is constant for all angles over the beam area. It is measured in steradians and is represented by:

Directivity

Directivity is dimensionless and is represented by:

e o)

DI‘B"(F'I = 4:”: Prad

The maximum directivity is given by:

Umax 4n
SRy i o

Gain
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The gain of the antenna is represented by:

GiB, p) = 4H—ULB~¢']
P.','n_‘i"

where P inj is the real power, in watts, injected into the circuit.

The maximum gain is given by:

Efficiency

The efficiency is given by:

Effective Area

The effective area, in square meters, of the antenna circuit is given by:
w2
) . A ) .
A g8, 0) = 4_1'[G"B‘ ¢

Planar (Vertical) Cut

For the planar cut, the angle phi ( Cut Angle ), which is relative to the x-axis, is kept constant. The angle theta, which
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is relative to the z-axis, is swept to create a planar cut. Theta is swept from 0 to 360 degrees. This produces a view
that is perpendicular to the circuit layout plane. Planar (vertical) cut illustrates a planar cut.

Planar (vertical) cut

 Note

In layout, there is a fixed coordinate system such that the monitor screen lies in the XYplane. The X-axis is
horizontal, the Y-axis is vertical, and the Z-axis is normal to the screen. To choose which plane is probed for a
radiation pattern, the cut angle must be specified. For example, if the circuit is rotated by 90 degrees, the cut
angle must also be changed by 90 degrees if you wish to obtain the same radiation pattern from one

orientation to the next.

Conical Cut

For a conical cut, the angle theta, which is relative to the z-axis, is kept constant. Phi, which is relative to the x-axis,
is swept to create a conical cut. Phi is swept from 0 to 360 degrees. This produces a view that is parallel to the circuit

layout plane. Conical cut illustrates a conical cut.
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Conical cut

Viewing Results Automatically in Data Display

If you choose to view results immediately after the far-field computation is complete, enable Open display when
computation completed . When Data Display is used for viewing the far-field data, a data display window containing
default plot types of the data display template of your choice will be automatically opened when the computation is
finished. The default template, called FarFields, bundles four groups of plots:

Linear Polarization with E co , E cross , AR Ip.
Circular Polarization with E Thp , E rhp , AR cp.
Absolute Fields with EB- ELP‘ H'El- HfP'

Power with Gain, Directivity, Radiation Intensity, Efficiency.

For more information, please refer to About Antenna Characteristics.

Exporting Far-Field Data

If 3D Visualization is selected in the Radiation Pattern dialog, the normalized electric far-field components for the
complete hemisphere are saved in ASCII format in the file < project_dir>/ mom_dsn /<design_name>/ proj.fff . The
data is saved in the following format:
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#Frequency <f> Gz /\* loop over <f> \*/
#Excitati on #<i> /\* loop over <i>\*/
#Begi n cut /\* loop over phi \*/
<theta> <phi _0> <real\(E_theta\)> <imag\(E_theta\)> <real\(E_phi\)> <imag\ (E_phi\)>
I\ * | oop over <theta> \*/
#End cut
#Begi n cut
<theta> <phi _1> <real\(E_theta\)> <imag\(E_theta\)> <real\(E_phi\)> <imag\(E_phi\)>
[\ * | oop over <theta> \*/
#End cut
#Begi n cut
<theta> <phi _n> <real\(E_theta\)> <imag\(E_theta\)> <real\(E_phi\)> <imag\(E_phi\)>
[\ * | oop over <theta> \*/
#End cut

In the proj.fff file, E_theta and E_phi represent the theta and phi components, respectively, of the far-field values of
the electric field. Note that the fields are described in the spherical co-ordinate system (r, theta, phi) and are
normalized. The normalization constant for the fields can be derived from the values found in the proj.ant file and

equals:

J {:E_t}:uﬁ'tn_J:nn.‘:}-2 + {:E_ri}:Li_J:rm.‘:}2

The proj.ant file, stored in the same directory, contains the antenna characteristics. The data is saved in the following
format:

Excitation <i> /\* |oop over <i> \*/

Frequency <f> GHz /\* | oop over <f> \*/

Maxi mum radi ation intensity <U> /\* in Watts/steradian \*/

Angl e of U max <theta> <phi> /\* both in deg \*/

E theta_max <mag\(E_theta_max\)> ; E_phi _max <mag\ (E_phi _max\)>
E theta_nmax <real\(E_theta max\)> <inag\(E_theta_nax\)>

E phi _max <real\(E_phi _max\)> <i mag\ (E_phi _max\) >

Ex_max <real\(Ex_max\)> <i mag\(Ex_nmax\)>

Ey_max <real\(Ey_nax\)> <imag\(Ey_max\)>

Ez_ max <real\(Ez_max\)> <imag\(Ez_max\)>

Power radiated <excitation #i > <prad> /\* in Watts \*/

Ef fective angl e <eff_angle_st> steradi ans <eff_angl e_deg> degrees
Directivity <dir>dB /\* in dB \*/

Gain <gain> dB /\* in dB \*/

The maximum electric field components (E_theta_max, E_phi_max, etc.) are those found at the angular position
where the radiation intensity is maximal. They are all in volts.

Displaying Radiation Results

In EMDS for ADS Visualization, you can view the following radiation data:
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e Far-fields including E fields for different polarizations and axial ratio in 3D and 2D formats

e Antenna parameters such as gain, directivity, and direction of main radiation in tabular format
This section describes how to view the data. In EMDS for ADS RF mode, radiation results are not available for
display. For general information about radiation patterns and antenna parameters, refer to About Radiation
Patterns.

Loading Radiation Results

In EMDS for ADS, computing the radiation results is included as a post processing step. The Far Field menu item
appears in the main menu bar only if radiation results are available. If a radiation results file is available, it is loaded
automatically.

 Note

The command Set Port Solution Weights (in the Current menu) has no effect on the radiation results. The
excitation state for the far-fields is specified in the radiation pattern dialog box before computation.

You can also read in far-field data from other projects. First, select the project containing the far-field data that you
want to view, then load the data:

Choose Projects > Select Project.

Select the name of the Momentum or Agilent EMDS project that you want to use.

Click Select Momentum or Select Agilent EMDS.

Choose Projects > Read Field Solution.

When the data is finished loading, it can be viewed in far-field plots and as antenna parameters.

uhwNe

Displaying Far-fields in 3D

The 3D far-field plot displays far-field results in 3D.
To display a 3D far-field plot:

1. Choose Far Field > Far Field Plot.

2. Select the view in which you want to insert the plot.

3. Select the E Field format:
e E = sqrt(mag(E Theta)2 + mag(E Phi)2)
e E Theta

E Phi

E Left

E Right

Circular Axial Ratio

E Co

E Cross
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e Linear Axial Ratio
4. If you want the data normalized to a value of one, enable Normalize. For Circular and Linear Axial Ratio choices,
set the Minimum dB. Also set the Polarization Angle for E Co, E Cross, and Linear Axial Ratio.
5. By default, a linear scale is used to display the plot. If you want to use a logarithmic scale, enable Log Scale. Set
the minimum magnitude that you want to display, in dB.
6. Click OK .

Selecting Far-field Display Options

You can change the translucency of the far-field and set a constant phi angle:

1. Click Display Options.

2. A white, dashed line appears lengthwise on the far-field. You can adjust the position of the line by setting the
Constant Phi Value, in degrees, using the scroll bar.

Adjust the translucency of the far-field by using the scroll bar under Translucency.

4. Click Done .

w

Defining a 2D Cross Section of a Far-field

You can take a 2D cross section of the far-field and display it on a polar or rectangular plot. The cut type can be either
planar (phi is fixed, theta is swept) or conical (theta is fixed, phi is swept). The figure below illustrates a planar cut (or
phi cut) and a conical cut (or theta cut), and the resulting 2D cross section as it would appear on a polar plot.

The procedure that follows describes how to define the 2D cross section.
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planar cut at phi

=@

conical cut at theta

=9|:|D -

To define a cross section of the 3D far-field:

1. Choose Far Field > Cut 3D Far Field.

If you want a conical cut, choose Theta Cut. If you want a planar cut, choose Phi Cut.

3. Set the angle of the conical cut using the Constant Theta Value scroll bar or set the angle of the planar cut using
the Constant Phi Value scroll bar.

4. Click Apply to accept the setting. The cross section is added to the Cut Plots list.

Repeat these steps to define any other cross sections.

6. Click Done to dismiss the dialog box

N

Ul

Displaying Far-fields in 2D

Once you have defined a 2D cross section of the 3D far-field plot, you can display the cross section on one of these
plot types:

¢ On a polar plot
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e On a rectangular plot, in magnitude versus angle

In the figure below, a cross section is displayed on a polar and rectangular plot.
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To display a 2D far-field plot:

1. Choose Far Field > Plot Far Field Cut .

2. Select a 2D cross section from the 2D Far Field Plots list. The type of cut (phi or theta) and the angle identifies
each cross section.

3. Select the view that you want to use to display the plot.

4. Select the E-field format.

5. Select the plot type, either Cartesian or Polar.

6. If you want the data normalized to a value of one, enable Normalize.

7. By default, a linear scale is used to display the plot. If you want to use a logarithmic scale, enable Log Scale. If
available, set the minimum magnitude that you want to display, in dB; also, set the polarization angle.

8. Click OK.

Displaying Antenna Parameters

Choose Far Field > Antenna Parameters to view gain, directivity, radiated power, maximum E-field, and direction of
maximum radiation. The data is based on the frequency and excitation state as specified in the radiation pattern

dialog. The parameters include:

e Radiated power, in watts
o Effective angle, in degrees
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Directivity, in dB

Gain, in dB

Maximum radiation intensity, in watts per steradian

Direction of maximum radiation intensity, theta and phi, both in degrees
E_theta, in magnitude and phase, in this direction

E_phi, in magnitude and phase, in this direction

e E_X, in magnitude and phase, in this direction

E_y, in magnitude and phase, in this direction

E_z, in magnitude and phase, in this direction

© Note

In the antenna parameters, the magnitude of the E-fields is in volts.

Theory of Operation for EMDS for ADS

The simulation technique used to calculate the full three-dimensional electromagnetic field inside a structure is based
on the finite element method. Although its implementation is largely transparent, a general understanding of the
method is useful in making the most effective use of Electromagnetic Design System (EMDS) for Advanced Design
System (ADS).

This section provides an overview of the finite element method, its implementation in EMDS for ADS, and a description
of how S-parameters are computed from the simulated electric and magnetic fields.

The Finite Element Method

To generate an electromagnetic field solution from which S-parameters can be computed, EMDS for ADS employs the
finite element method. In general, the finite element method divides the full problem space into thousands of smaller
regions and represents the field in each sub-region (element) with a local function.

In EMDS for ADS, the geometric model is automatically divided into a large number of tetrahedra, where a single
tetrahedron is formed by four equilateral triangles.

Representation of a Field Quantity

The value of a vector field quantity (such as the H-field or the E-field) at points inside each tetrahedron is interpolated
from the vertices of the tetrahedron. At each vertex, EMDS for ADS stores the components of the field that are
tangential to the three edges of the tetrahedron. In addition, the component of the vector field at the midpoint of
selected edges that is tangential to a face and normal to the edge can also be stored. (See Field Quantities are
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Interpolated from Nodal Values). The field inside each tetrahedron is interpolated from these nodal values.

The components of a fiell that ave
tangential to the slges of an element
are explicitly stored at the vertices.

The component of a field that iz
tandential to the face ofan element
anid mormalte an edge iz explicitly
= W iorel at the mid point of the selsctal

edzem.

The value of a vectar field at an
interior point iz interpolated from
the nodal values.

Field Quantities are Interpolated from Nodal Values

The components of a field that are tangential to the edges of an element are explicitly stored at the vertices.
The component of a field that is tangential to the face of an element and normal to an edge is explicitly stored at the
midpoint of the selected edges.

The value of a vector field at an interior point is interpolated from the nodal values.
By representing field quantities in this way, Maxwell's equations can be transformed into matrix equations that are
solved using traditional humerical methods.

Basis Functions

A first-order tangential element basis function interpolates field values from both nodal values at vertices and on

edges. First-order tangential elements, like those shown in Field Quantities are Interpolated from Nodal Values, have

20 unknowns per tetrahedra. (For simplicity, all 20 elements are not shown in Field Quantities are Interpolated from
Nodal Values.)

Size of Mesh Versus Accuracy

There is a trade-off between the size of the mesh, the desired level of accuracy, and the amount of available
computing resources.
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On one hand, the accuracy of the solution depends on how small each of the individual elements (tetrahedra) are.
Solutions based on meshes that use a large number of elements are more accurate than solutions based on coarse
meshes using relatively few elements. To generate a precise description of a field quantity, each tetrahedron must
occupy a region that is small enough for the field to be adequately interpolated from the nodal values.

On the other hand, generating a field solution for meshes with a large number of elements requires a significant
amount of computing power and memory. Therefore, it is desirable to use a mesh that is fine enough to obtain an
accurate field solution but not so fine that it overwhelms the available computer memory and processing power.

To produce the optimal mesh, EMDS for ADS uses an iterative process in which the mesh is automatically refined in
critical regions. First, it generates a solution based on a coarse initial mesh. Then, it refines the mesh based on
suitable error criteria and generates a new solution. When selected S-parameters converge to within a desired limit,
the iteration process ends.

Field Solutions

During the iterative solution process, the S-parameters typically stabilize before the full field solution. Therefore, when
you are interested in analyzing the field solution associated with a structure, it may be desirable to use convergence
criteria that is tighter than usual.

In addition, for any given number of adaptive iterations, the magnetic field (H-field) is less accurate than the solution
for the electric field (E-field) because the H-field is computed from the E-field using the following relationship:

H - ?IXE
~Jop

thus making the polynomial interpolation function an order lower than those used for the electric field.

Implementation Overview

To calculate the S-matrix associated with a structure, the following steps are performed:

1. The structure is divided into a finite element mesh.

2. The waves on each port of the structure that are supported by a transmission line having the same cross section
as the port are computed.

3. The full electromagnetic field pattern inside the structure is computed, assuming that each of the ports is excited
by one of the waves.

4. The generalized S-matrix is computed from the amount of reflection and transmission that occurs.
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The final result is an S-matrix that allows the magnitude of transmitted and reflected signals to be computed directly
from a given set of input signals, reducing the full three-dimensional electromagnetic behavior of a structure to a set
of high frequency circuit values.

The Solution Process

There are three variations to the solution process:

e Adaptive solution
¢ Non-adaptive discrete frequency sweep
¢ Non-adaptive fast frequency sweep

Adaptive Solution

An adaptive solution is one in which a finite element mesh is created and automatically refined to increase the
accuracy of succeeding adaptive solutions. The adaptive solution is performed at a single frequency. (Often, this is the
first step in generating a non-adaptive frequency sweep or a fast frequency sweep.).

Non-adaptive Discrete Frequency Sweep

To perform this type of solution, an existing mesh is used to generate a solution over a range of frequencies. You
specify the starting and ending frequency, and the interval at which new solutions are generated. The same mesh is
used for each solution, regardless of the frequency.

Non-adaptive Fast Frequency Sweep

This type of solution is similar to a discrete frequency sweep, except that a single field solution is performed at a
specified center frequency. From this initial solution, the system employes asymptotic waveform evaluation (AWE) to
extrapolate an entire bandwidth of solution information. While solutions can be computed and viewed at any
frequency, the solution at the center frequency is the most accurate.

The Mesher
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A mesh is the basis from which a simulation begins. Initially, the structure's geometry is divided into a number of
relatively coarse tetrahedra, with each tetrahedron having four triangular faces. The mesher uses the vertices of
objects as the initial set of tetrahedra vertices. Other points are added to serve as the vertices of tetrahedra only as
needed to create a robust mesh. Adding points is referred to as seeding the mesh.

After the initial field solution has been created, if adaptive refinement is enabled, the mesh is refined further.

2D Mesh Refinement

For 2D objects or ports, the mesher treats its computation of the excitation field pattern as a two-dimensional finite
element problem. The mesh associated with each port is simply the 2D mesh of triangles corresponding to the face of
tetrahedra that lie on the port surface.

The mesher performs an iterative refinement of this 2D mesh as follows:

1. Using the triangular mesh formed by the tetrahedra faces of the initial mesh, solutions for the electric field, E,
are calculated.

2. The 2D solution is verified for accuracy.

3. If the computed error falls within a pre-specified tolerance, the solution is accepted. Otherwise, the 2D mesh on
the port face is refined and another iteration is performed.
Any mesh points that have been added to the face of a port are incorporated into the full 3D mesh.

The 2D Solver

Before the full three-dimensional electromagnetic field inside a structure can be calculated, it is necessary to
determine the excitation field pattern at each port. The 2D solver calculates the natural field patterns (or modes) that
can exist inside a transmission structure with the same cross section as the port. The resulting 2D field patterns serve
as boundary conditions for the full three-dimensional problem.

Excitation Fields

The assumption is that each port is connected to a uniform waveguide that has the same cross section as the port.
The port interface is assumed to lie on the z=0 plane. Therefore, the excitation field is the field associated with
traveling waves propagating along the waveguide to which the port is connected:

Exy.z.t) = Re[E(xy ]C;‘mt—.}':]
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where:

Re is the real part of a complex number or function.
E(x,y) is a phasor field quantity.

j is the imaginary unit, [

w is angular frequency, 2nf.
y=a + j B is the complex propagation constant, a is the attenuation constant of the wave.

B is the propagation constant associated with the wave that determines, at a given time t , how the phase angle
varies with z.

In this context, the x and y axes are assumed to lie in the cross section of the port; the z axis lies along the direction
of propagation.

Wave Equation

The field pattern of a traveling wave inside a waveguide can be determined by solving Maxwell's equations. The
following equation that is solved by the 2D solver is derived directly from Maxwell's equation.

V % [”i? x E(xy ]\:I —kécrEixJ‘] =0

r

where:

E(x,y) is a phasor representing an oscillating electric field.
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k 0 is the free space wave number, ,
%/ Hofo

w is the angular frequency, 2nf.
pr( X, y ) is the complex relative permeability.

&epsilon;r( x, y ) is the complex relative permittivity.

To solve this equation, the 2D solver obtains an excitation field pattern in the form of a phasor solution, E(x,y) . These
phasor solutions are independent of z and t ; only after being multiplied by e-y z do they become traveling waves.

Also note that the excitation field pattern computed is valid only at a single frequency. A different excitation field
pattern is computed for each frequency point of interest.

Modes

For a waveguide or transmission line with a given cross section, there is a series of basic field patterns (modes) that
satisfy Maxwell's equations at a specific frequency. Any linear combination of these modes can exist in the waveguide.

Modes, Reflections, and Propagation

It is also possible for a 3D field solution generated by an excitation signal of one specific mode to contain reflections of
higher-order modes which arise due to discontinuities in a high frequency structure. If these higher-order modes are
reflected back to the excitation port or transmitted onto another port, the S-parameters associated with these modes
should be calculated.

If the higher-order mode decays before reaching any port-either because of attenuation due to losses or because it is
a non-propagating evanescent mode-there is no need to obtain the S-parameters for that mode. Therefore, one way
to avoid the need for computing the S-parameters for a higher-order mode is to include a length of waveguide in the
geometric model that is long enough for the higher-order mode to decay.

For example, if the mode 2 wave associated with a certain port decays to near zero in 0.5 mm, then the "constant
cross section" portion of the geometric model leading up to the port should be at least 0.5 mm long. Otherwise, for
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accurate S-parameters, the mode 2 S-parameters must be included in the S-matrix.

The length of the constant cross section segment to be included in the model depends on the value of the mode's
attenuation constant, a.

Modes and Frequency

The field patterns associated with each mode generally vary with frequency. However, the propagation constants and
impedances always vary with frequency. Therefore, when a frequency sweep has been requested, a solution is
calculated for each frequency point of interest.

When performing frequency sweeps, be aware that as the frequency increases, the likelihood of higher-order modes
propagating also increases.

Modes and Multiple Ports on a Face

Visualize a port face on a microstrip that contains two conducting strips side by side as two separate ports. If the two
ports are defined as being separate, they are treated as two ports are connected to uncoupled transmission
structures. It is as if a conductive wall separates the excitation waves.

However, in actuality, there will be electromagnetic coupling between the two strips. The accurate way to model this
coupling is to analyze the two ports as a single port with multiple modes.

The 3D Solver

To calculate the full 3D field solution, the following wave equation is solved:

Vo [”i? X.El;x.‘j-'.,a']\:l —kécrEl;x.j-',z] =0

r

where:

E(x,y,z) is a complex vector representing an oscillating electric field.
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mr( x, y ) is the complex relative permeability.

k 0 is the free space phase constant, ,
“/Hogo

w is the angular frequency, 2nf.

&epsilon;r( x, y ) is the complex relative permittivity.

This is the same equation that the 2D solver solves for in calculating the 2D field pattern at each port. The difference
is that the 3D solver does not assume that the electric field is a traveling wave propagating in a single direction. It
assumes that the vector E is a function of x, y, and z. The physical electric field, E(x,y,z,t) , is the real part of the
product of the phasor, E(x,y,z) , and &epsilon; jw t:

Eixyz.t) = Re[E(xy.z ]ijt]

Boundary Conditions

EMDS for ADS imposes boundary conditions at all surfaces exposed to the edge of the meshed problem region. This
includes all outer surfaces and all surfaces exposed to voids and surface discontinuities within the structure.
The following types of boundary conditions are recognized by the 3D solver:

e Port

e Perfect H

e Symmetric H
e Perfect E

e Symmetric E
e Ground plane
e Conductor

e Resistor

e Radiation

e Restore

Port Boundaries
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The 2D field solutions generated by the 2D solver for each port serve as boundary conditions at those ports. The final
field solution that is computed for the structure must match the 2D field pattern at each port.

EMDS for ADS solves several problems in parallel. Consider the case of analyzing modes 1 and 2 in a two-port device.
To compute how much of a mode 1 excitation at port 1 is transmitted as a mode 2 wave at port 2, the 3D mesher
uses the following as boundary conditions:

e A "mode 1" field pattern at port 1.
e A "mode 2" field pattern at port 2.

To compute the full set of S-parameters, solutions involving other boundary conditions must also be solved. Because
the S-matrix is symmetric for reciprocal structures (thatis, S 12 is the same as S 21 ), only half of the S-parameters
need to be explicitly computed.

Perfect H Boundaries

A Perfect H boundary forces the magnetic field (H-field) to have a normal component only. A symmetric H boundary
can be used to model a plane of symmetry for a mode in which the H-field is normal to the symmetry plane.

Perfect E Boundaries

By default, the electric field is assumed to be normal to all surfaces exposed to the background, representing the case
in which the entire structure is surrounded by perfectly conducting walls. This is referred to as a Perfect E boundary.
The final field solution must match the case in which the tangential component of the electric field goes to zero at
Perfect E boundaries.

It is also possible to assign Perfect E boundaries to surfaces within a structure. Using Perfect E boundaries in this way
enables users to model perfectly conducting surfaces. The surfaces of all objects that have been defined to be
perfectly conducting materials are automatically assigned to be Perfect E boundaries.

Conductor Boundaries

Conductor boundaries can be assigned to surfaces of imperfect conductors or resistive loads such as thick film
resistors. At such boundaries, the following condition holds:

E._ =Z_(nxH)

197



Advanced Design System 2008

where:

o

is the is the unit vector that is normal to the surface.

E tan is the component of the E-field that is tangential to the surface.

H is the H-field.

Z s is the surface impedance of the boundary. (1+ j )/(d0).

0 is the skin depth, 2/ WGL) / of the conductor being modeled.

w is the frequency of the excitation wave.

o is the conductivity of the conductor.

The fact that the E-field has a tangential component at the surface of imperfect conductors simulates the case in
which the surface is lossy. The amount of loss will be proportional to the component of E x H

that flows into the surface.

The field inside these objects is not computed; the conductor boundary approximates the behavior of the field at the
surfaces of the objects.

Resistor Boundaries

Resistor boundaries model surfaces that represent resistive loads such as thin films on conductors. The following
condition holds at resistor boundaries:
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E, = R(nxH)

where:

E tan is the component of the E-field that is tangential to the surface.

H is the H-field.

R is the resistance at the boundary in ohms per square meter.

Radiation Boundaries

Radiation boundaries model surfaces that represent open space. Energy is allowed to radiate from these boundaries
instead of being contained within them. At these surfaces, the second order radiation boundary condition is employed:

(v '{E].'un :uil.kDEmﬂ_I{T:lv (¥ ""E]n+£‘|—:‘vun[vm'l 'Eun]

where:

E tan is the component of the E-field that is tangential to the surface.

o

is the unit vector normal to the radiation surface.

k 0 is the free space phase constant, .
“Hofo
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jisequalto [ 7.

To ensure accurate results, radiation boundaries should be applied at least one quarter of a wavelength away from the
source of the signal. However, they do not have to be spherical. The only restriction regarding their shape is that they
be convex with regard to the radiation source.

Computing Radiated Fields

Electromagnetic Design System maps the E-field computed by the 3D solver on the radiation surfaces to plane
registers and then calculates the radiated E-field using the following equation:

VG ds

Rarma

Eixyz) = [(jjuugH )G+ (E,, % VG +(E

where:

s represents the radiation surfaces.

j is the imaginary unit, [ 1.

w is the angular frequency, 2nf.

MO is the relative permeability of the free space.

H tan is the component of the magnetic field that is tangential to the surface.

H normal is the component of the magnetic field that is normal to the surface.
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E tan is the component of the electric field that is tangential to the surface.
G is the free space Green's Function, given by:

c—jk,:,l} -r
Q=

- - “
|r—71

where:

k 0 is the free space wave number, ”-"E:u'

rand p represent, respectively, points on the radiation surface and points beyond the surface as shown in

mplementing Green's Function When Computing Radiated Fields.

I

z
A
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s —
itheta is an = A . t
independent | i
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!
-
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il N 7\-\ ¥

Implementing Green's Function When Computing Radiated Fields

201


http://edocs.soco.agilent.com/display/ads2008/Theory+of+Operation+for+Digital+Predistortion#TheoryofOperationforDigitalPredistortion-1110714

Advanced Design System 2008

Displaying Field Solutions

The 3D solver is also used to manipulate field quantities for display. The system enables you to display or manipulate
the field associated with any excitation wave at any port-for example, the field inside the structure due to a discrete
mode 2 excitation wave at port 3. Waves excited on different modes can also be superimposed, even if they have
different magnitudes and phases-for example, the waves excited on mode 1 at port 1 and mode 2 at port 2. In
addition, far-field radiation in structures with radiation boundaries can be displayed.

The available fields depend on the type of solution that was performed:

e For adaptive solutions, the fields associated with the solution frequency are available.
e For frequency sweeps, the fields at each solved frequency point are available.
e For fast frequency sweeps, the fields associated with the center frequency point are initially available.

Ports-only Solutions and Impedance Computations

This section addresses how impedances are computed for multi-conductor transmission line ports. Some examples of
such structures are:

e Two coupled microstrip lines
e Coplanar waveguide modeled with 3 separate strips
e Shielded twin-wire leads

For structures with one or two conductors, you will need to define a single line segment, called an "impedance line",
for each mode. Some examples of such structures include:

e microstrip transmission line (two-conductor structure)
e grounded CPW (two-conductor structure) where the CPW ground fins are also attached to the OUTER ground

For these structures, the port solver will compute the voltage V along the impedance line which is used to calculate Z
pv =V 2 /(2*¥Power). The power is always normalized to 1 Watt.

If one models N-conductor structures where N>2, then EMDS for ADS uses a different algorithm for computing Z pv
and Z pi . The user must define an impedance line for each interior conductor. The impedance lines should go from the
center of each interior conductor to the outer conductor.

The port solver computes a voltage along the first N line segments for each of the first N modes when the port solver
detects that there are N+1 conductors. This becomes a "voltage vector" 1}

(of length N) for each of the N quasi-TEM modes. Then, when computing Z pv , the square of the scalar voltage is now
replaced by the dot product of the voltage vectors, for example:
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For a more detailed explanation as to why this is done, refer to reference [1] at the end of this section.

For Z pi , the current is generally computed by adding the currents flowing into and out of the port and taking the
average of the two. (If the simulator computed currents to perfect accuracy, the inward and outward currents would
be identical.) For all mode numbers >= N, where N = number of conductors, the currents are calculated in this way.
For the first (N-1) quasi-TEM modes, the currents are computed on the N-1 interior conductors producing a current
eigenvector. Then the impedance:

Zpi = I;E-Powcr]x’l;}tj]

The result is that the EMDS for ADS impedance computations for such structures as coupled microstrip lines match the
published equations for even- and odd-mode impedances.

As an example, take a CPW modeled as three interior strips surrounded by an enclosure. The ground strips do not
touch the enclosure. Such a model is in the examples directory of EMDS for ADS and is called cpwtaper . The port
solver shows us that the desired CPW mode is not the dominant mode, but is actually mode 3. To identify the modes,
one can use the arrow plots in the Port Calibration menu or the Arrow display of the E-field in the post processor.

Each port consists of a 4 conductor system, the outer (ground) conductor, the inner strip, and the two "ground" strips.
This results in 3 quasi-TEM modes. Mode 1 has E-field lines predominately in the substrate, all pointing in the same
direction. This is the common mode (+V, +V, +V). Mode 2 also has E-field lines predominately in the substrate, but in
opposite directions under the two "ground" strips. This is the slot mode (-V, 0, +V). Mode 3 has nearly zero E-fields
everywhere because the fields are predominately between the inner strip and the "ground" strips. This is the CPW
mode (0, +V, 0).

For further help in identifying modes in such a structure, one can look at the distributions with the "full" scale. One will
notice that modes 1 and 3 obviously have the same "even" symmetry in the E fields, while mode 2 has an odd
symmetry. The CPW mode has an "even" symmetry, so it has to be mode 1 or 3.

Modes 1 and 2 have significant E-field strengths in the substrate, especially under the "ground" strips. So, there is a
potential difference between the "ground" strips and the outer ground for these two modes. However, for mode 3, the
"ground" strips are at the same potential as the outer ground, which is consistent with the CPW mode.

Thus one can identify the modes. For mode 3, the "ground" strips are at 0 volts with respect to the outer ground, and
the signal line has +V. The Z pv impedance computed for this mode using a dot product of the voltage vector for
mode 3 gives the same Z pv as by computing the simple voltage between center strip and either "ground" strip. That
is because the voltage vector for mode 3 along the three impedance lines is 1} =[0,V,0] and

V.V=1[0,V,0]-[0,V.0] = 0-0+V°40.0 = V°
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However, the impedances for the other modes now match accepted impedance definitions found in the literature for
multi-conductor transmission lines.

1. G.G. Gentili and M. Salazar-Palma, "The definition and computation of modal characteristic impedance in
quasi-TEM coupled transmission lines," IEEE Trans. Microwave Theory Tech., Feb. 1995, pp. 338-343.

Calculating S-Parameters

A generalized S-matrix describes what fraction of power associated with a given field excitation is transmitted or
reflected at each port.

The S-matrix for a three port structure is shown below:

b, 811815 Sy5) e

byl = |85 813 Sa3] @y

'53 331 333 333 &3
where:

All quantities are complex numbers.

The magnitudes of a and b are normalized to a field carrying one watt of power.

|ai| 2 represents the excitation power at port i.

|bi | 2 represents the power of the transmitted or reflected field at port i.

The full field pattern at a port is the sum of the port's excitation field and all reflected/transmitted fields.
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represents the phase angle of the excitation field on port i at t=0. (By default, it is zero.)
£b;

represents the phase angle of the reflected or transmitted field with respect to the excitation field.

S ij is the S-parameter describing how much of the excitation field at port j is reflected back or transmitted to port i.

For example, S 31 is used to compute the amount of power from the port 1 excitation field that is transmitted to port
3. The phase of S 31 specifies the phase shift that occurs as the field travels from port 1 to port 3.

© Note

When the 2D solver computes the excitation field for a given port, it has no information indicating which way is
"up" or "down". Therefore, if ports have not been calibrated, it is possible to obtain solutions in which the
S-parameters are out of phase with the expected solution.

Frequency Points

The S-parameters associated with a structure are a function of frequency. Therefore, separate field solutions and
S-matrices are generated for each frequency point of interest. EMDS for ADS supports two types of frequency sweeps:

¢ Discrete frequency sweeps, in which a solution is generated for the structure at each frequency point you specify.
e Fast frequency sweeps, in which asymptotic waveform evaluation is used to extrapolate solutions for a range of
frequencies from a single solution at a center frequency.

Fast frequency sweeps are useful for analyzing the behavior of high Q structures. For wide bands of information, they
are much faster than solving the problem at individual frequencies.

 Note

Within a fast frequency solution, there is a bandwidth where the solution results are most accurate. This range
is indicated by an error criterion using a matrix residue that measures the accuracy of the solution. For
complex frequency spectra that have many peaks and valleys, a fast sweep may not be able to accurately
model the entire frequency range. In this case, additional fast sweeps with different expansion frequencies will
automatically be computed and combined into a single frequency response.

205



Advanced Design System 2008

Renormalized S-Matrices

Before a structure's generalized S-matrix can be used in a high frequency circuit simulator to compute the reflection
and transmission of signals, the generalized S-matrix must be normalized to the appropriate impedance. For example,
if a generalized S-matrix has been normalized to 50 ohms, it can be used to compute reflection and transmission

directly from signals that are normalized to 50 ohms, as in:

Vo, Vi
Vos| = [Sso]a|Vi,
VG‘3 Vn!-}

where the input signals, Vi i, and output signals, Vo i , are both normalized to 50 ohms.

To renormalize a generalized S-matrix to a specific impedance, the system first calculates a unique impedance matrix
associated with the structure. This unique impedance matrix, Z, is defined as follows:

Z = JZfI-8)"1+8),/Z,

where:

S is the n x n generalized S-matrix.

I is an n x n identity matrix.

Z 0 is a diagonal matrix having the characteristic impedance (Z 0 ) of each port as a diagonal value.

The renormalized S-matrix is then calculated from the unique impedance matrix using this relationship:

So = JYalZ-Zo)Z+Zy) " fTq

where:
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Z is the structure's unique impedance matrix.

ZQ and YD are diagonal matrices with the desired impedance and admittance as diagonal values. For example,

if the matrix is being renormalized to 50 ohms, then Zﬂ would have diagonal values of 50.

Visualize the generalized S-matrix as an S-matrix that has been renormalized to the characteristic impedances of the
structure. Therefore, if a diagonal matrix containing the characteristic impedances of the structure is used as ZD in

the above equation, the result would be the generalized S-matrix again.

Z- and Y-Matrices

Calculating and displaying the unique impedance and admittance matrices (Z and Y) associated with a structure is
performed in the post processor.

Characteristic Impedances

EMDS for ADS calculates the characteristic impedance of each port in order to compute a renormalized S-matrix,
Z-matrix, or Y-matrix. The system computes the characteristic impedance of each port in three ways-as Z pi , Z pv,
and Z vi impedances.

You have the option of specifying which impedance is to be used in the renormalization calculations.

PI Impedance

The Z pi impedance is the impedance calculated from values of power (P) and current (I):

2P

Zei = o1

The power and current are computed directly from the simulated fields. The power passing through a port is equal to
the following:
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P = 1{ExHds

where the surface integral is over the surface of the port.

The current is computed by applying Ampere's Law to a path around the port:

I:ﬁH-ﬂ
{

While the net current computed in this way will be near zero, the current of interest is that flowing into the structure, I

- or that flowing out of the structure, I + . In integrating around the port, the system keeps a running total of the
contributions to each and uses the average of the two in the computation of impedances.

PV Impedance

The Z pv impedance is the impedance calculated from values of power (P) and voltage (V):

where the power and voltage are computed directly from the simulated fields. The power is computed in the same way
as for the Z pi impedance. The voltage is computed as follows:

V:§E-ﬂ
{

The path over which the system integrates is referred to as the impedance line, which is defined when setting up the
ports. To define the impedance line for a port, select the two points across which the maximum voltage difference

occurs. EMDS for ADS cannot determine where the maximum voltage difference will be unless you define an
impedance line.
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VI Impedance

The Z vi impedance is given by:

For TEM waves, the Z pi and Z pv impedances form upper and lower boundaries to a port's actual characteristic
impedance. Therefore, the value of Z vi approaches a port's actual impedance for TEM waves.

Choice of Impedance

When the system is instructed to renormalize the generalized S-matrix or compute a Y- or Z-matrix, you must specify
which value to use in the computations, Z pi, Z pv, or Z vi.

For TEM waves, the Z vi impedance converges on the port's actual impedance and should be used.
When modeling microstrips, it is sometimes more appropriate to use the Z pi impedance.

For slot-type structures (such as finline or coplanar waveguides), Z pv impedance is the most appropriate.

De-embedding

If a uniform length of transmission line is added to (or removed from) a port, the S-matrix of the modified structure
can be calculated using the following relationship:

[Sj - [CT{I [S] [c"‘ﬂ

where:

is a diagonal matrix with the following entries:
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I
"0
d.
0 7% 0
0 0 CT}E}

y = a + jB is the complex propagation constant, where:

ai is the attenuation constant of the wave of port i.

Bi is the propagation constant associated with the uniform transmission line at port i.

| i is the length of the uniform transmission line that has been added to or removed from the structure at port i.
A positive value indicates that a length of transmission line has been removed from the structure.

The value of y for the dominant mode of each port is automatically calculated by the 2D solver.

Equations

The sections below describe some of the equations that are solved in a simulation or used to define elements of a
structure.

Derivation of Wave Equation

The solution to the following wave equation is found during a simulation:

?x[}%?xE\:I—kéErE =0

where:

E( x,y,z ) is a phasor representing an oscillating electric field

k 0 is the free space wave number, .
“Hofo

w is the angular frequency, 2nf.
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pr( x,y,z ) is the complex relative permeability.
&epsilon;r( x,y,z ) is the complex relative permittivity.

The difference between the 2D and 3D solvers is that the 2D solver assumes that the electric field is a traveling wave

with this form:
Wt -y
Eixyzt) = Rc[El;x._}']cUm v ]]
while the 3D solver assumes that the phasor E is a function of x, y, and z:

E(xyzt) = RE(xyz)e™]

Maxwell's Equations

The field equation solved during a simulation is derived from Maxwell's Equations, which in their time-domain form

are:
VxH(t) = JH]+%D(#]
. d e
VxE(t) = —B(t)
dt
VeDit) =p
VeB(t) =10
where:

E (t) is the electric field intensity.

D (t) is the electric flux density, &epsilon; E (t), and &epsilon; is the complex permittivity.

211



Advanced Design System 2008

H (t) is the magnetic field intensity.
B (t) is the magnetic flux density, g H (t), and u is the complex permeability.
J (t) is the current density, o E (t).

p is the charge density.

Phasor Notation

Because all time-varying electromagnetic quantities are oscillating at the same frequency, they can be treated as
phasors multiplied by e j w t (in the 3D solver) or by e j w t -y z (in the 2D solver).
In the general case with the 3D solver, the equations become:

VxHSY = JJ + Lp™
dt
VxEJY = LB
dt

ot ot
VeDd™ = pd
VeBd™ =0

By factoring out the quantity e j w t and using the following relationships:

iEc‘rmt = ijc“‘mi
it

H

dt

(=]

= joH

Maxwell's Equations in phasor form reduce to:
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VxH = J+joE

VxE = —J[!).B
VeD =p
VeB =0

where B, H, E, and D are phasors in the frequency domain. Now, using the relationships B = p H, D = &epsilon; E,
and J = a E, Maxwell's Equations in phasor form become:

VxH = joe+o)E = jlowe)E

fora=0
VxH=jowE
VerE = p
VepuH =10

where H and E are phasors in the frequency domain, p is the complex permeability, and &epsilon; is the complex
permittivity.

H and E are stored as phasors, which, as illustrated in Electric and Magnetic Fields Can Be Represented as Phasors,
can be visualized as a magnitude and phase or as a complex quantity.

Imaginary

phasor rotating
at angular frequency
of (W

213


http://edocs.soco.agilent.com/display/ads2008/Theory+of+Operation+for+Digital+Predistortion#TheoryofOperationforDigitalPredistortion-1113849

Advanced Design System 2008

Electric and Magnetic Fields Can Be Represented as Phasors

Assumptions

To generate the final field equation, place H in the equation in terms of E to obtain:

H- L v«E

Jop

Then, substitute this expression for H in the ¥ x H equation to produce:

V x L—,L? xE\:I = joeE
jop T

Conductivity

Although good conductors can be included in a model, the system does not solve for any fields inside these materials.
Because fields penetrate lossy conductors only to one skin depth (which is a very small distance in good conductors),
the behavior of a field can be represented with an equivalent impedance boundary.

For perfect conductors, the skin depth is zero and no fields exist inside the conductor. Perfect conductors are assumed
to be surrounded with Perfect E boundaries.

Dielectric Loss Tangent

Dielectric losses can be modeled by assuming that the relative permittivity, £ is complex:
r

# ¥

E = £ —E
Expressed in terms of the dielectric (electric) loss tangent, thE = E”r;'ga“r] , the complex relative permittivity,
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g, becomes:

g = g "—Jjg, tand,

Magnetic Loss Tangent

Losses in magnetic materials can be modeled by assuming that pr is complex.

-

e = W1 —Ju,

¥

Expressed in terms of the magnetic loss tangent, ;p”r ]x"(p_“r] , the complex relative permeability becomes:

ﬂr = ”raLl —J::llr.- ;| = ”r"l;l _J'tmam]

r

Definition of Freespace Phase Constant

Using the relationships g = £qE, and || = Hold, the wave equation being solved can be placed in this form:

V x [:—? XE;I - mzugeﬂarE =0

Now, if the freespace phase constant (or wave number) is defined as, E 2 , the above reduces to:
o

.
= O lpEg

V x ?XETI—&E)EYE:U

1
B,

AT
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which is the equation that the 2D and 3D engines solve.
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